Curious case of Waydroid (on Librem 5)

Referring to this video^tfw|twcamp^tweetembed|twterm^1565028370370502665|twgr^db40d7775a915874253bf7b4504482551ea1bbe8|twcon^s1_ from @dos that shows Waydroid working and working well, on Librem 5. It was posted on 31st August, 2022.

So far, there has been no announcement from Purism about it. But that was not the case with Anbox. Although Anbox did not work so well, @david.hamner and Purism were quick to announce that “Anbox now works on Librem 5”.

Even though there are specific instructions available at on how to install and configure Waydroid on Librem 5, @david.hamner, is there any specific reason for this deafening silence on Waydroid?

@buzzLightyear I think that the key operative expression in that tw**t is:

is looking pretty good!

It did not stated; “it is ready to be safely used by someone that is not a developer.”

There is a difference between: the developer that is working on it got it to run decently with several hacks and downstream patches, compiling stuff, dealing with all the different software bits from different projects that need work, and it being packaged and ready to be used by an end user in a friendly way with little pain on installing it.

The second part usually takes a lot longer longer. And in some cases involves upstreaming patches which also takes it’s time

For example the instructions you quoted, still require a lot of: downloading source code of different components and compiling them, for waydroid to work. Not all users will want, or have the skills to do that.

The reason for the “deafening silence on Waydroid” is that we will likely not make a blogpost about it before installing it is in better shape.

Also we have to work on different fronts at the same time.


I get the point, it is similar and inline to what @dos had conveyed.

Talking about Anbox working on Librem 5. It is also in a not-ready state for end user. When I tried installation, it gets installed but after that it is so bad that it is unusable from the end user perspective. (Screen hangs, it takes seconds to reload etc.) Inspite of everything, we had a Purism announcement about it.

Compare that with Waydroid, it is far better performing application than Anbox. And if I had a say, it is pretty big thing. So, it deserves a announcement and not sure about others, but I am very eagerly awaiting @dos or @david.hamner or Purism to say, it is now available in the repo for download.

No matter how performant a feature is: if the feature isn’t actually usable – e.g. due to the sheer number of hoops I have to jump through in order to get the feature up and running – then I’d rather not see Purism announce it as ready.


And worse still … it might not work.

There can be a lot of assumptions about “environment”. What works for one person might not work for another.

I have the skills to download files and run a shell script. But … if it doesn’t work (i.e. craps out with some error during the build), I may not have the skills, knowledge, time and patience to work out what went wrong and fix it … so there’s a lot to be said for waiting until it’s all nicely tested, integrated, packaged and working directly from the Purism repo.

I totally get though that some users may have proprietary Android apps that they simply can’t avoid using - and hence are very keen to get some solution.

1 - Waydroid also allows F-Droid apps :wink:
2 - I can also understand that argument

This is true, but as I’m sure you know, now there are a lot of users who got their hopes up and are now disappointed in Anbox. I think not mentioning Waydroid yet because it isn’t ready yet is a way of avoiding a bunch of heartbreak all over again.


Yeah, I’m pretty eager to be able to run my app from F-Droid on a Librem 5.

Of course, the real solution is to rewrite the app in Qt so it can run in all the major operating systems, but that is a lot more work on my part than figuring out how to get Waydroid working.

I wonder how many creators of FOSS apps for Android are thinking like me that the long term solution is to abandon all the Android-specific stuff and move to universal toolkits/libraries that can run anywhere. I hope multi-platform FOSS toolkits/libraries will become the future of programming, but the only real option that I know of at this point is Qt. Learning Qt is proving harder than I thought and it lacks a lot for mobile programming compared to Kotlin+Google Mobile Services.

Funny, but when I look for software for Librem 5, I always just ignore Qt apps and only look at the GTK apps.
Maybe it is my misunderstanding, but I thought that GTK apps work best on Librem 5 and Qt might not be working that well / could be blurry.
It would be interesting to hear an expert opinion.

1 Like

Phosh supports GTK, Qt and HTML5 apps. I haven’t seem that Qt is blurry in Phosh. Do you have screenshots to show the problem?

The issue is that GTK doesn’t support Android and iOS, whereas Qt does. GTK could be expanded to cover mobile OSes in the future, but I dont see it happening because none of the major companies that contribute to GTK (IBM/Red Hat, Google, SUSE, Canonical and Purism) have any interest in doing it. Google already has its own solution with Flutter, but it seems like another gateway to use Google’s proprietary services to me. React Native doesn’t support Linux. Cordova may work, since it supports both mobile and desktop systems (through Electron), but I haven’t really investigated it, since I prefer standard toolkits over HTML5 +CSS3+JavaScript.

1 Like

I don’t because I try to avoid Qt on Librem 5 since I reflashed some time ago :smiley:
Maybe I have limited my choice of apps for no real reason.
I would start a poll.

1 Like

The answer is easy - you still can’t install Waydroid without patching your kernel and Mesa (which is about to change in a week or so), while you could install Anbox easily back in the day. Once that changes, you can expect announcements to be made. This isn’t related to how “usable” Anbox or Waydroid is at all, it’s all about how big the potential to screw your whole system up is while installing them.


Thank you for your hard work on this.
Much appreciated!
Without Waydroid, I wouldn’t be able to buy train tickets, or use other rather basic services.

1 Like

@dos thank you for the time and effort you put in to make waydroid work. i have tried it a few times but even though waydroid installs i’m unable to launch any apps from it. eagerly waiting for clear instruction to install waydroid (would be gret if there is a script that automates everything)

1 Like

sudo systemctl stop waydroid-container sudo rm -rf /usr/share/waydroid-extra ~/.local/share/waydroid ~/.local/share/applications/waydroid.*.desktop ~/.local/share/applications/Waydroid.desktop sudo rm -rf /var/lib/waydroid sudo apt remove -y libgbinder libgbinder1 libglibutil libglibutil1 libgbinder-dev libglibutil-dev python3-gbinder waydroid
sudo apt update
sudo apt full-upgrade -y

rm -R artifacts
wget -O
unzip -d ~/artifacts/
sudo apt install -y /home/purism/artifacts/debian/output/waydroid_1.3.3-0pureos0+librem5ci79377.0353512_all.deb
#sudo waydroid init