Do matrix in chatty support images?

I did not see this mentioned in the forum, nor the issues on chatty matrix.

In chatty you are able to attach an image, and seemingly send it, but the other end do not receive it.
If the other end sends me an image, I only see an image symbol and a download button. When I press the download button it loads forever, and I don’t find the image anywhere on the phone.

After reinstalling chatty, removing all the folders mentioned in chatty debugging, and reinstalling chatty, the problem still persist.

Is this normal behavior?

About normal behavior: at first I thought the title was about dot matrix support in chatty…
Workaround suggestion: ASCII art images :nerd_face:
(sorry, had to)

1 Like

I laughed waaay to hard at this :smile:

It is for now. You can use other Matrix clients until file transfer got implemented in chatty some unknown day. I myself tested Element and that works fine so far, but there are also more light weight clients in beta that may also do their job (maybe someone else has experience with fractal etc).

1 Like

Thank you for the answer. I have tried nheko previously, and it was okay. I like element on the desktop and on android, and will give it a try on the L5.

Chatty usually works fine for text, so I will continue using it for that. It is great that notifications usually works. Hopefully stuff like images, reactions, replies and edits will be added eventually :slight_smile:

I am very open to more suggestions for good matrix clients

Just as hint (I wrote it in another thread): after you logged into matrix in Element, take terminal keyboard and hit Ctrl + - at least once (zooms in) and rotate screen to landscape view and back. It makes the room list shrinks to just the symbols to give the chat more space. You can also repeat zoom until you’re happy with screen space, but don’t go too far - resetting zoom is a little bit more complicated.

This is a work around, because resizing rooms panel horizontal is not supported with touch input (but already reported). If you can you also can use a hardware mouse to do the resize. But file transfer, emotes, reactions etc etc is working. It just has no access to cameras yet (not sure why).

I tested fractal, cinny, and fluffychat. Cinny and fluffychat did not even start. Fluffychat seems to have a bug that relates to librem 5’s Vivante GPU. Fractal’s current stable version from flathub does not support encryption unfortunately.

Element I was not able to find at all in flathub. I tried running ‘flatpak install flathub im.riot.Riot’. Did you install using commands from, @Ick?

Exactly. Hopefully other clients will also work in future.

1 Like

I tried to install the beta version of fractal with these instructions. It seems to work well on the phone, but time will tell if there are many bugs. Looks pretty though

Is there uuencode support built into chatty?

WTH!!! :face_with_symbols_over_mouth:I spend 4 days waltzing between carrier techs, Google links to Hades, testing w/ friends, reading volumes of puri docs, wiki editing settings, and made a post that no one answers to find this thread that basically says, Chat doesn’t work.

Why is Puri still befuddling people, with stuff that just doesn’t work?

How do I get rid aloof any other crippleware taking up space or does delete not work for programs AKBK-K as apps?

And Puri wonders why people get PO’ed. EXTREMELY PO’ed!!!

Now, I must sheepishly go back to other forums and explain that I bought a phone that exaggerates it’s product

What else is crippleware? Come clean - there is no shame in being truthful.

So, CHAT doesn’t work with images or videos. Puri should never have put it there.

Please save yourself the trouble and don’t reply with excuses why. It won’t help the deteriorating image of Librem products.

Sheesh :face_with_symbols_over_mouth:

I think buying a S23 would be giving up all rights to my privacy, but at least it’s stuff works, and for half the price.

:face_with_symbols_over_mouth: again!

There is no excuse because I don’t see any reason to complain about what Purism does. It’s a brand new application and no fork as far as I know. The to-do list is huge and I totally can understand why some important features are not implemented. On git there are 310 open issues … can be interpreted as “current to-do list” (from over 800 tasks in total). And there are already 1165 MR done (currently 15 new in work). They’re working hard on that app. And some features like encryption or basic functionality (be able to send end receive text without troubles) are more important than sending and receiving files.

And why did they release a half finished app on the phone? Because else you would have no access to SMS or MMS. The plan (and Purism told it) was to give us as fast as possible access to every progress they did and I like it this way. It’s easy to complain if you don’t have to write any line of code. There is a lot you can complain much more about Purism, but I don’t think it makes any sense in this case.


I am a L5 consumer. I read the hype, a opportunity to buy into the queue appeared and I soon had the L5. It took me awhile to discover that the L5 is for hobbyists and technically inclined.

I read, and re-read your comments. I’m not going to pray for better days for them. Care less about what their problems are. Your whole first paragraph, beyond what looks very odd, strongly suggests that they suffer from poor management, lack of more qualified technicians, running on a thin edge of finances, and possibly legal barriers.
Nothing I need to know. Thanks anyway.

I disagree with your last paragraph. All they had to do was grey out *use to mean unavailable until WordPress used it as regular text colour) you know what I mean, so we know, it’s not us, it’s not the carrier, it’s not the phone. Low and behold it is something we are supposed to know that it won’t work as expected of any phone. There’s empty space in the update details, why not a regular note that the update is still in planning. The space is doing nothing any way.

Sorry. I don’t feel bad about being really PO’ed at wasting my time again trying to make something work.

That is your opinion. I think you are wrong. We’ll move on now shall we :innocent:

If I am not mistaken your post was about SMS and MMS in chatty. This works perfectly fine for me in chatty, no complaints.

My post is about the matrix protocol, which is an encrypted chat protocol that has nothing to do with SMS or MMS. This protocol is not fully implemented yet. Regular matrix texts works fine, but media such as images does not.



The words from this second quote (from you) can be applied to the first quote (from you).

Please sell your L5 and get an S23.

I know that.
My post was about :arrow_lower_left: the other part :arrow_lower_right: where you said: (the bold is my edit).

I assumed MMS was the data part. Ergo, when the context menu says
SMS/MMS it means both and to me it would mean with data. It’s what happens when experts start using terms way above what the normal consumer need to know.

In case it’s mentioned, I didn’t think I was going off-topic here because your "media such as images does not. fit right in.

As I understand it now, the option to add data/pic/image/ does nothing. Doesn’t even warm that it didn’t send anything.

I thank you for taking the time to explain and now I know MMS is NOT about pics.
As for dot matrix, the only thing I had to know about that is it was my first printer.

Again, thanks,

Sorry. Sometimes it is easy to assume everyone else know all the terms you know yourself. I have always been very interested in technology and have learnt about it my whole life.

SMS is text messages you send to other people using their phone number. MMS is media such as images you send using a phone number. In chatty, both sending text and images should work if everything is set up correctly. This works for me.

Chatty also (partly) support the Matrix protocol. This is something similar to whatsapp/signal/facebook messenger etc., only privacy respecting. Matrix does not send messages using phone numbers, but rely on an internet connection. If Matrix does not ring a bell to you, you probably aren’t using it.

1 Like

Sorry to seem difficult, but I’ll ask anyway:
Is the below image of app “Chats” AKA “chatty”? and is the one you talk about where you can attach a pic with the chat?

When I send a Chat sans any attachment, people receive and reply. When I send chat w/ attached image, the Send performs the same way a plain chat is sent but nothing is received at other end, and if they send me a pic, I don’t receive the chat or image.
The only “chatty” +linux I could find is for Twitch.

Thanks krimskrams.

Yes it is. You can click on the ‘Website’ link there or use the fifth Google search result for ‘chatty linux’:

Per understanding: Most of the GNOME apps have different technical names as the ones you will see on PureOS or every other Linux distribution with GNOME. They do that so everyone knows what an app does. Chats (chatty) does Chats, Web (Epiphany) allows surfing the Web. Files (Nautilus) makes navigating the files possible.

It can be a bit confusing for non-coding people diving into problems but it’s the best way for simple users and developers imho. Imagine how unhandy it would be if the technical names of these app were also that simple. Impossible to Google for…