EPSON Printer Driver installation Issues

@kieran Sure: Based on EPSON Specs, the following is given:

TCP protocol RAW Port 9100 (Local)/any port (remote port); Control These Operations: Forwarding Raw Data
IPP/IPPS TCP protocol Port 631 (Local) /any port (remote port); Control these operations: Forwarding AirPrint data (IPP/IPPS printing)

Here is the actual link for the Ports:

@rcu I will do that.

Edit: To install those generic printer driver and utilities, it is saying that I need to install “lsb” package first. Yet command line says “Package “lsb” is not available, but is referred to by another package.”

Edit 2: I downloaded the necessary printer driver & printer utility. Now I just need to figure out how to install the LSB package it is referring to. You will see the “install package LSB” comment after clicking on “Accept” and read the directions.


So which one are you using?

Raw 9100 is probably simplest.

I am going to try @rcu answer first.

Try it:
apt-get install lsb-base lsb-release
If these packages are not available in the PureOS repositories then connect the Debian 10 ‘buster’ repositories:
sudo echo ‘deb buster main non-free contrib’ >> /etc/apt/sources.list
sudo apt-get update
sudo apt-get install lsb-base lsb-release
Then install the printer driver and utilities.

@rcu I entered that command and the command line reported “lsb-base is already the newest version (10.201…)” & “lsb-release is already the newest version (10.201…)”; If I am interpreting it correctly, then all I have to do is install the drivers correctly. Thank you for the help @ErraticEagle I hope you’re still following this thread.

Situation update:
I have downloaded the amd64 system type printer and drivers. I keep hitting a snag, the command line reports “no such file or directory”, even though I gave permissions to make each folder act as if they were an executable file. I even slowed down to triple-check for any misspellings, file name checks, and other potential user errors.

No luck. The two files are sitting in my Downloads folder and there is no shell script in the driver folders. I checked. @rcu @kieran

This is not the case when you need a script. Navigate to the folder where the required packages are located:
cd [path to folder]
Install the deb package:
sudo dpkg -i [full package name]
Read the PureOS and Debian documentation.

@rcu I got the command right, including navigating to the right package. It was a partial success, now I am just missing the dependencies. This round I added the debian repository and ran the upgrade. Command line reports the lsb-base and lsb-release dependencies are the lastest version (10.2…). I am still getting an error that says the driver needs lsb 3.2 or higher.

Additionally, the command line also says “Try 'apt --fix-broken install”

Edit: unmet depedencies [printer driver]: Depends: lsb (>= 3.2) but is not installable."

‘apt --fix-broken install’ command reports unmet ‘lsb’ dependency?
Try it:
sudo apt-get update
sudo apt-get install printer-driver-escpr
Downloaded from ‘…’ deb packages for the printer can be deleted.

@rcu Here is the full information:

Note: the first command worked fine. The second command could not work. Here is the Command Line response.

After I input sudo apt-get install printer-driver-escpr

Command Line Message:

“Reading package lists…done”
“Building dependency tree…”
“Reading state information…Done”
“You might want to run ‘apt --fix-broken install’ to correct these”.
“The following packages have unmet dependencies:
epson-injet-printer-escpr2 : Depends: lsb (>=3.2) but it is not installable.”
“E: Unmet dependencies. Try 'apt --fix-broken install ’ with no packages (or specify a solution).”

the apt install command auto-manages dependencies AFAIK … why not try with that instead of the sudo dpkg -i [full package name]

if you have downloaded the .deb files just

apt install “insert-absolute-path-to-the-package-name” as root (#) with sudo or su

apt auto-remove “package-name” if you want to more thoroughly remove stuff

@reC I will give that alternate command a try either late this afternoon or Friday morning. I will also include the command line responses for context. Thank you to everyone who has been helping me with this so far. I do appreciate the help being given.

@reC I did the following as root:

apt --fix-broken install That removed the fragment of software that was without the dependencies. Next, I did the following, also as root, sudo apt-get install printer-driver-escpr . After that, I ran _sudo apt-get update, this worked successfully like the first two. There was successful installation of that specific driver.

When I tried to print a basic dummy text in Text Edit, nothing happened; nothing printed at all. The problems that keep repeating come from the Epson Printer Driver & Printer utility specifically: mainly the “lsb” packages/dependencies keep being reported even though “lsb-base” and “lsb-release” in the PureOS itself are the most recent version 10+.

Edit: I will check the documentation covering printing. The printer driver installed fine.

I am deciding to reboot this thread. From a clean install of PureOS 9. First, when I go the EPSON website, their drivers and utilities need the “lsb” package to run properly so they show up in CUPS. I was able to get my EPSON printer working in Linux Mint (Debian/Unbuntu franken OS).

Here is the forum post:

That other forum post show how I solved the problem in Linux Mint. What I do not know how to do is to get this EPSON ET-3760 to work with just debian alone.

Edit: Using the VMWare article I removed the printer port and also switched the network adapter setting to Wifi so the PureOS virtual machine appears as an additional computer. This choice contributed to getting my EPSON printer and scanner to work under Linux Mint.

Here is the freaking weird part for me. I just searched for and opened up the settings app, went into Printers and Scanners, saw my printer (ET-3760) on the network and made it the default. I noticed that it was setup as with the IPP Everywhere protocol. Opened LibreOffice Writer, typed “Your Mother!” > File > Print > Used defaults > Clicked “OK” > Printed with zero issues, the entire joke text without issues.

Other than the VMWare, I did not have to configure anything in PureOS at all. It setup automagically, without needing external driver download from EPSON to set this up. Printer Settings even shows ink level statistics. Pure OS was significantly less work than Linux Mint. I am dumbfounded.

The only problem I am having is that my installation of PureOS is using the wrong scanner on a different printer when it should be using the scanner on the ET-3760. How do I fix this? The wrong scanner uses “EPSON PID 0899” which is for the other printer, not the ET-3760.

Have you tried it with PureOS 10/Byzantium? I also have an Epson (WF series) which worked like a charm under PureOS 9/Amber, which seamlessly found it on the wireless network and printed perfectly from day 1 onwards, 18+months ago.

PureOS 10/Byzantium, however … that’s a different story so far.

Downloaded the allegedly appropriate Linux driver package from Epson. Then did:

Librem15:~/Downloads$ sudo apt-get install ./epson-inkjet-printer-escpr2_1.1.45-1lsb3.2_amd64.deb
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Note, selecting 'epson-inkjet-printer-escpr2' instead of './epson-inkjet-printer-escpr2_1.1.45-1lsb3.2_amd64.deb'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 epson-inkjet-printer-escpr2 : Depends: lsb (>= 3.2) but it is not installable
E: Unable to correct problems, you have held broken packages.

Librem15:~/Downloads$ sudo apt-get install lsb
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Package lsb is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'lsb' has no installation candidate

Both lsb-base and lsb-release are installed, from the byzantium repo, as version 11.1.0pureos1 (byzantium).

So, if you have moved up to byzantium, have you managed to finesse this issue as you did above for amber? This is now the one last thing holding me back from a working system such as I had before the upgrade to byzantium, which was a fresh install of the OS (not a dist-upgrade), and a restore from backup of the data files in Home. Thus, it is a totally clean byzantium system.

Any ideas applicable from your quest?

If you have a .deb package you want to install, its better to use sudo dpkg -i name-of-deb instead of sudo apt install.

I actually did do a

$ sudo dpkg -i epson-inkjet-printer-escpr2_etc_.deb

but it bombed out due to the unmet dependencies error, and then needed a

$ sudo apt --fix-broken install

to clean things up, which is why I then went down the $ sudo apt route.

The problem seems to be that the driver package is expecting lsb to be installed (since it is a dependency) and yet the instructions at Epson’s site, namely to do

$ sudo apt install lsb

are clearly no longer valid (whereas it may have been at some stage), since APT says there is no such thing to install.

So, the main question is: what is the workaround to get lsb installed on Byzantium/Bullseye in such a way that the printer driver package recognises that it is?

Generally, dpkg is the way to go.

For lsb, this may help, but you’ll be on your own: