EPSON Printer Driver installation Issues


#21

@beaker @kieran I will see if going through that will help with the printer & scanner issues this Sunday.


#22

@kieran I tried using the normal GUI for the printer. No luck with that one. The only thing that prints is the number “8” in upper left corner of the paper. Not the actual dummy text I created in Text Edit.

I do not know why it will print only that number. I also need help in troubleshooting. Could the number “8” be an error code?


#23

With about zero information to go on … I would suggest that the computer is sending crap to the printer because the computer is not fully aware of what it is supposed to be sending. Unfortunately I have no experience with Epson printers so I can’t tell you what “languages” given models of Epson printer speak.

Assuming that you are communicating with the printer via the network, another factor to look into is what application protocol is being used. A very common choice is “raw” on port 9100. Other choices would be lpd / lpq (traditional Unix printing protocol), SMB (traditional Microsoft Windows printing protocol), IPP. So can you tell us what protocol and port (where relevant) is being used?


#24

I downloaded the Scanner ‘Driver All-in-one package’ and unpacked it. It contains only scanner driver and scanner utilities. You also need to download and install ‘ESC / P-R Driver 2 (generic driver)’ and ‘Epson Printer Utility’ for the printer.


#25

@kieran Sure: Based on EPSON Specs, the following is given:

TCP protocol RAW Port 9100 (Local)/any port (remote port); Control These Operations: Forwarding Raw Data
IPP/IPPS TCP protocol Port 631 (Local) /any port (remote port); Control these operations: Forwarding AirPrint data (IPP/IPPS printing)

Here is the actual link for the Ports: https://epson.com/faq/SPT_C11CG20203~faq-0000525-shared?faq_cat=faq-8796127635532


#26

@rcu I will do that.

Edit: To install those generic printer driver and utilities, it is saying that I need to install “lsb” package first. Yet command line says “Package “lsb” is not available, but is referred to by another package.”

Edit 2: I downloaded the necessary printer driver & printer utility. Now I just need to figure out how to install the LSB package it is referring to. You will see the “install package LSB” comment after clicking on “Accept” and read the directions.

Link: http://download.ebz.epson.net/dsc/du/02/DriverDownloadInfo.do?LG2=EN&CN2=&DSCMI=106340&DSCCHK=dfb754828eb21063e7b841aa0c98179893b615eb


#27

So which one are you using?

Raw 9100 is probably simplest.


#28

I am going to try @rcu answer first.


#29

Try it:
apt-get install lsb-base lsb-release
If these packages are not available in the PureOS repositories then connect the Debian 10 ‘buster’ repositories:
sudo echo ‘deb http://deb.debian.org/debian/ buster main non-free contrib’ >> /etc/apt/sources.list
sudo apt-get update
sudo apt-get install lsb-base lsb-release
Then install the printer driver and utilities.


#30

@rcu I entered that command and the command line reported “lsb-base is already the newest version (10.201…)” & “lsb-release is already the newest version (10.201…)”; If I am interpreting it correctly, then all I have to do is install the drivers correctly. Thank you for the help @ErraticEagle I hope you’re still following this thread.


#31

Situation update:
I have downloaded the amd64 system type printer and drivers. I keep hitting a snag, the command line reports “no such file or directory”, even though I gave permissions to make each folder act as if they were an executable file. I even slowed down to triple-check for any misspellings, file name checks, and other potential user errors.

No luck. The two files are sitting in my Downloads folder and there is no shell script in the driver folders. I checked. @rcu @kieran


#32

This is not the case when you need a script. Navigate to the folder where the required packages are located:
cd [path to folder]
Install the deb package:
sudo dpkg -i [full package name]
Read the PureOS and Debian documentation.


#33

@rcu I got the command right, including navigating to the right package. It was a partial success, now I am just missing the dependencies. This round I added the debian repository and ran the upgrade. Command line reports the lsb-base and lsb-release dependencies are the lastest version (10.2…). I am still getting an error that says the driver needs lsb 3.2 or higher.

Additionally, the command line also says “Try 'apt --fix-broken install”

Edit: unmet depedencies [printer driver]: Depends: lsb (>= 3.2) but is not installable."


#34

‘apt --fix-broken install’ command reports unmet ‘lsb’ dependency?
Try it:
sudo apt-get update
sudo apt-get install printer-driver-escpr
Downloaded from ‘…epson.net’ deb packages for the printer can be deleted.


#35

@rcu Here is the full information:

Note: the first command worked fine. The second command could not work. Here is the Command Line response.

After I input sudo apt-get install printer-driver-escpr

Command Line Message:

“Reading package lists…done”
“Building dependency tree…”
“Reading state information…Done”
“You might want to run ‘apt --fix-broken install’ to correct these”.
“The following packages have unmet dependencies:
epson-injet-printer-escpr2 : Depends: lsb (>=3.2) but it is not installable.”
“E: Unmet dependencies. Try 'apt --fix-broken install ’ with no packages (or specify a solution).”


#36

the apt install command auto-manages dependencies AFAIK … why not try with that instead of the sudo dpkg -i [full package name]

if you have downloaded the .deb files just

apt install “insert-absolute-path-to-the-package-name” as root (#) with sudo or su

apt auto-remove “package-name” if you want to more thoroughly remove stuff


#37

@reC I will give that alternate command a try either late this afternoon or Friday morning. I will also include the command line responses for context. Thank you to everyone who has been helping me with this so far. I do appreciate the help being given.


#38

@reC I did the following as root:

apt --fix-broken install That removed the fragment of software that was without the dependencies. Next, I did the following, also as root, sudo apt-get install printer-driver-escpr . After that, I ran _sudo apt-get update, this worked successfully like the first two. There was successful installation of that specific driver.

When I tried to print a basic dummy text in Text Edit, nothing happened; nothing printed at all. The problems that keep repeating come from the Epson Printer Driver & Printer utility specifically: mainly the “lsb” packages/dependencies keep being reported even though “lsb-base” and “lsb-release” in the PureOS itself are the most recent version 10+.

Edit: I will check the documentation covering printing. The printer driver installed fine.