[EPSON Printers + Scanners | Kubuntu] Printer Installation

I am currently trying to figure out how to properly install, activate, and run my EPSON ET-3760 printer/scanner from Kubuntu.

I tried: Installing the applicable drivers that included my current printer, tried to print a test page (no luck), and can’t seem to get it working properly even though the correct printer is listed in one of the options.

OS Version: Kubuntu LTS in VMWare Fusion 12.1.0

I know it is possible to get a printer running in a virtual machine, I found out accidentally it can work, I just can’t remember what I did last year to make it happen, including the factors responsible.

What else do you need to know?

P.S. I am only concept savvy, not tech savvy. So provide your recommendations in small bits first with citing your sources; do not just put up a link telling me where to go without explicitly telling me what I should be focusing on. For example, if you mention fiddling with CUPS directly without “idiots-guide” simple steps it won’t help. I am easily overloaded with too much information.

Have you tried same with PureOS and/or other distributions, and did it work then?

The problem I have come across is that this is an issue with multiple OSes. Only Kubuntu seems to have been the closest to success. Actually seeing the correct printer listed.

1 Like

My current problem is getting a solid connection to occur so I can print a test page. I am holding in my head the series of steps necessary this time so I can create a tutorial for others to follow if they use an EPSON printer like me.

Are you trying to print over wireless, or with an ethernet or USB connection?

looks pretty similar to the one i have. are you setting up network printing? Or usb?

@amarok @ruff To answer both your questions: I prefer printing over the network (WiFi). That is what I am trying to achieve.

Ok, so what I did was

  • Download ppd files from epson site - search for your printer and select ESC/P-R Driver 2 (generic driver)
  • extract your ppd file or install the driver package
  • Ensure IPP Everywhere is enabled on your printer
  • Ensure cups and ghostscript are installed
  • Ensure you are in @SYSTEM group or add your group to /etc/cups/cups-files.conf SystemGroup
  • Start CUPS and navigate to http://localhost:631/admin (enter your user credentials)
  • Add printer, use ipps proto, and urls like ipps://[printer ip]/ipp/print
  • select PPD file you extracted earlier or just select printer model (if you installed the package)

should be it I’d guess. Slightly worried this driver has some binary files, mine was pure ppd archive from which I just extracted relevant ppd file and loaded it to cups.

@ruff I got up to the driver package being installed and my specific printer driver being recognized by Kubuntu OS. So that process worked correctly. Which is what I already achieved before coming here.

What isn’t working is the wireless connection issue. I pointed out quite clearly that I am concept savvy, Not Tech Savvy. I do not know how to get into System Group or add my group to the “.conf” file in System Group. You skipped necessary “idiot-guide” steps I alluded to.

I am not a linux expert, not even a novice at it. You need to break down your steps even further, more simple than you are used to.

Edit: Better Verbage: Add way more detail to your instructions.

Does the printer work from any other computer?

Does the printer work from the host machine? What operating system is on the host machine?

How is the printer itself connected to the local network? (presumably either ethernet or WiFi)

How is the host machine connected to the local network?

What printing protocol is any existing working computer using to communicate with the printer? (I realise that you may have difficulty answering that.)

Turning our attention to the Kubuntu VM, is it working at all as far as network connectivity is concerned? e.g. fire up a web browser and access a web site.

I skimmed only the previous comments, and just wanted to add the following: As you are using a VMWare product have you ensured that VMware tools are installed for the guest OS? These tools are necessary to share a printer connected to the host. You will also and importantly need to ensure that VMWare Player is configured to use virtual printers:

Sorry if this doesn’t match your GUI, as I’m using Workstation here.

this doesn’t fit current use case which is about network printing and hence is independent of host/guest relationship.


  • to add yourself to system group sudo usermod -aG wheel $(id -run)
  • to start cups service sudo systemctl start cups

the rest is in the web gui of either printer or cups.

Slow down turbo, if the printer is already setup in Mac OS, VMware can just pass the print request to the Mac OS configured printer. Bypassing all of the stuff you are doing now.

Yes you should be able to configure a network printer within the VM, but that doesn’t mean the easier way that VMware provides shouldn’t also be possible.

to me installing 3d party apps (like vmware tools from iso) is always more complex than setting up printer :slight_smile:

Taking advantages of the software you are using is also important. These are part of the features sets the customer paid for. Never fear either, most Linux distros support open vm tools anyway. Not installing it means screen scaling and any kind of drag and drop, copy and paste, and file sharing will not work. You might not want that, but most people do. So I digress that using the features VMware makes available is an equally important thing to discuss.

Q #1: Yes the printer works from all other computers.
Q #2: Yes, the printer works from the host machine. Host OS is MacOS 11 Big Sur.
Q #3: The printer is connected to the local network via WiFi.
Q #4: The host machine is connected to the local network via WiFi.
Q #5: Possible Printing Protocol: Default is Air Print (Apple), However EPSON Driver was used.
Q #6: Yes Kubuntu VM is working very well where network connectivity is concerned (Web Browser and other functions); currently printer is the only issue.

You have hit the nail on the head. For reference, the last time I attempted this (using PureOS previously) and fiddling with CUPS and command line directly; there was no solution to this problem. Kubuntu is more user friendly with setup.

Also, you are right, I should be using the features of the VMWare I am using, since I have a valid license key to use it for personal use. However, VMWare (what I am using now) already does auto-scaling by default; however, I have not tested drag-and-drop, copy and paste, and file sharing yet. The only problem is getting the printer to work properly and intentionally, not by accident this time.

Edit: P.S. The VM Kubuntu OS is currently setup to use the default printer of the host OS under “Printer” in the VMWare OS Settings options.

To everyone else:
If what you are suggesting to fix this issue cannot be easily done by my mother (who comes to me for tech questions), then I will disregard your suggestion. She is even less tech savvy than me; the command line would scare her.

Maybe try asking nicely? This comes across as really presumptuous.

Try doing this over USB first. You’re making it way more complicated by doing this over wifi. You need to confirm that the driver is properly set up in your guest OS before moving on to network configuration.

I wasn’t being presumptuous, I was stating a fact of technical ability, or lack thereof. You’re the one that assumed me presumptuous. I didn’t need the physical USB connection when this happened accidentally before under the competing software Virtual Box.

“Give me extremely detailed instructions or I will ignore them” is indeed presumptuous.

If it worked under VirtualBox, why are you using VMWare?