EU SIM not working


Is anybody else running into the issue of the EU SIMs not working on their L5s ( librem5r4 = Green?) ? I’ve tried SIMs from 3 different EU countries and none of them work.

Things tried with all SIMs:

  • turning on phone with SIM in and all hardware switches on
  • turn off phone, all hardware switches off, start phone, turn on modem switch
  • turn off phone, all hardware switches off, start phone, turn on all switches --> other switches work
  • remove SIM card while phone is on --> phone restarts

All of these still result in the “Cellular” icon being disabled and no PIN being asked.

I’m comfortable with the linux CLI, so if there are commands that allow outputting useful debug information, I wouldn’t mind running them. The phone is basically vanilla as I haven’t installed anything and it’s like a new phone. If there’s a way to reset it to factory state, I wouldn’t mind doing that either, but it is basically already in that state🤷‍♂

Can you be more specific?
Which are the countries and which are the operators?

  • French SIM: Orange
  • Dutch SIM: Lebara

Can’t remember the operator of the German SIM. Must’ve been vodafone.

1 Like

Did you take a look at the APN settings?

I don’t have access to those. The docs describe how one requires the modem to be activated, but the icon just doesn’t activate.


There is an overview in the community wiki. The 2 operators are not mentioned yet.

Honestly it sounds a little bit unrealistic that Orange in France and KPN (used by Lebara in NL) are unsupported, so it has to be really checked if it is a matter of settings.

A stupid question in this regard.
How can I test if VoLTE is working or not?
Is there a GUI or bash command that I could use to check?

1 Like

I would say it is very very likely that something is wrong with the set-up/settings and not with the L5-carrier compatibility.

All I did when I got the phone first is follow the basic setup without a SIM connected. I can’t find a guide to reset the phone to factory settings without reflashing (simply no time to figure that out on my OS), but if one exists feel free to share it.

Maybe that’s the issue, I dunno. The only things I can think of is that udev rules don’t exist to recognize when the modem switch has activated the modem or that it’s a hardware failure and the switch itself hasn’t been inserted properly. I’ll check those for now.

If somebody knows commands to run in order to manually configure the modem, I wouldn’t mind getting those as well.



I’m assuming there’s a problem with the udev rules. Barely anything happens when the modem switch is toggled. When the 2 other switches are toggled there’s a bunch more things happening.

purism@librem5:~$ sudo udevadm monitor 
monitor will print the received events for:
UDEV - the event which udev sends out after rule processing
KERNEL - the kernel uevent

KERNEL[343.867544] change   /devices/platform/rfkill-hks/rfkill/rfkill3 (rfkill)
UDEV  [343.925999] change   /devices/platform/rfkill-hks/rfkill/rfkill3 (rfkill)
KERNEL[345.276251] change   /devices/platform/rfkill-hks/rfkill/rfkill3 (rfkill)
UDEV  [345.373332] change   /devices/platform/rfkill-hks/rfkill/rfkill3 (rfkill)


Looks good. Opened it up and nothing is disconnected. Modem is connected to antenna properly. Everything’s fine. Must be the udev rules.

I’m done for today, maybe will take a look later, but my hunch is that the udev rules aren’t setup properly.

Could somebody share a trace of sudo udevadm monitor when they switch the modem on (and off, if you like)?

Apologies to former artists performed this this 1935 song, with my (parody) alterations:

In Spain SIMs say “Si, si”
In France SIMs say “Oui, oui”
Ev’ry little Dutch SIM says “Ja, ja”
Ev’ry little Russian SIM says “Da, da”
But L5, tell me why
No matter how I try
You won’t answer to my plea
Won’t say “Yes” in any language to me
When will you say “Si, si”?

1 Like

I had the same issue on my French SIM.

I did 1 mistake, and experienced another issue before having my SIM card working :

1. My mistake :

I inserted the SIM card at the back below the battery -> this is not the SIM card location, the good location is on the side of the phone. Then it asked me for the PIN code.

2. the other problem (APN) :

I had to go to mobile options then click on + button to add a new APN because none of the available APN were the good one.

So please, could you try as new APN and feedback ? thank you.

Also, I mention that sometimes my new added APN was lost (and the MMS/4G were not available again), I don’t know why. If you have the same issue, please feel free to tell us.

1 Like

This has nothing to do with the SIM card then. The whole modem isn’t seen at all. You may want to check the output of lsusb command while the kill switch is in “on” position (towards the upper end of the device).


Where are the mobile options? Could you provide screenshots?

As you can see in my screenshots, I don’t have a “Mobile network”.

Hello, I have edited my answer, first of all, please feel free to check if you have plugged the SIM card from the side or the back of the phone. It should be plugged on the side, below the Hardware Kill Switches.

About the mobile option, you have to go the the Settings app, then you can see a Mobile menu, this is where you can fin the APN settings. I can’t screenshot because my L5 is not closed to me, I am sorry

Also, just a reminder - please don’t do that. As noted in the quick start guide, you should remove the SIM tray only when the phone is off.


If, for example, the modem killswitch is activated, then you will not see “Wi-Fi” or “Mobile” in the Settings.

Doesn’t seem like it’s being detected.

purism@librem5:~$ uname -a
Linux librem5 6.0.0-1-librem5 #1 SMP PREEMPT Wed Oct 5 09:24:53 UTC 2022 aarch64 GNU/Linux

purism@librem5:~$ lsusb -vt
/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=xhci-hcd/1p, 5000M
    ID 1d6b:0003 Linux Foundation 3.0 root hub
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=xhci-hcd/1p, 480M
    ID 1d6b:0002 Linux Foundation 2.0 root hub
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/3p, 480M
        ID 0424:2640 Microchip Technology, Inc. (formerly SMSC) USB 2.0 Hub
        |__ Port 1: Dev 3, If 0, Class=Mass Storage, Driver=usb-storage, 480M
            ID 0424:4041 Microchip Technology, Inc. (formerly SMSC) Hub and media card controller

So the USB hub is correctly seen, but the modem is not. Replacing (or maybe even just reseating?) the modem may potentially be enough then. Please contact the support.

What about maybe carefully detaching, then reconnecting the modem? Plausible?

Yep, I don’t see that. Please refer to my screenshots in this thread that were taken with the killswitch off.

Already saw that.