External battery charger for Librem5

Black it for Night, white it for Day, so white theme it help to save a lot of battery to Librem 5, but you need to considere and to help to L5 to low the brightness until you can see well, unfortunately at the moment we can’t afford to keep a screen with high brightness, because L5 it using an excellent screen but with old technology compared to oled screens where they are energy efficient

1 Like

It is not while wide opening for inserting of some battery is up to 55mm (not slightly over 60mm, as needed).

Yet this one charges L5 battery up to max. of 4.2V (as officially and strongly recommended):

Note: Above linked (to aliexpress.com) product doesn’t include any kind of additional adapter (EU for example), it is made for US infrastructure only although compatible AC input ranges from 110V to 240V. Also, its charging speed would be 800mA which would coarse mean that cca. twice longer time needed up to 100% (4.20V) of L5 battery usual capacity.

1 Like

You mentioned it right on time, phone seems to be dead since this morning. I see similar issues as that thread, phone turns on and runs for few minutes before being unresponsive.
Right now it’s sitting on ‘Installing Updates…’ at 80% for last 15 minutes, I’ll need to find a way to start from scratch I guess.

I may start another thread about unresponsive phone.

Sure (just currently :upside_down_face:), if jour Librem 5 was not turned off overnight (for 8+ hours).

If battery capacity less than 10% this might/should be expected (but my opinion is not the expert one and probably not even the relevant one here, @librem5, please keep us informed).

Please try this one first:

This self regulating of stopping charging (red LED light off) I’m finding as just another Librem 5 great feature (only phone with such capability, if this term as technical correct). Thanks for this to all involved! Thanks @dos!

Not by default I think. Some gremlins still to deal with.

Status of Suspend for Librem 5


Sorry I couldn’t understand the post clearly. However here is summary.
I turned off phone (had around 20% battery), charged until red LED off (took about 4 hrs).
Turned on phone and it’s working right now.

I’ve also disabled ssh systemctl disable ssh . I think ssh access was causing hang up, if someone can confirm this (I may try to re-enable and see some later time). Disabling ssh was enough to get phone working even at 20% battery (Oh and shell is changed to zsh so in case ssh with zsh causes issue)

1 Like

Phone froze up again this morning. It was charging overnight so battery isn’t issue. I’ll start another thread and enable ssh again for debug.

1 Like

Adding some details here:
I didn’t replace pureos-store with gnome-software. I’m currently trying to flash latest image.

Flashing seems to be stuck on:
1:12 1/ 1 [=================100%=================] SDP: boot -f u-boot-librem5.imx 100%|██████████████████████████████████████████████████████████████████████████████████| 1073880/1073880 [00:18<00:00, 1901894.86it/s]

I’ve tried installing uuu and jumpdrive from source but that didn’t resolve it. Process is still stuck at SDP: boot.

On the side note: external charger works (https://www.amazon.com/Universal-Battery-Charger-chargering-Samsung/dp/B07SWV43H9)

Can you try on a usb-2.0 port? sometimes failed on usb-3.0

Oh tried both (cable that came with phone - USB-3.0 and one cable that I already had - USB-2.0). Tried USB-3.0 less than USB-2.0 (tried about 8 times on USB-2.0 and 2 times on USB-3.0)

Try different usb port with sudo and different usb cables. This issue happened to me one time, i not remember well how, why, this issue it happen to flash L5. Also you can use a different computer too.

I’ve tried sudo and non-sudo (after adding udev rules) that didn’t help.
Let me try different USB ports (this didn’t help either).

One more thing I’ve noticed:

If I keep flash script running (before plugging in phone), I don’t see solid red LED on battery insertion. (LED goes blinking red -> solid green)

If script is not running then I see behavior mentioned under steps at https://developer.puri.sm/Librem5/Development_Environment/Phone/Troubleshooting/Reflashing_the_Phone.html (blinking red -> solid red) and then I start script.

This procedure I like better, yet it will not work if this prerequisite (connection) isn’t achieved:

Using different computer didn’t work however I got more details:
Trying to debug jumpdrive boot process:
Output of uuu -lsusb
uuu (Universal Update Utility) for nxp imx chips – libuuu_1.4.193-0-ge56424c

Connected Known USB Devices
	Path	 Chip	 Pro	 Vid	 Pid	 BcdVersion
	1:5	 MX8MQ	 SDP:	 0x1FC9	0x012B	 0x0001

boot-purism-librem5.sh has uuu purism-librem5.lst and purism-librem5.lst has all uuu commands listed.
so I started uuu shell with uuu -s and executed commands from lst.

Please input command: 
U>CFG: FB:  -vid 0x316d -pid 0x4c05
>Start Cmd:CFG: FB:  -vid 0x316d -pid 0x4c05
U>CFG: SDP: -chip MX8MQ -compatible MX8MQ -vid 0x316d -pid 0x4c05
>Start Cmd:CFG: SDP: -chip MX8MQ -compatible MX8MQ -vid 0x316d -pid 0x4c05
U>SDP: boot -f u-boot-librem5.bin
>Start Cmd:SDP: boot -f u-boot-librem5.bin
New USB Device Attached at 1:5
100%1:5>Okay (3.057s)
U>SDPU: delay 1000
1:5>Start Cmd:SDPU: delay 1000
Wait for Known USB \
Wait for Known USB /

Wait for Known USB -
Wait for Known USB \
Wait for Known USB | /

I’m sorry, Are you suggesting script needs to be started before connecting phone? (I’ll try this with other computer as well)

Looks all right to me so after confirming (again) needed/related connection with those two:
uuu -lsusb
lsusb | grep 8M

current proposal of mine might sound weird (at the moment) but please share with us following procedure (that might/should work with your current Librem 5 setup): please do not use Jumpdrive executing command at all, just jump to this one as your very next command:

Negative. I’m suggesting to start script afterwards.

Please share with us back specification numbers of your new external charger, because if you are having numbers similar to the ones shown here: https://forums.puri.sm/uploads/default/original/2X/6/6de968b085ca3c0c97e628fa1d0fceb24f23d190.jpeg be aware that those numbers are very bad ones to be used with Librem 5 battery, IMHO (hopefully not relevant, but they are not ideal if/when inserted into Librem 5 with its fully charged output of 4.35V, as referred elsewhere already).

Doesn’t work either (adding terminal info below).
Should phone be in flash mode all the way until script finishes? Phone definitely comes out of flash mode after SDP: boot
It shows green LED which changes to amber LED and it doesn’t show up under lsusb or uuu-lsusb

○ uuu -lsusb
uuu (Universal Update Utility) for nxp imx chips – libuuu_1.4.193-0-ge56424c

Connected Known USB Devices
Path Chip Pro Vid Pid BcdVersion

1:1 MX8MQ SDP: 0x1FC9 0x012B 0x0001

○ lsusb | grep 8M
Bus 001 Device 004: ID 1fc9:012b NXP Semiconductors i.MX 8M Dual/8M QuadLite/8M Quad Serial Downloader

± ./scripts/librem5r4-flash-image --variant luks
2022-03-17 18:06:33 INFO Looking for librem5r4 luks byzantium image
2022-03-17 18:06:37 INFO Found disk image Build 10637 ‘luks librem5r4 byzantium image’ from Wed Mar 16 20:33:06 2022
2022-03-17 18:06:38 INFO Found uboot Build 82 from Fri Sep 10 11:19:03 2021
2022-03-17 18:06:38 INFO Downloading to ./tmp_librem5r4-flash-image_xzlwyb5f
2022-03-17 18:06:39 INFO Downloading image from https://arm01.puri.sm/job/Images/job/Image%20Build/10637/artifact/librem5r4.img.xz
2022-03-17 18:41:54 INFO Calculating sha256sum of ./tmp_librem5r4-flash-image_xzlwyb5f/librem5r4.img
2022-03-17 18:42:05 INFO Downloading uboot from https://arm01.puri.sm/job/u-boot_builds/job/uboot_librem5_build/82/artifact/output/uboot-librem5/u-boot-librem5.imx
uuu (Universal Update Utility) for nxp imx chips – libuuu_1.4.193-0-ge56424c

Success 0 Failure 0

1:1 1/ 1 [=================100%=================] SDP: boot -f u-boot-librem5.imx