Fan full blast after sleep, coreboot and Intel ME


#1

My Librem 13v3 arrived two days ago, and I seem to have immediately run into several issues which at present do not make me a ‘happy camper’. I am fully aware that bits and pieces of what I describe below show up in several threads, but it might actually be useful to combine them.

Key problem: about 90% of the time, when waking the laptop from sleep (lid close, lid
open, login), the fan goes to full blast (without load), and the CPU runs only at 400MHz. (This is likely true, because the performance is clearly degraded in this state.) Putting the laptop to sleep and waking it up again rarely fixes this for me, only a full restart helps.
As described by others, laptop is perfectly cool, so no need for the fan.

Although I am at the most recent firmware coreboot-4.7-18-g7ac4919b8a-4.7-Purism-4,
after some struggle I rebuilt the firmware and reflashed. (Side rant, there are several dead links and partially outdated instructions, which makes this not very straightforward)

Is there any lead on the fan issue? The fan noise is loud enough as to be intolerable during lectures or a being in a conference. Note: in my fairly limited use so far, I did not encounter any heat triggered reboots/shutdowns; from my understanding of the forum posts, this seems to be a different issue.

Some more observations, maybe relevant, maybe not:

The Intel ME related output of cbmem -c is very different from what is stated on the purism coreboot page:

FspNotify returned 0x00000000
Finalizing chipset.
ME: Host Firmware Status Register 1 : 0xFFFFFFFF
ME: Host Firmware Status Register 2 : 0xFFFFFFFF
ME: Host Firmware Status Register 3 : 0xFFFFFFFF
ME: Host Firmware Status Register 4 : 0xFFFFFFFF
ME: Host Firmware Status Register 5 : 0xFFFFFFFF
ME: Host Firmware Status Register 6 : 0xFFFFFFFF
ME: FW Partition Table : BAD
ME: Bringup Loader Failure : YES
ME: Firmware Init Complete : YES
ME: Manufacturing Mode : YES
ME: Boot Options Present : YES
ME: Update In Progress : YES
ME: D3 Support : YES
ME: D0i3 Support : YES
ME: Low Power State Enabled : YES
ME: CPU Replaced : YES
ME: CPU Replacement Valid : YES
ME: Current Working State : Unknown (15)
ME: Current Operation State : M0 without UMA but with error
ME: Current Operation Mode : M0 without UMA
ME: Error Code : Preboot
ME: Progress Phase :
ME: Power Management Event : CM0PG->CM0
ME: Progress Phase State : Unknown phase: 0x0f state: 0xff
ME: Power Down Mitigation : YES
ME: PD Mitigation State : Issue Detected but not Recovered
ME: Encryption Key Override : Workaround Applied
ME: Encryption Key Check : FAIL
ME: PCH Configuration Info : Changed
ME: Firmware SKU : Unknown (0x7)
ME: FPF status : fused
Finalizing SMM.
BS: BS_PAYLOAD_LOAD times (us): entry 0 run 110772 exit 10356

I have also seen unknown state 4. Anyways, is this OK, or could this have to do with the fan?

In some post it was pointed out that PureOS does not have full firmware for the Skylake. Could this have something to do. I am tempted to copy over the firmware stuff from a regular Debian machine. Graphics seems fine, though I haven’t done anything fancy, but the machine seems to deplete the battery during sleep more than I see on other laptops (all running various Linuxes…)

Finally, I am wondering how coreboot upgrades are getting to people who don’t manage to rebuild. I work with Linux since 1995 and it took me several tries and too much hunting in the forums (e.g., I still had to apply the libusb patch by hand …). I was under the impression that PureOS was intended for novices – good luck there. I admit I want to eventually install Qubes, but will wait for the hardware to work as advertised with PureOS.

I am happy to provide more info and our try things, but response will be slow as I have a grant deadline looming. Thanks for your help, best regards,

Stefan


#2

I’m also having these performance issues, but only after plugging in the laptop. If I reboot and it runs on the battery, everything works as expected. Here’s a thread that describes similar issues: Link :: Hoping to find a fix for this; pretty sure it only started happening after some recent package updates.


Purism power optimisations service fails after recent update
#3

Thanks for the reply; I’ll watch the other thread closely.

Just as to the ‘recent updates’ comment: I played with the laptop the day it arrived, without upgrading. So, possibly Purism support should know what image they installed. The fan issue appeared pretty much immediately, and until I realized that it was linked to sleep/wake-up, I thought I had received a defective unit (pretty ‘funny’ as I am in Europe). The point I am trying to make is that a ‘sudo apt dist-upgrade’ installed about 540 updates, so the original image cannot have been extremely recent. I don’t have the machine here, but could check. I think from memory kernel jumped from 4.15->4.16.

Also, I have the phenomenon a bit in reverse. I sometimes can avoid
starting the fan full blast (and low frequency) when plugging the laptop in.

Then, over the past 18 months similar problems seem to have plagued other distributions on ‘regular’ hardware (e.g. Lenovos) so I am starting to concede that this may be a wider kernel issue.

Thanks again,

Stefan


#4

Hmm, good to know. My librem is my only machine right now; didn’t realize there were wider performance issues. Strange that we have similar issues with different sequences. I guess I’ll keep monitoring the threads and work with what I’ve got.


Librem 15 (PureOS) becomes sluggish after closing/opening lid
#5

Same issue. Librem 13v3. For me, this happens infrequently, but only:

  1. When the laptop is not powered
  2. Immediately after waking the laptop from sleep by opening the lid.

It happens roughly 1/20 times I wake the laptop from sleep.

As noted above, symptoms include:

  1. Fan running at full blast
  2. A very laggy UI, in spite of negligible CPU utilization.

Putting the laptop back to sleep (closing the lid and waiting for the fan to stop) resolves the issue. When I re-open the lid, the fans stay off and performance returns to normal.

I’m not 100% certain, but it does seem to happen slightly more often in warmer environments.


#6

Me too. Current workaround is to close the lid again until the fan switches off, then open the lid again and then everything is fine. This is annoying though so any fix appreciated!


#7

Can confirm I have this problem as well, Librem 13 v 3.


Having multiple issues with my brand new Librem 13 v 3
#8

On the assumption that this might be a firmware issue, and noting that my firmware was a little out of date (4.7-Purism-4), I followed the instructions here to update (to 4.8.1-Purism-2). Sadly that didn’t fix it.


#9

I had the same issue. For me updating from coreboot 4.7-Purism-4 to 4.8.1-Purism-2 helped a lot.

Before the update the CPU dropping down to 400 and the fan going full speed happened after almost every wake up from sleep. And I had to power off and reboot.
After the update it only happens very rarely (about 1 in 20 times so far) and if it does all I have to do is close the lid, wait for the fans to stop and open the lid again.


#10

Same here, about 5% of the time.


#11

Finally back from my extended trip. The problem is still there after upgrading to
coreboot 4.8.1-Purism-3; cannot yet confirm the ‘statistics’ by others.

As far as I can tell,
this issue is spread over (at least) three threads; so I’ll link here to the other ones …

https://forums.puri.sm/t/librem-15-pureos-becomes-sluggish-after-closing-opening-lid

https://forums.puri.sm/t/purism-power-optimisations-service-fails-after-recent-update

https://forums.puri.sm/t/cpu-fan-stuck-at-high-speed-sometimes/

I would still hope that someone from puri.sm connects these threads and provides
official updates.

I can only report that I added the proprietory Intel firmware, but this had no effect on
the frozen frequency / fan full blast issue.

Best,

Stefan


CPU fan stuck at high speed sometimes
#12

I still have the same issue as well.
It seems to happen ~90% of the time when I’ve put my laptop to sleep while plugged in.

boot.log contains:
[FAILED] Failed to start Power/battery optimisations for Purism devices.
See ‘systemctl status purism-power-optimisations.service’ for details.

coreboot 4.8.1-Purism-3. Also ran an apt-get full-upgrade this morning and am running kernel 4.17.0-3-amd64

Issue still happens. CPU is slow (seems limited), and fan goes full speed.

Anecdotally it seems to happen more when the power adapter is plugged in than when just on battery, but it still happens in both scenarios.

Putting the laptop back to sleep and waking again resolves the issue every time.

Does anyone have a workaround? Any update from Purism on this issue?

Thanks!


#13

I also can confirm these symptoms.

CPU throttled, full fan operation. Closing the lid (sleep) solves it about the same time the LCD back light turns off. Waking up to normal operation.

4.15.0-33


#14

#15

I still get the issue but I think that’s bc the components need time to warm up (physically) as after a while when it’s not so cold it works fine


#16

I have had this issue in the past on my Librem 15v3, but it seemed to resolve itself over time. (I was probably closing the lid and didn’t realize that was the solution.) I haven’t had the issue in awhile, but it happened again today and found this thread after a reboot did not resolve the issue. When I ran systemctl status purism-power-optimisations.service, it showed an active status, so there was nothing more to do there. I was happy to find this thread with the suggestion to close the lid but I’m hopeful that the Librem team will figure out another solution to this.


#17

Have the same issue. If sombedy know what service or kernel part is responsible for that thing I can take a look on code.


#18

I also still have the full-fan-after-sleep issue after upgrading the coreboot to coreboot-4.8.1-7-g30300027ce-4.8.1-Purism-3.

Is there an official bug for this issue?