Flatpak warning "icon of unknown type"

Every time I do apt update && apt upgrade I get this error:

** (appstreamcli:32617): WARNING **: 11:08:02.615: Found icon of unknown type 'unknown' in 'system/flatpak/flatpak/cc.nift.nsm/*', skipping it.

What does it mean and how can I resolve it?


I did a
sudo flatpak repair org.telegram.desktop
and it seems to have solved the problem with the icon error.

I am still having problems with the app though, as it doesn’t look right on the phone screen. I have tried it both with and without qtwayland5 installed, but either way it doesn’t work properly. Toggling the OSK on/off leaves empty space below the telegram window. Also, in app switching mode, Telegram has a “?” in a circle as icon.

Any hints to get Telegram working as it should on the L5?

You should start another thread.

Hey there, AppStream author here :slight_smile:
The issue you are seeing is simply a bug with Flathub’s metadata - there is nothing you can do about it, only Flathub can fix this issue. It is also not “fatal” for the most part, but it will mean that whatever the app cc.nift.nsm is that it will not be visible anywhere (that’s why it is a warning, so users and especially developers are aware of this and don’t spend a lot of time hunting the wrong bug).
As for your Telegram issue, that looks like a completely unrelated issue to this warning :wink:


Hi Matthias, thanks for clarifying!