Gnome-Keyring Using Geary


I am having a strange issue with my L5.

When I attempt to use Geary, I am asked for the default keyring password. I don’t know what this password is. I was never prompted to create it (I think). I searched this site for a possible default/startup password and did not find one. I did managed to compose one mail but Geary crashed when I attempted to send the email.



GNOME keyring stores all the passwords that you create in any apps on your device. So if you set up an email account in Geary, and told Geary to save your user name and password, then GNOME keyring saves it so that you don’t have to enter your email login data every time.

You may have simply used your L5 PIN to save the data in GNOME keyring, and then forgot about it. Or the keyring may be asking you to create a password in order to store the data.

Also, if you install Seahorse, either through the terminal or by using the search window in the Software store app, you can see all the apps you’ve stored passwords for. I’ll link you a useful thread about Seahorse (aka Passwords & Keys): How to change Gnome-Keyring Password? and List of Apps that fit and function well [Post them here.]

Thanks for the response,

I understand the function of the keyring.

The exact message is:

Blockquote Enter password to unlock
An application wants access to the keyring “Default keyring”, but it is locked

This message is not asking for a new initial password but what appears to be a password already created.

I have spent hours trying all kinds of password including the L5 pin so the keyring password cannot possibly be that.

Thanks for the information about Seahorse. I did read those threads when I was looking for a possible solution.

1 Like

The only thing I can think of is that you must have either created a password and then forgot about it, or that you left it blank and saved it as blank (if that’s possible with Seahorse). Did you try that?

That keyring popup will show up every time you power up the L5 with networking enabled, or initiate network access after it has been turned off.


I have installed Seahorse but the tree part of the screen only shows a small amount and I cannot move the divider to the right so I have no access to the tree elements.

In addition, I don’t want to turn this thread into a discussion about Seahorse.

1 Like

Well… Sorry.

1 Like

@rsmereka I would delete/move the current key, to restart the complete szenario :slight_smile: Move the current key from “~/.local/share/keyrings/Default_keyring.keyring” to another location and restart the phone.

I hope this helps :slight_smile:


And if you want to disable the complete gnome keyring …

Copy “/etc/xdg/autostart/gnome-keyring-secrets.desktop” to the users autostart under “~/.config/autostart/” and edit the file (or mulitple files) from keyring - insert/add:


Now for this user is the deamon disabled -on next boot.


Thanks for the solution. Moving the default keyring from it’s home worked for me.

I left Gnome Keyring enabled.

I still have an issue sending from Geary but that is another story.

1 Like

I received my Librem 5 some days ago and I’m facing the same problem. I didn’t set any ‘Keyring password’.

If you added an email account to geary the app should ask you to add a password for it, this happened to me, the issue is that the lockscreen should unlock the keyring and it doesnt, tge issue is here

Thank you uzanto. I read the thread of the link , but unfortunately is too complicate for me. I didn’t understand how/if they solve it.
Above ‘execrable’ suggested to move a file to an other directory. I’ll see if I’m able to do it. Unfortunately I’m not friendly with the command line…

Isn’t solved yet, as the Seahorse gui is broken right now, you can remove the keyring and start again doing this:

Open the terminal and type rm /home/purism/.local/share/keyrings/Default_keyring.keyring then open Geary and you will be prompted to add the email account password again, then the keyring one, try to use one that you can remember.

If you can connect the phone to a monitor and keyboard and mouse you can change the password easily with Seahorse.

1 Like

Thank you very much uzanto :pray:

Hi uzanto,
your indications worked. As you wrote it asked the new psw.
Unfortunately now there is problem in sending e-mail; it put e-mails in the outbox and stay there

Could be:

  1. misconfigured smtp server settings (i.e. outgoing), or
  2. lack of internet connection

Not possible: before the problem of the ‘keyring’ it worked fine and connection is fast and ‘strong’. Now it seems to work again

You may need the password to send emails too and the app forgot them, try editing the sending options and add it again.

1 Like

Same thing happened to me. I moved the Default.keyring (that I also didn’t remember asking me for), then when I restarted the phone and entered geary, THEN it asked me to create one.

Althougyh it is possible that the first time it asked me to create a “keyring” I confused it with asking me for one of my regular passwords and gave it that.

1 Like