Gnome-software (PureOS store) no longer starting

Hi there,

last week the “PureOS store” program was updated to version “41.beta+really41.0-0pureos1”, since then the PureOS store GUI is lo longer starting up, neither by hitting the “PureOS store” icon, nor by going via Settings --> About --> Software Updates … simply nothing happens on the screen.

Amd when trying to start “gnome-software” (is the “gnome-software” the “PureOS store” by the way?) from within a terminal I receive back “Timeout was reached”. I found some older bug reports with Red Hat and Debian where killing the “gnome-control-center” might do the trick, it does not on my Librem5 though.

Any idea how I can fire up the “PureOS store” again?

Thanks in advance,

Kind regards, Joerg.

Try in command line the following:

sudo apt update
sudo apt upgrade


Another troubleshooting approach is to run the appropriate program from the command line. If it crashes out immediately, maybe it will output a helpful error message.

I believe not.

I believe it’s pureos-store, more specifically /usr/bin/pureos-store

All packages are on the very latest version (apt upgrade shows now updates to be installed).

I mentioned in my very first post that running the program (“gnome-software” in this case) does bring back a timout error message.

Concerning the “pureos-store”: there is no file/program /usr/bin/pureos-store, nothing in /usr/sbin/ either. I checked for a flatpak installation, but “flatpak list” does not return anything.

So… I am still lost how to bring back the PureOS store app :-/ .

Kind regards, Joerg.

You can check where it is using the dpkg-query command, like this:

dpkg-query --listfiles pureos-store

That should list all files installed for that package. For me, it shows the executable /usr/bin/gnome-software:

purism@pureos:~$ dpkg-query --listfiles pureos-store | grep bin

If you try starting it by entering gnome-software at the command line, does it show any error messages then?

I just fired up my used L5 and did the sudo apt update/upgrade via wi-fi. Worked perfectly. This is a cool phone

So … “dpkg-query --listfiles pureos-store” does also show “/usr/bin/gnome-software”, which then indeed seems to be the “PureOS store” thing I have guessed in my very first post.

But still: when running this from a terminal I do get back “Timeout was reached” as an error after a bit (like 10 seconds or something).

Anything else I can try to get this thing started again?

Kind regards, Joerg.

After gnome-software failed to start, you could run this to check for recent log messages:

sudo journalctl --since -300s

That means to show all journalctl log messages from the past 300 seconds. Hopefully there are some clues there about what went wrong when you tried to start gnome-software.

Yes, that was indeed very helpful, thanks: I could see warnings from “sm.puri.OSK0.desktop” saying “Warning: failed to load layout from Resource : terminal/de_wide: Missing resource, skpping” and some similar with “Tried file …squeekboard… us_wide.yaml, but it’s missing: No such file or directory (os error 2)”.

I then changed the “Format” from “German” to “United States” under “Settings” --> “Region & Language”, did a restart of the device … and volia: the “PureOS store” is able to start again.

So it must be a bug with the “gnome-software” while having changed some locale from “United States” to “German”.

Thanks again for the hint,

Kind regards, Joerg.

1 Like