Gnomeshell crashes after update from 25/26th of april - byzantium

On saturday/sunday I’ve applied a whole bunch of updates from byzantium (around 188) and shutdown the computer after work was done.

Today - on monday - I’m getting the “An error occured, which can’t be fixed from the system - contact your systemadministrator” (roughly translated from german) and the gnome shell doesn’t start.
Interestingly installing another dm doesn’t work either, tried XFCE (lightdm) - it just hangs and crashes as well, so it seems, it has something to do with a wayland component, rather than the shell itself…

Thanks in advance for any help!

1 Like

Thank you, but they don’t really have a solution until now, except creating a franken-OS, which I definitely won’t do :slight_smile:

Yes, byzantium is broken.
Debian’s associated error report is:

This is a known transitional problem during the upgrade from GNOME
Shell and gnome-desktop3 3.34.x to 3.36.x. It will be resolved when
the transition finishes (probably sometime in the next 1 to 2 days),
but there is nothing that the maintainers of individual packages can do
about it right now.

Besides downgrading / frankendebian hacks, there seems nothing to be done but waiting for the upstream situation to resolve itself and PureOS taking it over. Tried the same (switch to lightdm) to no avail. Kind of annoying but a risk of the bleeding edge, I guess.

For now I managed to set the terminal font to a huge size (using instructions here: to make it readable at all on a 4k monitor and am using Linux old-school style :slightly_smiling_face:

Which leads to a totally different question: I thought that the packages taken to the PureOS repos are more (amber) or less (byzantinum) well tested. The described error sounds like that any test would have revealed it?

@jeremiah, did I misunderstand that? I’m actually thinking about switching to byzantinum, but maybe my imagination about how it should work is wrong.

1 Like

Amber is well tested and stable. Byzantium is a rolling release, not well tested and unstable.

Was this fixed for anyone yet? I’ve noticed a few more upgraded packages in Byzantrium since when running apt update && apt dist-upgrade (even some gnome things like gnome-terminal), but gdm3 still doesn’t start here.

Nope, it isnt fixed, updated today and nothing changed.

1 Like

The latest GNOME Shell is coming into Byzantium:
Basically the options are;

  • install from Debian unstable (this is tricky, but can be done.)
  • wait for GNOME Shell 3.36 to come into Byzantium (should be real soon now :tm:)
  • Install from source package (which requires you build it and have built the dependencies)

There is a bit more of a wait: (gjs is the blocker).


Just one thing that I don’t understand, this is fixed in Debian Testing now, why not in PureOS Byzantium?

Because there is a few days difference for the packages to transition in PureOS

1 Like

I’m not an expert on this, would it be possible to use Debian Testing repositories as they update and add the software needed for PureOS over that? What need PureOS nowadays to be PureOS?
Thanks for your answer.

Is this not the package which is in landing but not in Byzantium preventing gnome-shell from working

1 Like

I’d say yes, but it’s not really obvious why it’s not in byzantium already

1 Like

Another round of updates yet no working GNOME. I’m starting to consider switching to another distribution. Please fix this.

hi @jeremiah ! in the latest Debian testing i can’t raise the “network connections” front end under GNOME by typing in the CLI nm-connection-editor as non-root-user nor as root-user it’s simply not there … neither is pppoeconf

is this situation the same under PureOS Byzantium ?

i know i shouldn’t be asking this since testing-ANYTHING is recommended to be run under a virtual environment and not directly on bare-metal … but … could you oblige ? :slight_smile:

1 Like

Having backups and another system ready to boot on an USB drive, I don’t care encountering occasional breakage with a testing or bleeding edge distribution, other than the little extra time and loss of comfort it may create. Until this issue with Gnome, I’ve been very happy with updates in Byzantium, e.g. LibreOffice 6.4.

I’m sorry to be too busy with my daily job in this period to help deeply troubleshoot this issue; I’m unsure I could update today without breaking Gnome, as choosing the following dependency conflict mitigation in Aptitude would lead to a cohabitation between two installed versions of libgnome-desktop (3.18 and 3.19):

I’m thinking of not updating my main PureOS installation until the dependency confilcts to be solved in Gnome core and the transition from 3.34 to 3.36 to be almost complete.


Fixed it.
Downloaded manually the packages libgirepository-1.0-1_1.64.1-1, libgjs0g_1.64.1-3_amd64.deb and gjs_1.64.1-3_amd64.deb from, installed it via sudo dpkg -i PACKAGENAME, made an sudo apt --fix-broken install afterwards and upgraded via sudo apt upgrade normally.

Running pretty smooth until now :slight_smile:


I tried that, now apt --fix-broken install wants to remove: gdm3 pureos-desktop pureos-gnome
This seems like a bad idea? Did you go ahead? If so, what do you use as display manager now?

Maybe i forgot something, let me check when i am at my computer again.