HDMI Monitor Not Working Librem 15

My HDMI port suddenly stopped working a few days ago. I’ve had my Librem 15 for about 3 months, my second monitor worked fine out of the box until recently.

Fn+F7 and Settings>Devices.Displays show nothing.

I have tried two different monitors and two different HDMI cables, all function with other computers. I have also updated to the latest OS and restarted.

Any solutions?


I’m having the same problem on my Librem 13v4. HDMI was working fine until I restarted my computer today, when it suddenly stopped working.

Here’s what I’ve tried:

  • Attempted connecting to two different monitors and two different cables
  • Tried on firmware versions 4.11 and 4.9-Purism-2
  • Tried using my normal OS (Nixos with X11) and the PureOS live installation USB

It seems like my computer is still aware that the HDMI connection exists, but doesn’t see it as connected. Output of xrandr is as follows:

~ xrandr
Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
eDP1 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 290mm x 170mm
   1920x1080     59.98*+  59.93    48.01  
   1680x1050     59.95    59.88  
   1400x1050     59.98  
   1600x900      60.00    59.95    59.82  
   1280x1024     60.02  
   1400x900      59.96    59.88  
   1280x960      60.00  
   1368x768      60.00    59.88    59.85  
   1280x800      59.81    59.91  
   1280x720      59.86    60.00    59.74  
   1024x768      60.00  
   1024x576      60.00    59.90    59.82  
   960x540       60.00    59.63    59.82  
   800x600       60.32    56.25  
   864x486       60.00    59.92    59.57  
   640x480       59.94  
   720x405       59.51    60.00    58.99  
   640x360       59.84    59.32    60.00  
HDMI1 disconnected primary (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)

It’s working again now.

For future reference in case anyone else encounters this problem, here’s what I did:

  1. Unplugged all USB devices, the HDMI cable, and the power cable
  2. Turned off the computer
  3. Turned the computer back on
  4. Plugged back in the HDMI cable

My guess is that it was the powering off of the computer (and then powering it back on) that did the trick. When changing the OS and firmware versions, I was rebooting the computer instead.


Thank you! I was having this issue on my Librem 15 v3, though for me xrandr didn’t mention HDMI at all. Those steps worked for me as well.