Hotspot not working

Hey folks,

I’ve got data on my Librem 5. I am able to load a website fine with the Librem 5. I connected my laptop and old android device to the hotspot I turned on with the Librem 5 following this guide: Hot Spot and Tethering - Purism - Librem products documentation and neither of the devices connected to the purism WPA hotspot are able to access the internet.

I went into the terminal after reading the forums and seeing that an update fixed it for some folks, and ran

sudo apt update && sudo apt upgrade && reboot

When it was done I’m still left with a Librem 5 that has internet over the mobile data, and a hotspot that doesnt seem to want to share the mobile internet!

Help please o_O

1 Like

I had a go at this before, as I understand it, it doesn’t work and needs more development

1 Like

Those instructions work fine for me on my L5 (Stock PureOS Byzantium). Are you sure you have a data connection (the website loaded previously didn’t load via Wifi for example?). Or could you have changed some settings?

1 Like

Hotspot has not worked for me for over a year now unless I run a specific iptables-legacy command, try it and see if it helps : Most https sites no longer work through wifi hotspot - #16 by Loki

1 Like

Lately the hotspot works quite stable for me on a fully up-to-date Byzantium L5.

The mobile data connection is less stable though, so maybe you do not have a mobile data connection. I recommend to install this package to see if you have an internet connection: network-manager-config-connectivity-pureos. An icon will be shown top left if there is no network connectivity.

To mitigate losing de mobile data connection, follow these instructions.

And here an older post regarding using the hotspot functionality on the L5.


The data works fine on the librem 5 itself - without issue. I can see the hotspot with multiple devices. Any of them that connect get assigned an ip address and then procede to tell me that there’s no internet. I double check my L5 and the internet is there and working fine, just non of the devices on the pureos hotspot can - This is such a ridiculous deal breaker for using this phone. If people could carry around their ‘old’ android phone with wifi as a backup to using their L5’s hotspot - it would be a no brainer while i learned to cope without some apps, but not being able to hotspot is really upsetting when it’s clearly been an issue for a very long time in the gnome DE.

Who do we submit bug reports to? Purism or PureOS or GNOME DE for this error?

1 Like

Since a few asked if i was running the current version, i turned on my wifi to ssh into the phone and inxi -Fz - I would have done it from the phone to copy and paste here, but this website is so bloated it was very annoying to try and do it from the L5.

purism@pureos:~$ inxi -Fz
System:    Kernel: 6.6.0-1-librem5 aarch64 bits: 64 Console: tty 1 Distro: PureOS 10 (Byzantium) 
Machine:   Type: ARM Device System: Purism Librem 5r4 details: N/A 
Battery:   ID-1: max170xx_battery charge: 8.3 Wh condition: 15.4/13.9 Wh (111%) 
CPU:       Info: Quad Core model: N/A variant: cortex-a53 bits: 64 type: MCP 
           Speed: 1000 MHz min/max: 1000/1500 MHz Core speeds (MHz): 1: 1500 2: 1500 3: 1500 4: 1500 
Graphics:  Device-1: gc driver: etnaviv_gpu v: N/A 
           Device-2: imx8mq-cdns-dp driver: cdns_mhdp_imx v: kernel 
           Device-3: imx8mq-dcss driver: imx_dcss v: kernel 
           Device-4: imx-audio-hdmi driver: imx_hdmi v: N/A 
           Display: server: No display server data found. Headless machine? tty: 108x46 
           Message: Advanced graphics data unavailable in console. Try -G --display 
Audio:     Device-1: imx8mq-cdns-dp driver: cdns_mhdp_imx 
           Device-2: imx-audio-hdmi driver: imx_hdmi 
           Device-3: simple-audio-card driver: asoc_simple_card 
           Device-4: simple-audio-card driver: asoc_simple_card 
           Sound Server: ALSA v: k6.6.0-1-librem5 
Network:   Device-1: regulator-fixed driver: reg_fixed_voltage 
           IF-ID-1: usb0 state: down mac: <filter> 
           IF-ID-2: wlan0 state: up mac: <filter> 
           IF-ID-3: wwan0 state: unknown mac: N/A 
Drives:    Local Storage: total: 148.5 GiB used: 7.43 GiB (5.0%) 
           ID-1: /dev/mmcblk0 type: Removable model: 032GB2 size: 29.12 GiB 
           ID-2: /dev/sda type: USB vendor: Generic model: Ultra HS-SD MMC size: 119.38 GiB 
Partition: ID-1: / size: 28.12 GiB used: 3.62 GiB (12.9%) fs: ext4 dev: /dev/dm-0 
           ID-2: /boot size: 450.3 MiB used: 188.2 MiB (41.8%) fs: ext2 dev: /dev/mmcblk0p1 
Swap:      ID-1: swap-1 type: zram size: 1.42 GiB used: 0 KiB (0.0%) dev: /dev/zram0 
Sensors:   System Temperatures: cpu: 35.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 244 Uptime: 4h 48m Memory: 2.83 GiB used: 1.55 GiB (54.8%) Init: systemd 
           runlevel: 5 Shell: Bash inxi: 3.3.01
1 Like

Just dropping in to let everyone know that my hotspot worked from day one. I got my phone March 2023 for reference. I also carry my Android around as a backup and connect to the hotspot exactly as you are suggesting just to watch youtube videos because of the hardware acceleration on that device.

Karen, the instructions you followed are 100% correct and none of them ask you to fiddle with the network components manually so it is unlikely that you modified anything in a way that would interfere with this functionality.

So, the two main steps for troubleshooting this are:

  1. Open up a support ticket with Purism. If you did not do any command line tweaking, they are responsible for making their software works. I can confirm their software does work, it works really well in the exact use case that you suggested and this could be a defect of some sort that they need to address.

I don’t know if they have time to review this issue properly though.

  1. If this were me, as a sysadmin, I would reinstall the entire OS on the device and start from scratch. The instructions for enabling wifi should work. One of the things that I find when I get into situations like this is that I forget that I fiddled with something on the command line and when I cannot get something to work it is way easier to reinstall and open source environment than to untangle some spaghetti tweaks I may have done.

Again, probably not very helpful and you are feeling frustrated. I just wanted you know that the feature does and should work.

To anyone reading this, do we have users experienced in troubleshooting this issue? This would be fastest troublshot by someone familiar with how this works on the L5. For your reference, the L5 runs a standard Linux environment, probably Debian. However, not done and digging to know:

a) What customizations were required relative to bone stock Debian install.

b) The gui that you are using on the L5 is Phosh, that was built by Purism from scratch. I am not familiar with the environment and don’t know what standard tools the gui interface is using to enable / disable the hotspot.

I write all of that to help you start to visualize how to start thinking about troubleshooting. The feature does work and regular people not interested in fiddling with system administration of the phone and just want the product to work should think about reinstalling the phone software from scratch so that you have a from factory baseline to work with. With respect to your question about where do you post the issue, your starting point is with Purism because it is a base feature of the phone, it isn’t working and they should be helping you with that.

Does that assist you in any way?


Ya, I’m down to re-install - I’m guessing it’s similar to the pinephone? I had half debated installing manjaro phosh because that’s what ive been using for a long while and my favourite desktops are manjaro - but i do have 2x debians, one a desktop/client and the other is a headless server.

other than installing SSH today so i could run nmcli and a few other troubleshooting ideas, it was stock. I had run apt update/upgrades to ensure i was playing with it up to date as I basically haven’t touched it since it was mailed to me this past July (3-4 years after my order? i forget now).
I found a uuu precompiled binary from here GitHub - nxp-imx/mfgtools: Freescale/NXP I.MX Chip image deploy tools. (manjaro doens’t have an offical package)
and I will get the flash script from here:
Librem5 / librem5-flash-image · GitLab

I’m noticiing that the flash instructions say to ensure your python is up-to-date - but it doesn’t indicate if it’s python 2 or 3. I have 3 installed for building custom android / lineageos roms. will this work? or do i need python2?

By default, the script will assume it’s flashing Evergreen; however, you can pass in the different version to the --board option. Use librem5r2 for Birch and Chestnut series phones, librem5r3 for Dogwood.

I am also unsure of what version i got, but guessing since I ordered early on during the gofundme or whatever that kickstart thing was, i got an evergreen?
my inxi replied r4, so im extra confused
(edit: figured it out here Selling Librem 5 - unsure which batch - #6 by Skalman ). in this helpful post

System:    Kernel: 6.6.0-1-librem5 aarch64 bits: 64 Console: tty 1 Distro: PureOS 10 (Byzantium) 
Machine:   Type: ARM Device System: Purism Librem 5r4 details: N/A

thanks - yes, this was the most helpful response and least condescending

1 Like

this is helpful for re-installing from manjaro/arch:

also the errors about jenkins which led me to this post via search engines tell me that you need python3 - which is nice because i didn’t want to have to configure more than 1 version

1 Like

Still not working

1 Like

@karen did you see my message above? I have exactly the same symptoms as you, also after a reinstall. My understanding is that it works for some people and not for other depending on the MTUs of their internet connections. The fix is to tell the Librem 5 to calculate the PMTU (if I remember correctly) automatically and then it works everywhere. (I’m still confused why it isn’t enabled by default.)


I notice on your screenshot that the Wi-Fi slider is off. For me it is on when using the hot spot. It surprises me that it can be off and your hot spot seems to be on.

Note that I’m still using the “old” (Redpine) Wi-Fi module.


@janvlug I will try deleting my saved wifi spot and turning it back on and then turning on the hotspot - I’m pretty sure I tried that before installing Plasma/PostmarketOS and Manjaro/Plasma. I’ve been trying a few other operating systems to try and fix it.

@tendays i did try copying and pasta’ing (haha) the solution there, and when it was done there’s no entry in the iptables after running it. I tried logging out and logging back in to restart the service and it doesn’t appear to save the changes and it still didn’t work for me. I will look closer into it. I actually found your post from last year and referenced it in my complaint, because I tried the stuff there but it doesn’t seem to be persistent, and I also read that there might be a “best practices” case for putting it somewhere else, and I’m wondering where / how that is. How would I determine my MTU if Librem 5 is calculating it incorrectly and set it manually? I saw you used Wireshark, which I have on my Qubes Kali laptop and could check out, although I’m kinda new at that and don’t really understand what I’m looking at. I think MTUs are kinda like packet sizes/things that I used to set the size of back in IPX/SPX and dial up modem days manually when I was a kid?

1 Like

So this isn’t getting fixed anytime soon I guess.

This has been about a year since everyone’s known about it. There’s a few possible fixes but it doesn’t appear anyone is eager to address it upstream, or forking networkmanager to fix it (understandably). What a bummer for users.

anyone wanna buy a Librem5? -_-
1 Like

Following the link from the link suggests that it has been fixed. So there must be more to it.

1 Like

ya, there’s 4 links in there. the last one talks about needing to fork nm or having fixes done upstream -

I also found this which was interesting this evening: it talks about another solution but looks like it only works with certain types of modems. not sure if it’d help this situation here. I wish the --clamp-mss… thing worked for me, but it’s just not working, and it’s not working in anything that uses the network-manager, which is basically everything.

The take aways from that article:
“…However issue was resolved with switching modem data connection over to ppp0 instead of default wwan…” “…Problem with wwan0: 4G LTE MTU is either 1428/1430 for some major US carriers. This resulted in path-MTU difference when wifi clients (1500 MTU) tried to access large websites and failed…” non of this means anything to me, as I can only kinda glean some idea of what’s the matter as a user.

I lent my pinephone to a friend who needed a basic phone, im curious if it works on that or not. (mobian phosh)

1 Like

My apologies, I cannot help at a deeper level, I don’t have time to dig in. Looks like we have hit an edge case here and this thread is important to bookmark as a just in case when I travel.

Will be interesting to see if anyone can compile an upstream version of NM that has the fixes and get it working.

True. So to be clear, the link I was referring to is: Sparklan card wifi hotspot does not work (#452) · Issues · Librem5 / linux · GitLab

which seems to be a problem in negotiating the encryption modes and is marked as “closed” and “hotspot now works”. However that might have been specific to the Sparklan card. So the first question would be: which card do you have?

However that problem (encryption modes) is quite different from the problem with PMTU.

Yes, PMTU is fairly technical and I think it has been discussed in more detail elsewhere in this forum. The basic problem is … the size of packet that each link in the path from you (the hotspot client) to whatever web site you are using can handle. Normally this would be handled automatically but having the hotspot in the way makes things more complicated.

Note that problems with the size of packet can mean that some internet communication does work e.g. if the protocol can operate successfully only using small packets. The effect of that can be, for example, that secure web sites don’t work but insecure web sites do (at least for some web pages).

So you probably need to narrow down “not working” to what specific problem you are experiencing and what specific card you have - and then maybe Purism Support has the current best practice solution.

1 Like