How to contribute as a non-developer?

Hi,

I am wondering how I could contribute to any community activities of L5 as a non-developer?
I can (basically) use Shell, but can not code or understand what needs to be done when looking into Purism Git (source.puri.sm). Or understand content of several chats in Matrix channels. So contributing code is very limited, basically “0”.

Translation(s), documentation(s), testing, feedback of any kind, whatsoever?

You can run the Librem 5 images in Qemu on your PC and try out all the available apps and write bug reports for any problems you find. See:

You can work on translating the Librem 5’s software:

You can write up documentation for each of the apps on the community Wiki. There is lots of work there that needs to be done in terms of documentation.

You can also join Reddit’s r/Purism and simply try to be a voice of reason to respond to the Purism critics. (This is a thankless task, but necessary in my opinion.)

2 Likes

I would love to do so. Now I downloaded all necessary pieces, sitting in front of the unlock screen and being able to operate, because I cannot slide to unlock. Help???

Already done for my language.

Potentially, after running QEMU is done. See above.

I like actions more than word. That is why I try to support here. Surfacing Evergreen best way should speak more than answering threads of haters and trolls.

The mouse on my laptop works fine as a finger touch with Debian 10 as the host. What was the exact command that you used to execute qemu?

For the mouse, maybe something to do with this? https://source.puri.sm/Librem5/developer.puri.sm/-/issues/151

I use virt-manager and have it set up as a normal PS/2 mouse and it works fine:
<input type="mouse" bus="ps2"/>

C:\path\to\qemu-system-x86_64.exe -drive file=c:\path\to\qemu-x86_64.img,index=0,media=disk,format=raw -vga virtio -display sdl,gl=off -m 2G -L Bios -boot menu=on -rtc base=localtime,clock=host -parallel none -serial none -name PureOS -no-reboot

I do not know.

I experienced this same problem when I first used the Qemu image. Pressing space got me past the “Slide up to unlock” screen and then my mouse would work for pressing the buttons for the password. That may work for you.

1 Like

Same here. Thanks for the hint. Now I am stuck with typing or pressing in the passcode. Simply does not work or is so laggy. No chance.

Man, you make it hard to help …

The password is 123456
Make sure that you have VT-x enabled in your BIOS/UEFI. Qemu is laggy running inside Debian and PureOS, but it is usable.

I know, thanks. I can not type it in.

What does that mean? How to?

Before I was wrong. There are missing translations. Did one for Chatty and now raised an issue in source.puri.sm asking developers to merge it into repo. Hope that works out well. When successfully done, I will do more translations.

See: https://www.howtogeek.com/213795/how-to-enable-intel-vt-x-in-your-computers-bios-or-uefi-firmware/

You can also type the password with the keyboard. For me, I think that the mouse problem only happened the first time using the VM. I think if I get past the login screen, the mouse works and if I reboot, the mouse works on the login screen. However, it has been a long time since I have used the Qemu image since I already have a Librem 5.

Now I tried to pull the .yaml files for translation from git, finalize them and commit them back to master branch. --> Error message.
Is there a how to … work with gitlab in source.puri.sm anywhere?
Or am I just not allowed to push back files to repository.

Again: Hard to help for non-developers, but still struggling to cross the boundaries.

There is the Contributing page which covers quite a lot of different things, including submitting patches. The way that most repositories are set up on source.puri.sm means that you can’t push to the master branch. Usually, you have to follow these steps:

  1. Fork the repository on source.puri.sm so that your account has a copy of it.
  2. Clone the repository locally.
  3. Create a branch for the changes you want to make, then make the changes:
    git checkout -b <name>
    where name is something meaningful.
  4. Commit the changes.
  5. Push the commit back to your fork at source.puri.sm:
    git push origin <name>
    where name is the branch name you used.

This last step should result in a message telling you how to make a merge request for your changes.

There is another way to do things but I think the workflow is not quite optimal. This is to create an issue first, then create a merge request for that issue by clicking the Create merge request button. However, I think the instructions it gives when you click the Check out branch button are not correct for the workflow we have. :frowning:

A workaround that might be easier is to create an issue in your own fork of the repository, then click Create merge request for that issue. Unfortunately, that wouldn’t help for existing issues.

2 Likes

Hi, I tried to download qemu-x86_64.qcow2 as mentioned in the manual (2.), but i cant’t find it :-(.

It should be available from this page, at least for a few days. The Image Build page lists the images for different hardware.

Thanks, I got it.

Any idea if contributing to translations will be made easier (or even possible) anytime soon? Any movement on DamnedLies integration problems (like translations being in limbo) or any of the other issues with the process?