How to Fix Google Links to missing

When using Google to search for PureOS/ism stuff and you get:

This site can’t be reached

The webpage at Troubleshooting screen capture issues might be temp…

Note the last digits, in this case are “/2292”. It needs to point to a article number so, in the URL that shows https… , add /1 to the end so it reads /2292**/1**

That should take you to the first article in the link that comes close to your query.



Can you reproduce the problem with a less “evil” search engine?

What did you search for?

For me, that particular topic does work - but I guess it may have been temporarily unavailable.

The URL is valid with or without the “/1”. If you specify “/1” then it will be stripped out e.g. redirected. This is Discourse behaviour.

If I use my search engine to search for “purism troubleshooting screen capture issues” then the first hit is the right page, the URL shown excludes the “/1” and clicking on the link works.

I’m using Firefox (probably up to date).

1 Like

It’s been like that for months.

Here - this is a example.

Open Google
In it’s search box, type: pureOS cheat sheets
Google result could be: (in black & white)

About 29 results (0.37 seconds) 
Newbie: PureOS for Beginners Resources
Purism community › Software › PureOS
Aug 17, 2021 — As many advised here, I have begun and maintain a cheat sheet of terminal commands I have learned, and may need again, which is also helpful.
Phosh keyboard shortcuts - PureOS - Purism community
Jun 14, 2021
For a new PureOS/linux user - #24 by Wayne
Nov 6, 2020
L14 and new to linux - PureOS - Purism community
May 19, 2021
HOWTO: build install a DKMS module? - Purism community
May 7, 2022
More results from

We’ll use second link because I already visited the first (‘Newbie’) link ergo cookie take me to correct page without adding the /1

Phosh keyboard shortcuts - PureOS - Purism community
Jun 14, 2021

In the URL status bar, I see:

Note the post # at the end of url.

Because I had not visited that link via Google yet, I get:

This site can’t be reached
The webpage at might be temporarily down or it may have moved permanently to a new web address.

Without providing TMI, I added the /1 to the URL and end up at the right page.

That’s OK, I won’t hold it against you.

My surmization is that if one has visited the url before, the cookie adds the /# whatever that post number is/was.
Never the less, others may run into this phenomenon and without knowing why the pages they try are missing what would you do.
Then again, if they do get the error, and don’t read this, they’ll give up and go to somewhere else. Meh!

1 Like

Hi Sharon,

i do not have this issue either. But i do not use google as well. Your Link works fine here and the URL resolve the whole thread and the number got just add via Java-Script i think when you are scrolling down the Posts. On Mobile it will be different instead of using a full high resolution Desktop.

Other will ask in Future some A.I. Assistant about some solution, which explain everything and every step. I am looking forward to think that privacy searching humans, and programs will find and follow the Text Info, using Search Page and some intention to understand the displayed information after follow some link.

You are right its some kind of a burden to get inside of old Web applications or Books. But on Linux everything will be there and you have, or can do more steps to dive in deeper in the fascinating complexity of easy to understand (like someone say: its done when you could not leaf a part away to work perfect) technology.



1 Like

OK. Let’s look at a car, big-screen TV, or kitchen range. Pick any.
We know how to start a car, changes the oil maybe, even change a tire. We know how to tune in the radio, and such. But, do we know how to get under the hood and re-bore the cylinders, replace a blown tranny, repair a leaking gasket etcetera? Why should you. That’s what mechanics are for.

With most people I know and those I see with a phone, know how to navigate it, get updates and upgrades, play tunes, watch a video, even turn it into a flashlight!

Get my point?

Back to topic, I did say it happens to me. It happens every time. It’s not as if I don’t know how to use any search engine. The fault is not always the OP.
One day I thought, add the post number. Voila!. A little research and I see why. Why post my experience at all? Yeah, I’m wondering that now too.

BTW, I made it very clear that the OP was to help, not asking if I should fix anything.

I use a variety of different search engine pending on my needs but yes, Google is my main SE for 3 reasons: as sayings go,

  • Keep your friends close, and your enemies closer’,
  • Know thine enemy,
  • The enemy of my enemy is my friend.

Thanks Chris for your input,


OK, so which browser are you using?

Cookies or cache could be a part of the puzzle. I have Firefox configured to toss all cookies and cache every time it is closed (that setting has its upside and its downside).

If you want to look into this more, see whether you experience the same behaviour with another forum that uses the Discourse forum software.

FWIW, in order to search for information from this forum, you may have more success using the search mechanism that is built-in to the forum (magnifying glass icon at top right). Not only may it work correctly (it always does for me and it offers better functionality) but it will be private c.f. using :pig_nose: for your searches.

1 Like

[quote=“irvinewade, post:6, topic:23128, full:true”]

Thaaats confidential :crazy_face:. Seriously, it is the enemy that I know remember? - enemies closer? I use Google. Google doesn’t use me. It records what I choose. I use DDG, Tor or StartPage

Incognito mode?

It is refreshing to see that someone else speaks Canadian :slightly_smiling_face:

I see I didn’t answer your question in post #2 above. Here it is:

Haven’t tried and doesn’t matter to me but, forsaking brevity, I tried using FFox and Chrome
They had no problems finding and opening the page.
Told ya :laughing:
It’s Google and on some Chrome browsers. Maybe even 1