How to install anbox?

I think the answer is “don’t”. Refer: Anbox on Byzanthium

Well this is really bad news.
Is there currently a way to run android apps on the librem 5?

Because the bank basically forces me (stupid eu law) and then there are lots of people that insist on using whatsapp.

Search the forum for waydroid. I think I saw someone(s?) getting it to work.

If it is currently possible to install waydroid can someone please give me detailed instructions on how to install it? As i said earlier i’m not a linux expert by any stretch of the imagination unfortunately but i really need to get this app to run…

Using the search box (magnifying glass icon), type “waydroid” and then select “Options.” Sort by “Latest” to see the most recent threads. One of those (3 or 4 entries down) has a link to working instructions.
Check out the instructions, then ask questions back here about the bits you don’t understand, if any.

1 Like

I found this post

I tried following these instructions:

But i only get until the step
sudo dpkg -i libglibutil*.deb

Which returns an error that libglibutil*.deb cannot be accessed / does not exist.

I need more details in order to be able to answer. How did you proceed to build the libglibutil packages?

I did nothing but following these instructions

As i said i’m not an linux expert.

Then look into the parent directory.

And for what should i be looking?

.deb files.

The instructions provided by @pini work, but since it’s using software rendering everything is incredibly slow and some system components are unstable.

Through the past week I have worked on getting Waydroid to work without having to switch to software rendering:

At this point, I don’t recommend messing with Waydroid if already provided instructions are not enough for you to grasp everything. I’m hopeful that this will change soon though!


I’m sorry for the late reply.
I attached some screenshots. I can’t find any .deb files.

here is the terminal log:

I would love to wait but at this point librem 5 is of very limited use for me if i can’t run android apps.

dpkg-source: Fehler: unmöglich, mit Quellformat »3.0 (quilt)« zu bauen: unter ../libglibutil_1.0.66.orig.tar.{bz2,gz,lzma,xz} wurde kein Tarball der Originalautoren gefunden
dpkg-buildpackage: Fehler: Unterprozess dpkg-source -b . lieferte Exitstatus 25
debuild: fatal error at line 1182:
dpkg-buildpackage -us -uc -ui failed

As stated by these lines, the build failed.

Yeah but why and what do i do now?

I can’t help you further if you’re not familiar with building packages.

Great, that renders the librem 5 useless for me at this point.

What do you consider soon?
I know that’s not your fault but i’m sitting on a 2 grand phone that is useless for me without the ability to run android apps.


Because i can’t use my credit card for online purchases then and i can’t communicate with people that insist on using whatsapp.

I don’t know all the specifics of the app you need, but does this PureOS app provide a similar function?

No it has nothing to do with id.
What this app does is if i purchase something with my credit card online i need to confirm in the app that i really want to authorize this payment. Basically 2 factor authentification.

It’s a stupid european law that does not exist in the united states.

Ah, OK. Sorry.