How to reconnect to Mobile Broadband

Sometime in my L5 the connection to the Mobile Broadband gets lost. In the upper status line the indicator for the signal strength and the 4G disappears. I found no way then rebooting. Is there any, even from cmd line?

1 Like

I do not use it myself but craftyguy wrote a script that is suppose to fixe it at the bottom of this issue:

I used it already two months ago. Call is not working after running the script. See my last comment in the issue.

1 Like

So using the kill switch doesn’t fix the problem?

No, toggle off-on (some times) does not help.

I was for the 1st time able to recover the modem and make a phone call after it with adding to the above described procedure the following command:

sudo systemctl restart ModemManager

Just to show how much of a pain this problem can. I spend a lot of time in desktop mode using either of the web browers. As I write this, another failure occurred Mar07 @ 14:12. Sigh.

Feb26-1726.log Feb28-1711.log Mar03-1758.log Mar05-1842.log
Feb26-1740.log Mar01-0849.log Mar03-1929.log Mar05-1928.log
Feb26-2056.log Mar02-1844.log Mar03-1947.log Mar05-1947.log
Feb26-2123.log Mar02-1958.log Mar04-0427.log Mar06-0731.log
Feb27-0018.log Mar03-1101.log Mar04-2101.log Mar06-1227.log
Feb27-0912.log Mar03-1140.log Mar05-1701.log Mar06-1230.log
Feb27-1215.log Mar03-1216.log Mar05-1806.log
Feb28-1344.log Mar03-1725.log Mar05-1824.log

1 Like

I never managed to make a phone call with my L5 evergreen (received last month), even as the signal strength (4G) indicator almost at maximum. Every call was immediate ended with “call ended”. On the advice of somebody in this forum I changed the sim card for a new one: no success.

The last update (Nov 16) indicated a modem update, so hopeful I tried again to make a phone call. To my surprise and disappointment the signal strength indicator showed no signal. In de mobile setting the strength indicated 0. At least consistent…

sudo systemctl restart ModemManager

Did not improve the situation.
N.B. on my daily use android phone signal strength is “good - maximum”.

Has anybody similar experience? Any advice?

I’ve got my Librem 5 for one month too and I’m facing the same issue in France.
I’ve not tested with a new sim card from another mobile carrier.
I’m talking with Purism support team. I’ve given them outputs from mmcli command and from AT commands.

They sent me the instructions to update the modem firmware with the one generated on 2022/09/30.
But it didn’t solve the issue.
I’m waiting for new instructions to identify what’s going wrong.


Thanks. I’m at the moment too occupied for direct conversations with Purism. Please inform us at this forum when you reach a solution :pray: .

1 Like

Support team told me they are still working on the issue.
I’m still waiting for new information.
I’ve done tests with a SIM Card from another french mobile carrier. The behavior is exactly the same than with the previous SIM Card.
This issue is probably observed for SIM Cards from several carriers.
Support team probably does many tests to find the root case and to provide a solution working in any cases.


Thanks for informing. Hope the issue will soon be resolved.

Hi i’m in france too and call, sms and data work out of the box with free and 4g. I received mine 2 or 3 weeks ago.

Only mms didn’t work.

At the update of yesterday (Nov 30) the signal strength indicator is back, incl 4G sign. But stil all cals are immidiate terminated by “call ended”.
Modem status

  • Network Type: lte
  • Signal Strength: 59%
  • Network Status: Not Registered

Device Details

  • Model: 0
  • Firmware Version: MPSS.JO.2.0.2.c.1-00032-9…
  •         IMEI: 86XXXXXXXXXXXX

Anny thing wrong here? If there is a need to register, how to?

If that’s the status all the time then I think it means you are not connecting successfully to the mobile network at all.

Yes, my idea :woozy_face: What to do, signal strength is now 78%, same negative result.

I manual choose the SIM provider (Maxis in my case) and selected broadband (tried grs also). Anny suggestions?

Yes, but getting an adequate signal is just the first problem. Secondly, you have to pass muster with the mobile service provider. The SIM has to be read successfully and be accepted by the provider, and the associated account has to be good.

I would say: try that (new) SIM in another phone - to confirm that it works there.

Also, forget about making a phone call. Just see whether you can get mobile data (assuming that you expect that to work on the plan associated with the SIM and assuming that mobile data is enabled in the Librem 5). For this purpose, you should kill switch the WiFi - so any internet can definitely be attributed to mobile broadband.

1 Like

May be worth double checking your APN settings while you’re poking around.

1 Like

Have you checked if the VoLTE is enabled? If not, you can use this little app to enable it:

1 Like

My SIM is provided by the provider (MAXIS) and already successful used in my SAMSUNG android phone.
I also tried data only and switched of the WiFi by means of the HKS. This resulted on FF in “server not found”

I tried some more or less randomly, with no effect. Is there a preferred setting?

Thanks, I will try this when I have some free time.

1 Like