I Never Got It To Work


#1

(I too, get the “awaiting shipment” on my account. Seems odd for an electronic service. My bank says the amount cleared.)

After several attempts, I was never able to use librem one email. There were several emails between me and support.

Has anyone here got it to work yet outside of company staff?

After some attempts at log in page said I was “logged in” but my registration was “pending”. Now it won’t let me log in at all. And it no longer recognized my recovery email like it did yesterday. Is it because I have gone past the 24 hour “pending” registration period?

I have better results at work with IBM and Cap-Gemini at least they have SLA escalation. I can’t believe I paid 7.99 for the bundle and can’t get the only service I’ve tried, (email) to work.


#2

Does your password have non-alphanumeric characters in it? I think there is currently an issue with that. What did support say?


#3

Hello @tracy,

My colleague made some questions for you in the other thread you have opened regarding the same issue.

You are also in email correspondence with us. You are free to ask as you like of course, but it would be easier for us if we communicated via one channel.


#4

#5

#6

Yes I did get it to work, with the support of Puri.sm staff. I am now among the 6147+ happy people on the main librem.one page!

My intent was to try it out because the lack of meta-data sharing appealed to me. If it worked I’d subscribe for a year and add the family bundle.

Let’s see how it goes. Enjoy the ride!