Inability to Paste Images in Forum

Is anybody here having problems pasting images in their posts?

Or is it just me? I’ve been unable to paste images as I regularly have done, either in this forum or another Discourse forum I frequent. I can paste text just fine, just not images, screenshots, etc.

I’ve tried different browsers, relaunching in “safe mode”, different computers, disabling VPN, etc., to no good effect.

I’m not getting any kind of error message, just nothing happens when I try to paste.


Worked for me just now on Firefox 98.0.2, copied from Spectacle into the text editor here.

Testing: toollogo
Can you see tools?

Yes, I see the image.

“it’s not us, it’s you.” Sorry.


You are one of the most frequent image posters. Any chance forum has limits for that?

I considered that, but I have the same problem in another Discourse forum where I haven’t posted a lot of images.

EDIT: OK, I found a way that works…

Before, I always opened an image, copied and pasted it into LibreOffice Writer, compressed a little if necessary, or edited in GIMP, then copied from there to the forum. (Not working now.)

I just tried using the upload button in the editing box, and that does in fact upload my image. (Who knew???) Guess I’ll do it that way now.

1 Like

I’m not a prolific image poster but I have always done it via the upload button.

Your icon: 45

I guess something about drag-and-drop /? cut-and-paste has been broken.


Maybe see if your browser has any errors printed in the console when you drag an image into it?

I don’t see any errors.
By the way, I can drag and drop an image successfully, I just can’t paste an image (via right-click-paste or from the File menu).

You might need to document exactly what steps you are trying but I couldn’t get copy-and-paste to work from either nautilus or eog (it would just paste a pathname into this box, which is privacy fail as well as functionality fail) whereas copy-and-paste works via libreoffice i.e. nautilus paste to libreoffice works then paste from libreoffice (in all three cases attempting to paste an image into this box).

I think the clipboard has become a lot more complicated in recent years.

Yes, I have always gone the LibreOffice Writer route, with a copy and paste of the image. And even using the Upload button here to upload an image file incorporates the actual file name, which I suppose is a fail as well.

I wonder if the lost functionality has to do with the about: config adjustments I did a few weeks back. I implemented some of them, but also reverted some. There is one that affects the clipboard, but even reverting and restarting doesn’t seem to have an effect on the forum issue.

At any rate, I can’t even paste images using GNOME Web, which I haven’t tweaked at all. :man_shrugging:

Potentially, yes, but not as bad as full pathname.

1 Like