Installing Flathub Repository & apps

Following @Skalman’s small tutorial at GNOME Maps debugging adventures on the Librem 5 I installed the Flathub repo to test Maps (scales well, but no way to use Location…yet).

In the process, these flatpak apps became available for download from the PureOS store:

Blanket - listen to different sounds; fall asleep in a noisy environment
Podcasts - listen to podcasts
Giara - Reddit app
Feeds - RSS reader
Dialect - text translation app based on Google Translate
Tootle - Mastodon client
Foliate - ebook reader
Komikku - manga reader
Flatseal - review and modify permissions for Flatpak apps
Hydrapaper - wallpaper manager for multiple monitors
QiFlora - monitor plants using Mi Flora devices
Vehicle Voyage - track vehicke service history

Thought I would mention these for your information; not everybody will want to add Flathub, but it’s there if you want it.


Out of curiosity, because of Maps or because geolocation does not properly work yet?

When you tell Maps to find your location, it pulls up a dialog box instructing you to enable Location Services, but clicking on it doesn’t take you anywhere. There is not a setting for Location Services in the L5’s Settings menu yet.

Edit: Oh wow, I just realized there IS a Location Services toggle in Settings, under the Privacy section. I’ve had it on all this time, but it still doesn’t seem to do anything (yet), even when trying to get location in Maps. Sorry for the confusion.


For location access from Flatpak, being it Gnome Maps or Pure Maps, Geoclue2 agent has to be hooked. Corresponding issue:

From the beginning of the issue, I think notification support was added, but not geoclue.

For a hack workaround, try to start /usr/lib/geoclue-2.0/demos/agent in terminal and try to start maps application after that. Haven’t checked it (no access to L5), but I hope it works.

How does Giara work for you?
I tried it in QEMU several weeks ago and it didn’t really fit the screen well.

I installed to test it, but it seems to want to force a login to Reddit. I don’t have an account there, so…

I’ll do some investigating. Thanks.

1 Like

Yes I too noticed that, but at least it is being worked on:

Terminal: “Geolocation service not in use”

Maps: Offers a Yes/No option to enable location. Choosing Yes dismisses the dialog, but the location button on the map doesn’t trigger anything.

giara’s first window that shows is the login page you cannot pass it before setting up the reddit account

do you know whether Gnome Maps work without Flatpak? or any other GPS-requiring app? when installed from DEB, they are granted the permissions

I tried it before and it wouldn’t even launch for me.

I see, that’s a problem. Let’s see if Purism developers or other users will chip in and explain how to enable GPS on L5.

1 Like

Just installed Pure Maps (flathub version). Looks and behave really nice on the screen.

Is Pure Maps able to get the geolocation from the Librem 5?

See this discussion: PureMaps (flatpak) on the L5
I’m going to go test outside sometime soon, maybe later today.

Responding to the first post, I found that to be the case on the Pinephone too. I’m guessing the store is the same between Mobian and PureOS even if it’s called something different.

If it works the same way on the Librem 5, there’s a new “source” dropdown in the top right that will default to Flathub. You can choose whether to install apps from the regular repository or from Flathub there.

Flathub is added as a repo, but I don’t think it defaults to only that. When searching for a package, I find debians as well as flatpaks. (That said, I’m only seeing the flatpak version of Gnome Maps for some reason, but I’m sure I could install the debian package from the terminal.)