Installing Programs - Firefox

I am a complete newbie to Linux and am not a techie, but just received my Librem 14 because I believe in the concept and am trying to learn.

Right away I am noticing issues doing basic things using epiphany as my browser. Many sites I visit seem to be have differently or seem to not like epiphany. I was told that Firefox may be better. But am so used to windows, I don’t know how to install it. Or drivers for my printer or my mouse.

Any tips are appreciated.

$ sudo apt list firefox-esr -a

Please continue as already confirmed here:

And this HP approach might give you some idea in which direction you need to search the Web on how to. Procedure is the same as above (just another package name used):
$ sudo apt list hplip
$ sudo apt install package-name

1 Like

Another option would be to use the “Software” tool.

When you are on the desktop clik on activities, then in the search bar type software.

You will see it show up, it looks like a white shopping bag with a blue circle on it.

Then have fun :slight_smile:


Hi @TheLostG. You might find this FAQ about PureOS (and the rest of the wiki) helpful:

Yes, it would be, just not (at the moment) for Firefox or Firefox ESR (I guess, currently using another Linux distro).

[Original post deleted]

Edit: Judging from the responses below, I must have steered you to bad advice, so I’ll leave it to the others to assist now. Sorry. :slight_smile:

1 Like

@amarok, let us be aware, in addition, that sudo isenkram-autoinstall-firmware is new useful Linux command, introduced with Debian 11 “bullseye”.

Yet, as you already know, adding main and/or contrib from Debian sources should not happen, should not coexist within PureOS, by focusing here to “the missing drivers”, as you kindly pointed out in your post.

1 Like

PureOS on the Librem 14 will most likely recognize your printer and your mouse without you having to do anything. Have you tried plugging them in?

Also, it is definitely NOT advised to mix in software from another Debian repository or you might end up with what’s called a “FrankenDebian” (a Frankenstein system). I myself was warned about doing this back in 2018 after I got my Librem 15v3.


Thanks. I opened the terminal and typed in:
apt install firefox-esr

I received an error that says:

E: Could not open lock file /var/lib/dpkg/lock-frontend -open (13: Permission denied)
E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), are your root?

I’m definitely doing something wrong….

1 Like

You need to prefix the command with “sudo” and then enter your password. Aka “sudo apt install Firefox-esr”

thanks I seen to be pat the error now. but now the terminal is asking me for my pw.However, when I try to type it in, nothing seems to be typing. No characters are entering in the command line.

1 Like

Most applications will hide the display of the characters you type into a password field to prevent curious eyes looking over your shoulder and seeing it. Go ahead and type your password and press enter :slight_smile:


This is an example of where Linux error messages need to be improved for new users. In this case, this is an issue with a Debian tool, but the documentation and error messages of Linux commands in general are often not helpful for new users, and you often need to do a Google search to figure out what is the problem. MS DOS also sucked in this regard, but VAX/VMS and some of the commercial UNIXes were much better in my opinion.


As long as you are about to learn … there is nothing wrong (to make this short). sudo and passwd guides from @lo0 are important indeed, thanks! Also what I’m thinking at the moment is that @TheLostG need to do following, at the first place, always before adding some new apps to your Linux system, PureOS here:

sudo apt update
sudo apt upgrade

In addition sudo apt full-upgrade and sudo reboot might be needed (if for example new Linux Kernel installed after sudo apt upgrade). @TheLostG, thanks for talking to us, telling where the problems are as we are not in your shoes and sometimes think that solving things are easy! I hope that passwd barrier for sudo is solved now, if not let us know. Software app might be updated from time to time too but let us not talk about it in this thread.

Just after above written commands, and perhaps after sudo reboot, you are ready to type following:

sudo apt update
sudo apt install firefox-esr

Just continue to read Linux output message(s), as you did here, and quit if not sure what next, quit or No are offered there (almost always I think) before hitting Yes, please.

And, if still having problems with Could not open lock file /var/lib/dpkg/lock-frontend -open you’ll go ahead and read this, as useful, yet I don’t think it will be necessary if above commands successful in execution.


Hi All,
Thank you for the replies. It seems that a ton of updates completed successfully for me.

And at least one issue with my existing browser (epiphany) seems to have been resolved.

Next i need to retry installing firefox esr and also try to figure out blue tooth (for hardware like mouse keyboard and printer). Thanks for all of the guidance with this.

1 Like

after doing some software updates. my browser is working. but my mouse is plugged in and not getting picked up by the Librem 14…