L5 MMS creates group chat with self

Alright, so I just got my L5 set up with T-Mobile (previously with AweSIM). Sms messaging works normally, but when I send a picture, chatty creates a separate group chat including me (with no phone number assigned) my recipient, and an unknown contact (my new number). Its like Chatty doesnt recognize the new number I am using. Is there a way to fix this?

-update- it’s received pictures that cause this, not sent pictures.


This bothers me as well, it anyone knows a fix for this I would appreciate it a lot.

Wait, MMS works now? I thought it required some hackery involving switching between provider profiles or something (SMS or MMS would work, but not both at the same time). When did it start working?

Same here. I was having the same behavior on Mobian on a pinephone.

MMS has been working out of the box for me since I received the phone, although it acts wonky sometimes. Instead of pictures loading automatically in Chatty, they will be displayed as links to click on .

MMS works for me since a long time, I don’t remember exactly but at least since half a year ago. But I think it only works when the APN used for MMS is the same as the regular mobile data APN, and that depends on your provider, you may be lucky or not. See State of MMS on Librem 5


Those with multiple personality disorder don’t see a problem here.

Which is unfortunately not the case with Telia Sweden…

If you want to see MMS working, you can try with a “kontantkort” from Comviq.

I have seen it working with Telia, but not at the same time as mobile data.

1 Like

To get MMS working correctly you need to manually input some configs in chatty’s preferences. The instructions on this post worked for me.


Not all heroes wear capes. The instructions worked for me, but not for using the APN “fast.t-mobile.com” What did work was matching the default Access Point Name under Settings/Mobile with the APN on chatty. MMS appears to be functioning normally now.


Yes, I agree that the key point is to have the APN’s match. I did the opposite and changed the default APN to the T-Mobile one. Glad the information helped!