L5 won't connect to wifi on German railway (DB)

The title pretty much explains it. On German trains with public wifi, my L5 just keeps connecting without success. For a long time I just thought and hoped it was due to the wifi being very unstable, but even on a lucky stable wifi day, it won’t connect anymore. It used to work occasionally some months ago, however.
Any ideas why that is happening and how I can solve it?

What card Redpine or SparkLan?

Did you came up with the captive portal login page? I guess the terms have to be accepted in advance before being able to surf with this ultra stable abnormous high speed connection. Thank you Deutsche Bahn <3

1 Like

SparkLan. I didn’t think of it, but yes, perhaps it’s not working since I switched to SparkLan.

Didn’t get that far, since the L5 won’t even connect to the wifi.

I have only tested this on Munich public transport trains. It connects right away and you must use, for example FF, and go to some page which will redirect you to a portal page to accept the conditions.

1 Like

So just to confirm … WiFi does work in all other situations e.g. at home? at work? friend’s place? cafe? public building? airport?

I haven’t really tried other public WiFi connections. I will try that. Besides that, it works everywhere else, at home, friend’s places etc.


As a frequent train traveler in Germany my advice is the following: turn off mobile network and possibly bookmark some common login pages:
http://portal.iob.de/ (RRX trains in NRW)

My non-expert explanation for this (might be wrong): In Germany “public” wifi usually forces you through some kind of login page, where you have to agree to terms of service. This happens by redirecting your first request (e.g. to https://puri.sm) to that login page. If you still have mobile network enabled there may be some kind of nameserver interference. Also I find my Firefox often does not redirect me to the login page immediately, as an Android browser would.

1 Like

That is definitely a possibility - but in that case it will also depend on your DNS configuration. On top of that, there is a risk that you have DNS caching that prevents the DNS poisoning from working.

1 Like

But does that have to do with the L5 not even connecting to the WiFi? I think that’s one step before getting to the login page. It just keeps trying to connect to the network without success.

Okay, I will provide a suggestion:

Open Settings → Wi-Fi, then tap the Gear icon next to the SSID. Scroll down to Advanced Settings → Security, then tap it and change the value to “WPA & WPA2 Personal”.

Thanks for your suggestion! Unfortunately, I cannot change to WPA/WPA 2 without providing a password, which doesn’t exist (or at least it’s not public) since connection works through a login page where I only need to tick a box.

1 Like

Captive portal is missing on the phone or in PureOS, I think Firefox has a captive portal implementation, but not sure that gets triggered correctly. Basically the OS (Phosh/Phoc) needs to generate a popup that allows you to connect for these type non-password, maybe non https type connections, where security is established after entering credit card information, or accepting terms check box.

Normally, Firefox will pop up a banner saying you need to log in to the network. This is triggered either when Firefox is first started, or when your network connection is changed to a different network. It also checks periodically in the background (it looks like the default is somewhere between every minute and every 25 minutes).

The pop-up banner is necessary because, these days, with so much HTTPS, the captive portal often won’t be able to redirect you to the login page just from normal browsing and you’ll get page loading errors or security errors instead.

You can also bookmark http://detectportal.firefox.com/, which should take you to the login page of the network you are currently using. Unfortunately, if you have enabled HTTPS-Only Mode, then Firefox will upgrade the request to HTTPS and you’ll have to click on the button that appears, to say you want to go to the HTTP version instead. If there is no captive portal and the network is working, then you will instead get a prompt to download an application/octet-stream (8 bytes), which you can cancel.

But you can’t go to the captive portal login page until you have connected to the Wi-Fi, and it sounds like the OP is having problems with that first step, not the captive portal. I don’t know what to suggest for that, because I have never had the problem of not being able to connect to specific Wi-Fi networks while still being able to connect to others.

Do you mean that the L5 has unstable Wi-Fi, or do you mean that the trains have unstable Wi-Fi?

Have you tried connecting to the same Wi-Fi using a different device at the same time and in the same place you try to connect with the L5? Or could you ask someone else if the Wi-Fi is working for them? In other words, is there any chance it might just be that the Wi-Fi on the trains is not working, rather than the L5 not working?

Maybe the Wi-Fi you were trying to catch had been cancelled and you could have caught the next Wi-Fi instead.

You’re right. Well, that’s a problem I’m also familiar with: I’m frequently at a friend’s place, where I just can’t connect to the 5 GHz WiFi. At my home both 2.4 GHz and 5 GHz networks are working ok… well poorly, to be honest (occasional connection losses). Running the same command to list visible networks, “nmcli dev wifi”, returns four results on the phone, but 21 results on my laptop in the same room. So I guess the phone’s network hardware is just poorer (or the firmware is not right? I might have messed around with that too). Yet on trains I do usually get WiFi.

Every time I tried I was also able to connect with my Android phone as well as laptop, even though often the network was unstable so that connection got lost after some time on my Android.

Anyway, two days ago I tried again and out of the blue it connected. I have no clue why after weeks and months it suddenly would succeed again. Perhaps there was an update in between or the railway WiFi got more stable? Now I’m motivated to keep testing the next times again. Hopefully, it’ll just keep working. Otherwise I might be able to see some patterns linked to stability of the network or related to which train routes I take. German railway offers so much excitement!

1 Like

Nope, tried on a few more train rides on different routes, but it’s again not working. I have no clue why it worked that one time. It’s been working fine on my Android.

1 Like

Can confirm on ICE trains i could not login using the L5 no matter what i tried. At the trainstations however, also a DB public network with login page the wifi connect and captive portal with firefox worked. I do not have https everywhere enabled.

Has anyone ever asked DB what their technical requirements are? etc.?