Last update phone stopped working

Same problem here, also stuck after the latest update.

I tried to connect to the lapdock and use that keyboard but that device apparently does not get recognized yet as the first step is to decrypt the phone.

Support request was sent yesterday but so far no response yet, any help from the community is appreciated. :saluting_face: If there are two with the same problem there might be more?

1 Like

Have you tried connecting the lapdock to the Librem 5 before turning it on? The order may matter for the boot up process and hardware initialization.

1 Like

Yes, good question and made no difference.

I also just tried to use a USB-A connector keyboard with the usb-c hub pro connected to the phone. When I connect the USB power source to hub the phone red light lights indicating it charges. No response to any keystroke on the keyboard.

I also have a reply to my support request so Purism technical team is aware and looking into this… maybe even reading along :wave:

1 Like

Okay, try removing and reinserting the battery, then see if the screen responds after that with touch input.

I updated my Librem 5 USA within the last 10 minutes and cannot replicate any issues in this thread after turning it off and on.

1 Like

This is what I did last night when the phone got stuck and after 25 mins it still did not proceed. Just tried again, problem remains.

Good for you, that means not everyone has the same problem with the updates…

1 Like

Alright, use this guide and follow it step-by-step.

1 Like

hmm that’s beyond my skill level as a linux n00b at this moment, plus that I have only Windows based machines, no linux devices besides my now frozen Librem 5.

Here is a remark made about running out of space for the root file system, not sure if that’s applicable for me but definitely something to check when my device is working again.

1 Like

If you have a spare USB drive, you can use it to flash a PureOS image, then boot it instead of Windows so you can continue to follow the steps mentioned above. These instructions below will get you to the end of the flashing process.

Download PureOS

1 Like

OK I downloaded pureOS on the fresh USB drive I got yesterday.

Upon checking everything before doing the reflash procedure, my phone is now completely dead. No response to any key press. Battery is checked and fully charged, making contact to the phone. Also, USB-C cable is powered and switched from a working other device to my Librem 5. No effect, phone remains dead.

I could really use some pointers here what to try next. Not my best Xmas.


Did not work.
And me, who is new on linux would need to ask here if there is someone who could assist me tru mirroring flashing my now unresponsive librem 5? I looked at it aand understood nothing. The phone itself is not found being connected to computer, niether macbook nor windows thinkpad. I have been in contact with support but nothing there but frustration. Sending me twice about the external keyboard witch did not respong at all. And twice sending me link to flash. But im no tech dude and dont understand. So is there a possibility to flash through mirroring? Please let me know. I told support to make something like that but no respense so far. Have no idea if it would work. But some phone companies have that resource availible. Connecting the phone and reinstalling where the webpage finds/looks for the phone and do the work.


did not work. Totally unresponsive. This sucks greatly! I want a new phone! And send the wrecked phone back to purism!!!


Looks like you and me are in the same boat. Let’s wait for a response before we totally panic and freak out.


Initialize the reflashing script to see the below message:

            - Ensure that the phone is powered off
            - Turn all Hardware-Kill-Switches off
            - Unplug the USB cable if connected
            - Remove battery
            - Hold volume-up button
            - Insert the USB-C cable (red light blinks, no green light)
            - Reinsert the battery (red and green lights constantly on, the script will continue)
            - Release volume-up button

Follow the instructions while paying close attention to the changing LED light near the top right of the Librem 5 screen. If it does not show any indication of activity, I suggest continuing to follow up with Purism support to have them troubleshoot your phone.


I have run into the same issue. However, I was updating from the terminal and can add more details. Close to the end of installing updates, the lock screen suddenly activated. I assume that a process restarted with the lock screen activation. However, the usual (the default) password was not working anymore. I switched to a tty with Ctrl+Alt+F4 or something and tried pureos with the default password. I waited a bit for a reasonable time in case any configuration continued in the background, and held the power button to power off the phone. However, neither an on-screen nor a USB keyboard seems to input anything into the disk decryption dialogue before boot.

Before that, I changed the repositories to crimson (see below). However, there were some updates that I did not apply for Byzantium. Now you have a similar issue. So, I assume it may be in the latest updates for Byzantium.

I have read in the forum that Crimson is newer than Byzantium. I replaced all three occurrences of byzantium with crimson in /etc/apt/sources.list and ran:

$ sudo apt update
$ sudo apt dist-upgrade

The proposed upgrade seemed reasonable. Unfortunately, I cannot report on the result.

My next step is to try to flash the phone with uuu.

1 Like

Nope, no lights blinking so looks like the phone is totally bricked.

Thanks for all the help, this goes to Purism support for further instructions.

1 Like

So to be clear is there anything on the screen at that point? In other words is the screen blank or can you photograph the screen and post it here?

I’m unclear what you mean by this?

Yes, there is a process for reflashing the phone. The upside is that the process should work regardless of the state of the software on the phone at the moment. The downside is that you will lose all content that is currently on the phone.

An alternative is to use Jumpdrive in order to investigate the current state of the software on the phone, and thereby potentially to fix the current state.

However either reflash or Jumpdrive requires you to have a working other Linux computer. Do you have such a computer?


That is how I see it in my case. I made a photo below. I expect circle symbols to show up when typing. I further expect the phone to boot when hitting OK or Enter. Neither happens.


Yes, but there are technically at least two codenames for Crimson: landing and crimson, used for the Librem 5 and 11, respectively. You used the incorrect codename for your device, assumed you can use dist-upgrade, and also assumed that LUKS encryption/decryption is still supported, when the latest built Crimson images for the Librem 5 on Jenkins use the plain variant.

Before you go off making more assumptions and executing commands, answer these questions:

  • Do you want to recover your Librem 5 files using Jumpdrive?
  • Do you want to use Byzantium or Crimson on your Librem 5?
  • What is the codename of your Librem 5 batch?

… and “do you know how to?” :wink:

1 Like

I do not want to recover any files. I copied all important data from the device before experimenting. However, I may try Jumpdrive to see if it works and report here.

If possible, I would like to install a different distribution and see how it goes. However, I need to learn and start with something that is supposed to work. So, reflashing Byzantium seems like an appropriate thing to try first.