Librem 13v4 Keyboard: Additional Characters

Is it possible to configure the system keyboard settings to support additional characters like the blue ones in the Wikipedia US Inernational Layout? I especially like to get working the Guillemets on the two keys to the right of P.

Already got the Pipe to work with setkeycodes, but didn’t succeed with this.

Thanks for any support!

1 Like

There are various methods on how to set things up, the Gnome Wiki has an overview of them. I personally use the Compose Key method. Open up the Tweaks program, go to Keyboard & Mouse. Third menu from the top you can choose a compose key. For me it’s set to Right Alt. When I want to type what you want, « or » I hit Right Alt + < + < or Right Alt + > + > and then you get those nice characters. Accents can be written that way too and most symbols I use come in as second nature after using them for a bit.

Here is a list of all the characters that you can type that way. Sure, it might not be the fanciest method, but it’s very clean and doesn’t need any additional packages. Also, many combinations that I use seem to come fairly natural as well… some are more special but still cool :slight_smile:

Thanks for this solution or suggestion. Unfortunately it doesn’t work for me, no matter which Compose Key i try.

Having enabled and chosen a compose key, are you saying

a) pressing and releasing the compose key elicits no response, or
b) the compose key does respond but the compose sequence doesn’t work


I would not ordinarily have a compose key enabled but following @pfm I did so.

When I press and release Right Alt, an odd-looking icon comes up (underlined). The icon looks like a rectangle overlapping with a circle:

That’s Unicode character 2384 (hex).

Same for me as for @kieran except for I do usually have a compose key available. Once I press it in an editor I get that character as well, which indicates that I can now enter the combination for the special character that I want. Note that not every editor does that, e.g., this text editor here in the browser won’t show that unicode character from @kieran’s post. Nevertheless I can still type two characters and they appear.

Just to make sure: What system are you running @m4ur1c3 and in what environment? Gnome?

That’s weird. It (U+2384) actually does come up in the window into which I am typing at this exact moment. « » ©

I didn’t test it exhaustively but it comes up in a terminal (shell) window, it comes up in LibreOffice Writer, it comes up in gedit and it comes up in Firefox (in various places including address bar, search bar and text box).

Edit PS: I have Firefox 77.0.1 i.e. current.

Funky, it comes up in most programs for me. In Tilix it looks a bit funky, like the whole circle part is cut out. But in Firefox, the standard Firefox ESR, and SublimeText it does not come up but still has full functionality. I never questioned the fact until now that it doesn’t up, since it still works.

If you type without thinking about it / type quickly then maybe you wouldn’t notice, as it is only there momentarily while you are completing the compose sequence. «Ö» < does this prove relevant to you ?

1 Like

Thanks for all your answers and help! I am running Qubes OS with Xfce and was able to solve my problem by adding X11 Model: us-intl to localectl. Before that, I had only set VC Keymap: us and X11 Layout: us.

1 Like

I use the Colemak keyboard layout, which automatically uses right alt for alt gr. Once I set the layout to Colemak, I can type «» ‹› and accented characters without any configuration. See Colemak Multilingual for more characters. Colemak can also help with Carpal Tunnel.