Librem 14 battery not charging and system thinks battery is absent

Recently I’ve been having some problems with my Librem 14 as seen in my recent previous posts, but this one takes the cake as the worst problem yet.
A few weeks ago I started having this problem where something would happen that causes my laptop to crash such as: normally running vmware, keyboard randomly stopped working which needed a restart however I couldn’t enter disk encryption password so I had to do a cold restart. Then when the laptop powers on, the battery wouldn’t be detected.
This was annoying because I couldn’t see the battery charge percent, but at least the battery would still charge. The “solution” I found for this is to let the battery drain completely and then leave the laptop be for a day, then charge it a bit and power it on.
However, this time when the battery drained and I plugged the power adapter in for an hour, the battery still wasn’t detected but even worse is that when I removed the power adapter the laptop immediately turned off. I assume this happened because the battery had no charge despite being on the charger for an hour.
Please note that /sys/class/power_supply/BAT0 doesn’t exist right now because the battery isn’t detected so I can’t change the start/end thresholds.
I have also tried removing the battery and holding down the power button to completely discharge the laptop and then putting it back in, but that hasn’t done anything. I have also updated to the latest Coreboot and EC firmware.
If you’ve gotten this far then I sincerely thank you and I have no ideas as to what is happening or how to fix this.


Same here. Now my computer doesn’t start up anymore. Sigh. I have barely used it since I got it last year. This is indeed so sad. When I open up the laptop, I cannot even find a BIOS battery inside. I have sent the support an email but I am so frustrated with this.

1 Like

I have a L14 and work really good all time, i seen this error pretty much and i am curious if is a issue into EC Chipset, LIke EC firmware erased, so if you can CHECK the the status of the EC by using a external Burner, shoud help to start troubleshooting this common issue.
I used my L14 with barrel charger all time, never used Power Delivery.

1 Like

I have the same issue now with the battery not being detected at all. The laptop doesn’t start anymore when not plugged to the barrel charger and stops if I unplug the barrel charger (just as if there was no battery).
This happened suddenly for me. The battery used to be detected and to be charging correctly.

Note: Updating to the 1.12 version of the EC firmware did not fix the issue.

Seem that battery is dead, update Coreboot or too.

You can still Burning a GNU OS(Trisquel Aramo - Pure OS) into an USB and booting… to see what it going on. If work, REinstall Pure OS.

Oh great. Looks like I’ve developed this issue as well. Had my Librem 14 for a couple of months now. Everything has been flawless. Today, however, my laptop suddenly showed battery power at 0%, but charging. I decided to restart the computer, now it’s showing now battery indicator at all. If I unplug the charger, the computer still runs, but I’m wondering for how long. Sounds like it can drain the battery, but not charge it anymore. Did anybody get any resolution on this? Do I need to contact support?

This problem happened to me several times and each time I had a really finicky fix. I think I would let the laptop fully charge and then fully discharge like 2 or 3 times. There were also some times where I would just leave the laptop dead for a few days and it would fix itself. I haven’t run into the problem recently so if you have updated the embedded controller in a while then I’d recommend that. Unfortunately I can’t say I ever found a solid solution sorry.

Silly as it is, this solved it for me: BAT0 missing from /power_supply. Battery indicator shows no battery availble

Hopefully the problem never comes back, but if it does, this will be the first thing I attempt.