Librem 14 ear bud headset output not working

Seems my headphone / earbud jack is not working. Tried two different sets of Buds, one with microphone one without microphone. No sound at / from the jack. Sound from built in speakers works fine. Any suggestions???

2 Likes

You may need to update your coreboot version to 4.14

https://puri.sm/coreboot to flash the latest version. It should fix headphone jack detection.

1 Like

Thanks! I will look into that.
This will require changes to my Librem Key correct?

yes, it will require changes to your Librem Key. I went through the process and it should detect you have a Librem 14 with PureBoot. To flash the Heads version requires copying the created file to a USB drive and restarting the computer. Interrupt the boot and enter the Heads menu. From there you can follow the steps to install the new version and generate new keys.

Edit: I don’t think they solved/implemented all the functionality to get the jack working seamlessly. I think you need to manually (some how) switch audio to the jack. I haven’t tried yet.

Thanks MUCH!

if you’re using Pureboot (vs the standard coreboot firmware), you’ll need to wait a little bit for the next Pureboot release.

3 Likes

Thanks for the solution. Flashing the firmware fixed my earbuds on the L-14.

1 Like

System is as delivered. I messed up on the first boot & setup of my Librem 14. Ended up having to do a factory reset etc. Is there a set of instructions for flashing under PureOS / PureBoot then updating the Librem Key? Seems there are links to different steps for each process but not a step by step to flash & update the Key. I also need to fix issue in (Software) program Error: Sorry, something went wrong: Error StartServiceByName for org.freedesktop.fwupd: Failedto activate service ‘org.freedesktop.fwupd’: timed out (service_start_timeout=25000ms)

Also have unmet dependency issue:
OS Updates
GNOME Settings 3.38.1-1pureos6 -> 3.38.1-1pureos7
Polari 3.38.0-1 -> 3.38.0-2
Thunderbird 78.11.0-1 -> 78.11.0-2

xxxxxxxxxxxxxxxxx:~$ man apt-get
xxxxxxxxxxxxxxxxx:~$ sudo apt-get -f install
[sudo] password for fredwalker:
Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
0 upgraded, 0 newly installed, 0 to remove and 38 not upgraded.
xxxxxxxxxxxxxxxxx:~$

Did not fix dependency problem. Suggestions to fix dependency issues & flash, update, upgrade & update Librem Key???
Thanks All!

@FredWalker nothing needs to be done to “update” the librem key. If you’re running Pureboot firmware, you’ll need to wait until the next update is released for the headphones fix. Instructions are at puri.sm/coreboot.

For your OS update issue, post a new thread and/or ask in the PureOS Matrix support room.

1 Like

Thanks Much!

Do sudo apt full-upgrade

Hello @MrChromebox,

I wanted to let you know that there is a new lucky owner of Librem 14 also waiting for firmware update to make headset and microphone working.

Thanks so much for your hard work!

Have you got an ETA for Coreboot/Pureboot update to fix the audio jack?

the audio jack being selectable as an output was fixed in coreboot version 4.14-Purism-1, released on 6/18/2021, and in Pureboot Release-18, which I just pushed now (though the release notes list the date as 7/6/2021 - testing wasn’t completed before I went on vacation last week)

1 Like

@MrChromebox - I confirm the audio jack is now manually selectable and the audio plays nicely in my in-ear piece!

I also confirm that the internal microphone is working and quality is significantly better . This means I can now participate in the lengthy conference calls with the other participants hear me clearly.

This is a massive improvement wit the current update. I complement you for all the hard work you put it! Lots of love! :kissing_heart:

Notice to @Kyle_Rankin @todd-weaver @nicole.faerber

2 Likes

How is that a good thing? :wink: