Librem 14 : strange behavior with charging since latest update

Since I made the latest update on my Librem 14, as soon as I plug the charger, I hear a little clic sound and the laptop turns in sleep mode (or standby, I don’t realy know if there is a difference) and I have to wake it up (start/stop button), type my password again and, if I don’t disconnect the charger, the laptop turn again in sleep mode before I have time to do anything and so on… until I unplug the charger from the laptop.
The laptop behave like the start/stop button is pushed when charger is plugged ! That’s weird !
I have tried to shut it off completely and restart but same trouble : I cannot charge it when I use it, so I dont know (but I suppose) battery charges when in sleep mode ?!
I don’t realy know what to do with this issue, and it would be great if someone had a solution… or an update fixing this trouble !
Thank you,
PS : I already made an EC firmware update around 6 months ago because of trouble concerning battery not recognised, this issue seems not to be related with EC firmware… (Librem 14 - troubles with battery level indicator / charge treshold)

1 Like

that click sound came from gnome,
there is an audio event on charger plug/unplug, same sound you will get when you plug/unplug usb device.
clicks on sleep wake up is due to gnome detects charger.

1 Like

have you updated ec firmware to 1.13?
if not , i strongly advise to do so.

1 Like

Thank you for your answers !
My current ec firmware is still 1.11, I did’nt know that there was a new version ! I will update it soon !
How to be kept informed of new updates ? I forgot if there is a special topic to follow ! :wink:
Thanks for helping ! :pray:

I did the update, problem not solved :fearful:
If I plug the charger while I’m using the laptop, in the best case I get a forced sleep mode, in the worse, I get a hard shutdown :scream:
Any idea, please ?! :pray:

So what last update do you got the strange charging event, can you be more massive info about.


I’ve not “recorded” wich update it was. That was the update that the system tells you have to do (security update, OS update…) and of course I did it.
I did only one other update few days ago, and made screeshot of window with details of update, unfortunately, I can’t start my Librem14 any more.
It seems it’s much more serious than only related to an update. To my opinion, the laptop is dead… at least the mother board :cry:
And no one can say that’s because I use it too much, I still use my old MacBook Pro 2011, still working fine for 12 years and thanks to it, I can access to this forum !
Yesterday I opened it and unplugged battery for a while, to test if that could reset something wrong but nothing changed.
With a magnifier (x15), I also checked the mother board close to the charging plug and I noticed some components (apparently resistors) that were welded manualy (a fix on a new laptop motherboard ?) That’s weird !!! :scream:
I took photos of that and I’ll post them soon. I also made videos of the bugging laptop trying and trying to start, unsuccessfuly… I’ll post them also on my channel…

1 Like

those resistors manual is known fix to usb emitting to much em noise… to pass FCC regulations.
information about those resistors , was public.
if your laptop wont boot , can you check power supply? Voltage , etc . and contact

Thank you for the latest information about manual welded resistors.
Here some photos with magnifier. One can see some tiny drops of tin on the board and an integrated circuit partially covered with welding flux (may it have been over heated ?)
I obviously checked power supply voltage, that is ok (around 19,067V)
Here a video of what happens.
I have sent email to support last week (not yet received answer) and I will resend one today with some more details (this time with copy to Mladen and Joao of the team)