Librem 15v4 With Pureboot - New-to-me machine, but can't get it booted or reset

Greetings all. I’m in a pickle and I’ve read the documentation, but I can’t find documentation help with my situation and so I’m hoping someone out there can save the day for me. I purchased a used but very new (7 months old) Librem 15v4 with PureBoot bundle. From what I can tell, the Pureboot bundle includes the Pureboot menu (which I see when I start the machine) as well as a Librem Vault gold-colored USB key with some factory-set crypto codes on it. The items I received from the previous owner were the laptop in addition to the Librem Key (usb key) and a Librem Drive (usb key) - but no gold-colored Librem Vault usb key.

When I start the machine, I’m presented with the Pureboot Main Menu

I assure my Librem Key is installed in a USB drive and select Default Boot, but I receive this error:

I don’t know what to do at that /boot command line, and so I shut the machine down to try many other options from the Pureboot Main Menu.

I’ve tried many things and nothing works. I even tried the OEM Factory reset - which probably doesn’t work since the dialog box mentions “It require that you already have an OS installed on a dedicated /boot partition.” Here are the steps and result from this effort:

I plug in the following usb keys: Librem Key and Librem Drive (I don’t have a key labeled “Librem Vault”, if that matters)

I select OEM Factory Reset from the Pureboot Main Menu

It begins chugging away

And eventually provides the following error:

I’ve spent hours on trying to get this machine booted and/or reset and I can’t make any progress. I’m not even sure I have all the items necessary to get the machine operable - I don’t know what I don’t know. I have technical knowledge from the Mac/PC world but this being my first Linux machine, I’m not sure what to try next. I contacted Pure but they sent me to the documentation, which I had already read back/forwards, to no avail. Any advice/assistance would be keenly appreciated! I’ll post pics of any steps you might suggest to try and make this troubleshooting as transparent as possible so it can hopefully move along quickly.

PS -
If there are any Pure support employees reading this, I would be interested in using a service to send the device in for a fresh factory reset. I asked this question via Email but haven’t received a response.

1 Like

ok, given that you received a used device in an unknown state, I think wiping everything and starting fresh would be the best bet. Here’s what I’d recommend doing:

  • Download latest PureOS ISO and write to USB
  • Boot PureOS USB via Pureboot menu: Options/Boot Options/Boot From USB. then select USB device from list (usually /dev/sda1 or sdb1)
  • Do a clean install of PureOS, wiping the internal storage, and using the default partition setup etc.
  • Before rebooting, format the Librem Drive (ext4 or fat32) so that Pureboot can save the keys to it later
  • Reboot, and you should be prompted to perform an OEM reset. Do so.
  • Reboot, create the new HOTP secret when prompted, then defaul boot should work

Thank you so much. Those steps got me further than I’ve been so far!

I was successful down to the point of Reboot. Instead of being automagically prompted to perform an OEM reset, I was put into the Pureboot Main Menu. I then manually selected OEM Factory Reset and it chugs along with the message “resetting GPG key (this will take a minute or two)” and then throws up the error:

I click OK and I’m taken to a dialog box “ERROR: TOTP Generation failed!”. I have several options on the subsequent menu, but it looks like they all look for the GPG key that doesn’t exist yet. Thoughts?

it would appear that the OEM/Factory reset function is failing to copy the key to your USB drive, and therefore aborting and thus not saving the key to the firmware as well. Can you try with another USB stick? Any FAT32 or ext4 formatted stick should work for this step. Be sure to remove your PureOS install USB or anything else to ensure the correct device is selected (next update will add drive labels to help with this)


I think you nailed it. Based on your suggestion, I tried the Pureboot menu option to manually generate a GPG key which I then stored to a clean USB key. Once I figured out this process, I tried the reinstall process again and eventually got through to a clean install! I suspect a corrupt Librem Drive usb key was the root of most of the issues I’ve been tangling with the past day or so.

Thanks MrChromebox for your highly appreciated guidance!

looks like the text on that dialog was being cut off a bit, and I suspect the error was “read-only filesystem.” I’ll see if I can improve that in the upcoming update

1 Like