Librem 5 evergreen for sale (won't boot)

I have a librem 5 evergreen that I got from participating in the crowdsale. It worked fine until today when it suddenly stopped booting. Charging LED glows red which apparently means the charger is working, but none of the buttons will get it to start. Possible that the battery has issues, as I let it sit for about a month one time without checking on it. Anyways, as I hardly used the thing, I don’t really feel like putting a ton of effort into repairing it.

I’ve listed it for sale on ebay if any of you think you can repair it or use it for parts:

Evergreen is picky about the way that it is charged and turned on. See:

There probably is nothing wrong with the hardware. Is the phone still under warranty?


Perhaps Purism should attempt to buy it back if the owner is determined to sell it without either warranty claim or troubleshooting effort. :open_mouth:

Yes, I would agree. Next time take your battery out (when it about 50% charged), please, before putting your phone aside for some time. Librem 5 will deplete it even when off (think so). Perhaps some other charger might help to wake up this dead battery (after 30 minutes of charging it or more)? Anyway, I’d consider charging red LED light as a very good sign (just dead battery issues, my guess that Librem 5 will not boot without some juice within, to this smartphone connected, his own battery).

Please go ahead and buy brand new Librem 5 battery and swap it with the current one as described here (to see/read if it is able to charge again, hope this helps with your issue):

I’ve had this happen to mine when I let the battery go straight to 0. If you remove the battery and put it back in you should be able to boot as normal. Easy thing to try and if you are still set on selling it at least you won’t need the won’t boot disclaimer.

edit- Can even rule out the battery altogether and just boot with it plugged in without a battery.


I wish to have your sense of humour. Suppose that wasn’t drinking :baby_bottle: as much as you?


@libwood’s suggestion makes perfect sense. Provided that you have the Librem 5 connected to the charger, in turn connected to mains power it should be OK to remove the battery, or to have already removed it, and the Librem 5 should operate normally. Or if it doesn’t, you can be sure that the problem is not the battery.

The computer I am writing to you on has no battery. I gave up on the expense and short lifespan. That would be my first approach. If it works on mains power get a new battery.

Yes it does (for sensible). But anyway, are you telling (confirming? to us) that anyone can boot (up to the title of this thread) Librem 5 Evergreen without inserted and healthy (charged over 0%) BPP-L503 battery? If so that would be nice feature to count on, when necessary, like here in this thread.

@irvinewade, I guess you don’t mind to sudo poweroff your Linux phone (that isn’t called PinePhone), take battery out, connect it to original power supply (charger that provides 0.45A, might be the case, only to it) and let it boot PureOS (Mobian, pmOS, SMXO), if this (without battery inserted/connected) works for you. And sorry if I’m reading your post wrongly, but still your post was somehow inspirational to me, thanks therefore!

Yet, this is (still is) important note from @libwood (that I liked and didn’t comment):

Further, as @amosbatto already recommended here, within this thread, those eight steps are very basic (to boot) requirements indeed, I have no doubt. @coconutcream, after following those eight steps, please, by using original Librem 5 power supply, press with your finger and hold power on button continuously for around 10 seconds (few more seconds might be better, red LED light stays constantly on, as charging current will change/decrease few %, irrelevant how much here, as I’m not an expert, but probably related to battery charging stage/status like almost empty or almost full, necessary electric current to charge it will vary anyhow) as just briefly pressing power button for as many as 50 times won’t wake up your Linux smartphone, I guess. Release it (same power button) for around one second and press power button briefly (twice, three times might be necessary as well) again, you should get green LED light at first, meaning your Librem 5 should boot now, I hope (if original battery still usable). Anyway please let me know if you tried this approach (as I just made this guide up for you, nothing serious from my side, just based on my intention to help, unofficially help).

While possible in principle (I booted the dev kit that way back in the days), the initial power surge when starting the kernel makes a charged battery a hard requirement. Even on the dev kit since long.


That’s not true - I have just tested it on Evergreen with provided charger and it works. I had to boot with modem and WiFi turned off via killswitches, but could enable them back afterwards after fully booting. Then I could even play a game and use cameras with modem and WiFi both connected, all without a battery.

You need a PD charger that can negotiate enough amperage on 5V. The provided one goes up to 3A, which is sufficient. With non-PD chargers the current limit will be set to 500mA, which is not enough.

The negotiated current can be checked with cat /sys/class/power_supply/tps6598x-source-psy-0-003f/current_max


Is it possible to read the battery’s voltage early on in the boot process and make the startup use less peak current when there is not enough voltage (such as 0 volts with a battery removed)? It sounds like keeping the WiFi & cell cards disabled until later in the sequence might be enough.

Ah, thanks for the correction. I haven’t used strong enough chargers apparently.

1 Like

So, if @coconutcream Librem 5 have value of current_max = 500000 he/she cannot boot without healthy battery connected to it (if I’m understanding this right), and for changing this value to something like 1500mA is out of the game here and now (if not done earlier)?

No, that value gets dynamically negotiated with the charger by the USB-C controller.


Anyway, the best way to check whether USB power path works (on Evergreen) is to take the battery out and plug the charger provided with the phone while holding the Vol+ button. If the red LED starts to blink, the phone isn’t dead. If it does not, try the other USB-C orientation (this will help if there’s a problem with a single CC line). If it still does not help, then it’s worth trying with other chargers and even a USB-A to C cable (to rule out PD-related issues). If the LED does not light up no matter what, then it’s likely that there’s a hardware problem with that unit.


Thanks, appreciate! In @coconutcream shoes I’d go (give it a try) ahead and use JumpDrive for Librem 5 to bring this smartphone to life, as optional choice.

From the description at the beginning of this topic, it seems like that phone should be able to come back to life just by letting it charge for a few hours, then unplugging the cable and pressing the power button for circa. 20 seconds (or as soon as the green LED shines up). The red LED is shining continuously, which means the USB power path and battery charging circuitry both work fine.


I doubt that would work.

This is made more complicated by the fact that those two cards connect to the Librem 5 via different mechanisms.

To say that this would work would require a detailed knowledge of the hardware and software internals - much more than I have.

I think you would be better off, as the user, taking responsibility for flicking the kill switch. That would be much simpler!