Librem 5 out of memory on Boot partition

After an update I got a message that my Boot (partition?) was low on memory.
I always do a sudo apt-get autoremove before update and upgrade.

After some digging I found a post in Ubuntu on how to remove older Linux kernels.
I manually deleted the old kernels and no longer get the messages.
I dont even know if what I did is correct or is the proper way to manage old images.
Has anyone tried Synaptic to manage old Kernels?

An alternative is Synaptic (sudo apt install synaptic)

search for linux-image, right-click a kernel and choose complete removal and finally click the Apply button to delete the kernel.

TIA Frank

Search in this forum for existing discussions of this problem.


No, I just reflash the Librem 5 USA whenever I feel like it at this point.

Nuking the OS used to be my go to solution, too :laughing:

1 Like

It works for me because I do not have anything important on it; the backup files are on the microSD card.

Remove old kernel images

I didn’t use synaptic. I don’t remember how I did it. I think I listed the contents of the boot partition, then deleted the older kernels…

I did :
sudo dpkg -l *linux-image*
(to see which kernel images are installed = lines starting with ii)
sudo apt remove linux-image-6.3.1-1-librem5
(it was the old kernel image)
sudo apt autoremove


Thank you Pak. Yes I did what you describe.
Otherwise I think the Librem 5 would have broken.

Thank you Irwin, yes I did search, and found answer on Ubuntu forum, to fix my immediate problem

My specific question was about Synaptic. Has anyone installed Synaptic on Librem 5.

Debian Wiki says
Synaptic is a graphical interface to the Debian package management system. Synaptic enables you to install, upgrade and remove software packages …

My confusion arises because I thought PureOs was a Debian fork (I believe) and PureOS has its own Software Installer (PureOs Store) so why do I need another package manage?
I already installed ‘Flatpak’ and I am using apt-get to manage my updates at present.

Will anything break f I install the Synaptic package manager, I already have too many?
I am using the Librem 5 as my daily phone and wish to not experiment on it.

So I thought it would not hurt to ask.


The related question would be: how well does it work on a screen of the relevant size? / is it adaptive?

1 Like

I use synaptic on the L5, as well as on my Debian desktop.

For the L5, I don’t view it on the L5 itself, but instead remotely display it on the desktop. As irvinewade says, screen size is an issue otherwise. It’s a little slow with the weak L5 wireless performance, but usable.

It’s a really good application, a great half-way point between the powerful/steep-learning-curve of the command line, and the weak/easy app stores.


Thank you stookie. I will install Synaptic and give a follow up.
As I use a ‘bonelk’ hub screen size and speed will not be an issue.
I connect the hub, hence the L5, to my home LAN vie the hub ethernet port.
The port connects to a desktop screen and Keyboard.
I always do updates wired my home wired connecion.

I guess the screen size issue also answers my question as to why Synaptic is not installed by default.
I have previoulsy posted what the ‘bonelk’ 7 port hub looks like.

Synaptic update. I installed Synaptic, But it has a problem as described in this post.

Does not accept my password.
I uninstalled Synaptic. I do not want to apply the suggestion resolution without more investigation.


1 Like

Hello @pak I have had this problem out of memory on boot partition and have tried your solution, sudo apt remove linux-image-6.1.0-1-librem5 (there are several other images to remove as well) However it hasn’t worked. It suggests running sudo apt–fix-broken install which I do. It tells me there are unmet dependencies linux-image-6.6.0-1librem5 but that this isn’t going to be installed and to run sudo apt --fix broken install. This usefully lists all the packages that are no longer required and offers to install the dependency 6.6.0-1librem5. I input Y. It tries to do this but fails due to (No space left on device) I try sudo apt autoremove again but this fails due to the dependencies. And I’m back to the beginning. Is there a way to force the removal of redundant images? Or do I have to re-flash?

1 Like

Hello @kkollin! Don’t know if I’m able to help.
First you need some information:
Which kernel image are you booted on : uname -r
Then which images are installed : dpkg -l linux-image*
and space left on boot partition : df /boot
If you are not booted on linux-image-6.6.0-1, you could try to remove it first ?

1 Like

Hello @pak. Many thanks for trying to help me.
uname /r shows 6.3.0-1-librem5
images on phone are:ii librem-image-6.1.0-1-librem5 6.1.23 and
ii ditto 6.2.0-1 6.2.13
ii ditto 6.3.0-1 6.3.13
ii ditto 6.4.0-1 6.4.16
in ditto 6.5.0-1
in ditto 6.6.0-1
un linux-image-amd64
iU linux-image-librem5 6.6.6p

df /boot shows: Filesystem 1K blocks Used Available Use% Mounted on /dev/mmcblk0p1
461087 439175 0 100% /boot

I tried to remove linux-image-6.6.0-1 but it says it can’t as it is not installed (ditto 6.5.0-1)
I also tried to remove 6.4.0-1 but that has dependencies in 6.6.0
I didn’t try to remove 6.3.0-1 as that appears to be the one in use.


1 Like

So, try to remove librem-image-6.1.0-1-librem5 and librem-image-6.2.0-1-librem5.
If it works you should have some free space on /boot.

1 Like

Hello Pak
Sadly these can’t be removed as there are unmet dependencies ie 6.6.0-1
It looks like I can’t remove anything because of unmet dependencies and can’t install the dependencies due to having no space on /root.

1 Like

There are force options in dpkg, but they are more riskier:

sudo dpkg -P --force-all linux-image-6.1.0-1-librem5

Check twice to avoid typo.
Other way to create the necessary space on /boot is to remove manualy old unused kernel image e.g /boot/vmlinuz-6.0.1-1-librem5.


Brilliant pak. The force worked and I removed 6.1 and 6.2 and then managed to install 6.6.0-1
Thank you so much for finding the time to help me. I’m very grateful.

1 Like