Librem 5 out of memory on Boot partition

You’re welcome!
I would recommend to keep max 3 kernel images. IMO two are enough: the newest and the former good working one.

2 Likes

Good idea. I removed 6.3.0-1 and 6.4.0-1 but when I run dpkg -l linux-image these two still show but labeled rc. I suppose this means removed? 6.5.0-1 shows as in and 6.6.0-1 shows as ii and linux-image-librem5-6.6.6p shows as ii.
I suppose that I need to check how many images are building up and remove excess ones from time to time? Surely this should be automatically done during updates?
Thanks for your help
kkollin

1 Like

I got the out of memory on boot partition message.
I manuallly removed all linux-images bar the latest, now my phone has failed.
When dialing I see the 4 bars connection go grey and nothing happens.
It could be the modem has failed but I dont know how to check,
I am trying to figure out how to recover.
I was hoping to have a package check and recovery function.
I found that reflashing is an option but reflashing seems very difficult.

Anyone know of a way to recover old images?
I do run a daily backup, but I dont think it does Linux-images.

Thanks
Frank

1 Like

I can provide clear instructions for reflashing the Librem 5 with a new Byzantium image, so decide if you want it or not.

1 Like

OK Thank you. FranklyFlawless
fwiw I thought PUREOS was a fork of Debian.

1 Like

PureOS is a Debian derivative. The instructions below assume you are running Debian or any of its derivatives, such as PureOS, using the x86-64 architecture, and that your Librem 5 is from the Evergreen batch:

sudo apt install git uuu
git clone https://source.puri.sm/Librem5/librem5-flash-image.git
cd librem5-flash-image
sudo apt build-dep .
sudo ./scripts/librem5-flash-image --udev
./scripts/librem5-flash-image --stable

After the Byzantium image has been downloaded, you will see the following instructions:

            - Ensure that the phone is powered off
            - Turn all Hardware-Kill-Switches off
            - Unplug the USB cable if connected
            - Remove battery
            - Hold volume-up button
            - Insert the USB-C cable (red light blinks, no green light)
            - Reinsert the battery (red and green lights constantly on, the script will continue)
            - Release volume-up button

After following those instructions, the Byzantium image will be flashed onto the phone, so during these 10 or so minutes, take a break and grab a ${DRINK_OF_CHOICE} until the procedure is complete.

3 Likes

Thank you FranklyFlawless, the update worked well
my present version is as below

Unfortunately, my problem remains.
When calling the signal strength bars, after about 3 seconds, get greyed out
I think the phone is broken.
Frank

==================
purism@pureos:~$ uname -srm
Linux 6.6.0-1-librem5 aarch64
purism@pureos:~$ cat /proc/version
Linux version 6.6.0-1-librem5 (builder@cumin-byzantium-updates-proposed-buildd-arm64-scrr) (aarch64-linux-gnu-gcc (Debian 10.2.1-6) 10.2.1 20210110, GNU ld (GNU Binutils for Debian) 2.35.2) #1 SMP PREEMPT Wed Jan 10 09:42:16 UTC 2024
purism@pureos:~$ cat /etc/os-release
ID=pureos
NAME=PureOS
PRETTY_NAME=“PureOS 10 (Byzantium)”

VERSION_ID=“10”
VERSION_CODENAME=byzantium

HOME_URL=“https://pureos.net/”
SUPPORT_URL=“https://puri.sm/faq/#faq-WherecanIfindoutmoreaboutPureOS”
BUG_REPORT_URL=“https://tracker.pureos.net/”

LOGO=pureos-logo-icon
purism@pureos:~$

1 Like

Good News
After doing an update from PureOs store and rebooting.

The librem5 is WORKING. Woo Hoo

Many thanks

2 Likes