Librem 5 problems with phone call

Unfortunately no (I can not find any). I can not find anything that relates. The phone shows 4G connection and the name of the carrier appears correctly.

When your phone is in this “no call” situation are you able to send and/or receive SMSs?

Good point I will try next time. It will not be late until it does not work again. I will let you know.

1 Like

Just today. It does not make calls. SMS send to a friend was immediately delivered. So SMS works. The calls app shows only the graphic but does not call anything. And you can not hangup either. You can only close the app.

Can you maybe strace -p <pid of call process> | tee ~/call.log to see what is going on?

Next time. Sorry but I needed the phone and had to fix it. I found another procedure to fix this without a reboot.

Turn of modem by HKS
pkill -HUP gnome-calls from the terminal.
Turn on modem by HKS
start gnome-calls from the graphic icon.

Before I did that I killed gnome-calls (without turning off the modem) but did not work.
Next time I will use strace. It could be a problem with gnome-calls.


I’ve hacked all of that (and my contributions) into the Tips and Tricks:


does not copy the output to the log file. Wrong strace syntax?

I think strace outputs to stderr rather than stdout. You can give “-o” to specify output file but if you want to use tee, I guess you can redirect stderr to stdout “2>&1”.

Yes, thank you, strace needs -o. I failed to check today because the graphic crushed (could not get rid of gnome-calls) and connecting to L13 did not present the serial port ttyACM0 nor could connect through ethernet. After a while the phone lost the modem and allowed me to close calls.

I flipped the modem switch and the modem came up again, ttyACM0 was created, ethernet worked again and calls could dial out.

It must be a serious bug. Sometimes it lets me close the calls app. Other times, like today, it does not allow. If I press the lock screen button, it blanks the screen but a second push of the button shows again the stuck calls graphic.

I wonder when the Byzantium distribution will become the default. May this will solve many problems. It is already 4 of July (happy independence day) but when is Byzantium coming to L5 ?

1 Like


1 Like

Can it be a SIM compatibility issue? I never had problems with my phone, but I changed carrier and got a new SIM, now I’m experiencing troubles similar to yours.
At first I thought I made a mess sending AT commands, then I read this post and I got the doubt.

It is 3 (or 4) days now that I installed the latest update and the phone does not show this behavior anymore. It always dials out. It seems that the problem has been solved for the moment.

Lucky you!


New problem has arrived with the latest state of amber. The phone does dialout but there is no notification of the progress of the call. To be specific,

a) I dial my home landline number
b) the home phone rings
c) there is no feedback of the rings on L5. It stays silent.
d) if I pickup the home phone, voice passes both ways.

Because of c) the L5 user gets the impression that the phone does not dialout. You hear nothing until someone picks up the other end.

Could it be that some sound channel has been muted?

As far as I know issue c) is a typical side effect of enabling VoLTE on the L5 … Isn’t that your case?


I have no idea about VoLTE. Do not even know what it is.
I did nothing on purpose. How do I disable it?

VoLTE sends your voice calls over the LTE data connection instead of the 3G/2G mobile telephony connection.

For billing purposes, mobile network providers are typically not counting it as data usage, but as minutes used against your monthly plan allotment.

Many providers have started shutting down 3G networks, and in some cases 2G networks, as they re-farm their frequencies for 4G/5G. Using a non-VoLTE phone on these networks, if you’re even allowed to activate it, will suffer from calls not connecting or even ringing, as without 3G/2G or VoLTE, they have no conduit for voice calls (other than VOIP).

The situation in the U.S. is starting to become problematic for some users without VoLTE-capable phones.

Are you sure about that? I don’t think calls would work at all if VoLTE is to be used and before the VoLTE support has been released (and @antonis is using amber). So it is doubtful that (d) would occur.

Anyway keep an eye on the top line of the Librem 5 screen when you make a call. Normally it will, prior to the call, be “4G” but it will drop down to “3G” (or maybe “2G”) when making a call - unless VoLTE is being used. @antonis ?

Obviously this also depends on Settings / Mobile / Network Mode. I assume the default (?) of: 2G, 3G, 4G (Preferred). And assuming that both “4G” and “3G” are available in your area.

Yes that is what it does. Before it says 4G and when I make a call it drops to 3G or even 2G. So if I understood your writing I do NOT use VoLTE.

And why does this happen anyway? Why it drops to lower speed connection?

In any case I still do not hear the ringing feedback. It stays silent until the other side picks up.