Librem 5 problems with phone call

You understood. You are not using VoLTE.

Historical and compatibility, I guess. That’s the way it used to work before LTE (4G) even existed (i.e. voice calls were made using 2G/3G) and when LTE was introduced, it was introduced only for data. At the time there would have been a mass of handsets that were not capable of LTE at all (so there was always going to be a period of overlap - and that period is coming towards its end).

A voice call doesn’t need much bandwidth. You don’t need the bandwidth of LTE for a voice call. Only a data call can fully utilise the bandwidth of LTE.

It is possible also that the lower bandwidth of 2G/3G is more robust in the face of unintentional interference and/or a weak signal, so maybe you are more likely to be able to make a call with 2G/3G than with 4G in marginal areas - which perhaps would have figured in the thinking of risk-averse legislators, particularly in my country where there are a lot of marginal areas. LOL.


I have some news but I am not sure it makes sense. Today I went to the airport, an hour drive from my hometown. So obviously I was using another cell. The 4G did not drop to 2 or 3G and there was feedback of the ringing. Now I am back to my hometown, the 4G drops to 3G and there is no feedback of the ringing again.

While driving to the airport I also noticed that although it connects to the car’s bluetooth, and although the cars buttons (next track previous track) work when L5 plays through music Lollipop, the sound does not get to the cars sound system and keeps playing through L5 speaker. Momentarily when music starts L5 shows a slashed circle, and plays through its own speaker.

Let me notice that music though bluetooth to my cars sound system was working a month or so ago.

When is Byzantium coming to L5? :wink:

I think it’s known that the Bluetooth support is incomplete in a car situation. I tried sound output via Bluetooth (not to a car) and it didn’t work at all.

Yes, I am. Enabling VoLTE is a manual process in Amber (but it does not necessarily work). Once enabled, in some cases there were issues with the ringtone not happening in an outbound call. Of course it cannot be done accidentally.

Based on my experience the icon shows a lesser network after several seconds, so you might feel that you are using VoLTE, but you don’t.

Maybe mmcli -m any | grep access will shed light?

For me that usually gives “lte” (4G) but if I force the phone down to 3G via Settings / Mobile / Network Mode then it gives “umts” (3G).

mmcli reflects the status of the network icon: it says “lte” while there isn’t an ongoing call, but it shows the actual band during a call (after few seconds into the call)

OK, but I meant @antonis to do that.

I will try that @irvinewade but this situation is “unstable”. Although I did not upgrade anything the last days it works as expected (the phone reboots at least 1 time per day, but that did not solve the problem when it was there). I will do that if it decides to misbehave again.

1 Like

I had similar problems and it started after I tried to switch the network manually (between the companies). The list of the cellular networks didn’t appear. Instead of showing the list, the query to network timed out. After that, I tried rebooting Librem 5, tried another sim card, taking battery off, but the problem was still there. I was able to use internet with 4G, but not able to call for anyone.

Solution for me was to choose again to browse network manually and when it starts to do that, quickly tap the automatic finding of cell networks. Maybe this bug has something to do with this request to change network from the list, which eventually times out.

1 Like