Librem 5 problems with phone call

I received my L5 last December.
I recall it did make phone calls.
I then had a problem and had to send it back to purism.
After many months, the L5 returned.
Today, after I had it doing little on my desk for a good month, I decided to try a whole day with the L5.
During the day, I needed to make a phone call and the l5 showed that there is a 4G reception, but the calls were not connecting. I just got the graphics and it said Calling, this call in not encrypted , but no actual calling.
Any advice on how to start troubleshooting the issue?
Cheers

1 Like

I’ve noticed that sometimes I have to go into the L5’s settings and reselect/reset my saved network provider (even though it has been saved already). Do you see the name of your provider on the main page of Mobile settings, or is it blank? If it’s blank, tap it and reset the provider.

(And your issue may be different from this one, of course.)

1 Like

Try to put your modem manually only to 3G network, then try do calls again.

1 Like

It did show my provider being EE in the uk.

1 Like

I did put it on 3G only and it didn’t even pretend to do a call.

1 Like

Conversely, is the 4G actually working? That is, not thinking about calling, but instead trying to access the internet, does that work?

I assume you have a BM818-xx modem.

You should verify whether you are calling from the Contacts app or calling from the Calls app and explicitly dialling the number. The latter may be simpler for troubleshooting purposes. (Some people have had trouble with the format of phone numbers as stored in the Contacts app.)

SIM card inserted? correctly? valid? (Do you have a SIM PIN? If so, are you being prompted for the PIN at boot up?)

You could try to dial a call completely manually using an AT command and see whether you get an error message.

It goes without saying that you should apply all available updates before continuing with the troubleshooting.

Is this other problem relevant to the problem here, or definitely unrelated?

1 Like

Hi @irvinewade
Thanks for taking the time and replying to this post.
Here are my answers:

The point of this was to demonstrate that initially I had a working device(phone call wise) that stopped working. (it was to do with charging)
I sent the device back to Purism, and then I received a device back from Purism.
It may be that they sent me a different device back?? With a wrong modem??

How do I check what modem does the device have?

What is the AT command?

Device is up to date

No

Thank you for you suggestions

1 Like

What about the questions about the SIM?

Awkwardly, I couldn’t immediately see how to do that (get the model number) in software.

Maybe the only way is to open up the back and I hesitate to suggest that.

The mmcli command can get a welter of information that should at least shed light on the state of the modem. (Be careful about posting any of the information.) See: https://source.puri.sm/Librem5/community-wiki/-/wikis/Tips%20&%20Tricks#modem-manager

Maybe. Or with the right modem but they had, during testing, put a different modem in it and messed up your settings.

Did the phone come back with your stuff still on it at all?

Let’s focus on that. Clearly something is not right. For testing purposes you want to ensure that the WiFi HKS is “off” and the Mobile HKS is “on”.

Yes that was the case

There is only one way to put the SIM in. Also the fact is that the device has the 4G icon shown.

having run some of the mmcli commands $ mmcli -m 3 (3 is the output from $ mmcli -L )
I am not entirely sure what can I reference as the modem model. You mentioned BM818-xx but I am not able to spot this string of characters in the output.
It does say something like manufacturere : QUALCOMM model: 0
I don’t know if this tells us anything?

grep broadmobi

Yes, the chip is Qualcomm, not the whole modem.

From Librem 5 BroadMobi modem reports wrong (?) manufacturer/model info -- bug in firmware? Where to find documentation for the modem?

the incantation to execute an AT command is as follows, also showing you how you can check the modem model.

sudo mmcli -m 3 --command=ATI

but unfortunately that didn’t work for me on my phone when I just tried it. Maybe it will work for you.

But getting back to the other mmcli output, does it show the “operator” to be what you expect? What about the “state” and “access tech”?

How did you establish that you have no 4G internet?
ping 8.8.8.8
would be a reasonable test.

PS I found a way to do an ‘ATI’.

mmcli -L
mmcli -m N | grep ttyUSB
minicom -D /dev/ttyUSBN
CTRL/A E
ATI
CTRL/A X

where ‘N’ needs to be replaced in the hopefully obvious ways.

I’ve done that sshed into the phone, for convenience, and done it as root because I don’t know which bits would require that and which not, and I’ve had to install minicom first.

Anyway, for me the output from the ATI command is

Manufacturer: BroadMobi
Model: BM818-T1
Revision: M1.0.2_E1.0.0.0_A1.0.2
IMEI: 999998888877777
+GCAP: +CGSM

OK

so that would seem to be the definitive way, for me, of checking the make and model of modem.

1 Like

More recently I learned that we can also use “-m any” instead of -m N which means it will take any of your modems. Since the L5 only has one modem, the effect should be the same as -m N but we no longer need to worry about finding out the value of N. :slight_smile:

Maybe you got the error message “Cannot send AT command to modem: operation only allowed in debug mode”?

To make ModemManager run in debug mode, change the ExecStart line in the file /lib/systemd/system/ModemManager.service by adding --debug so that the like looks like this:

ExecStart=/usr/sbin/ModemManager --debug

After that, run the following commands to make the change take effect:

sudo systemctl daemon-reload
sudo systemctl restart ModemManager.service

Then it should be running in debug mode, so the command sudo mmcli -m any --command=ATI should then work.

1 Like

Yes, that was it. Thanks for the pointers for how to run in debug mode.

Are there any security implications in doing it that way? Granted though that as long as you remember to set it back, it shouldn’t matter. Would it be recommended to revert out of debug mode afterwards?

Yes, for the first N (the modem number). The second N (a different value) is in the tty device name.

this returned error: couldn't find modem

ping 8.8.8.8 didn’t work connect: Network is unreachable`

Apologies but nothing here is obvious for me…:slight_smile:
mmcli -L returned /org/freedesktop/ModemManager1/Modem/2 [QUALCOMM INCORPORATED] 0
so I took the number 2 at the end of the path to be the number I am after
here’s what sudo minicom -D /dev/ttyUSB2 returned
`Welcome to minicom 2.7.1

OPTIONS: I18n
Compiled on May 6 2018, 07:48:54.
Port /dev/ttyUSB2, 09:12:56

Press CTRL-A Z for help on special keys

ati

Manufacturer: BroadMobi
Model: BM818-A1
Revision: M1.0.0_E1.0.0.0_A1.0.0
IMEI:
+GCAP: +CGSM
`
So what now?

Is that the variant (A1) that you had before?
Is that the variant that you ordered originally when you received the “modem selection email”?
Is that the variant that you want?

That would mean that you picked the wrong modem number. Use the number given by mmcli -L or, as @Skalman says, put any in place of the modem number. (At any one time, you will only have one modem, even though the modem number will vary from time to time.)

No, the number for the device name for the minicom command comes from the grep of ttyUSB, which shows that the modem presents as 4 ttyUSB devices but not all of them can be used for AT commands. (At the current time for me, ttyUSB0 is being used for the QCDM protocol - whatever that is - while the other 3 can be used for AT commands. So you got lucky.)

Do you have the broken network icon in the top line of the screen?

Sometimes you can erroneously have that, in which case you should kill switch off the modem, count to 10 :wink:, and then switch it on again. You should also verify in the Settings / Mobile that you have enabled “Mobile Data”.

ok strange things are going on.
my 4G Data is now working. I can ping and I can reach websites.(slow but working)
I read here that for Europe it needs to be E1 not A1.
Since I have the A1 I obviously was shipped the wrong device.
I had a feeling I was sent a different device to the one I sent.
I have initiated contact with Purism.

3 Likes

You can mmcli -m any | grep 'access tech'
and mmcli -m any | grep 'current: allowed'
and mmcli -m any | grep signal

to investigate the slowness. If you have the wrong modem variant then you may be being forced onto a compromise band that happens to overlap between -A1 and -E1 and that might be forcing you to a tower that is further away.

(You can also get the signal strength from Settings / Mobile / Modem Details.)

Maybe none of this information is really helpful unless you have a baseline against which to compare i.e. you know what the info was before the phone went in for repair.

In any case, clearly if you send a phone in for repair, it should come back with the same modem variant. So there’s probably not much more that can be achieved in this topic and only Purism can sort that out for you.

1 Like

When running in debug mode it will write more info to the log, I guess that can be seen as a security problem if you think someone can snoop on your log, although it is only on your local device. Anyway, for me, the main reason for not leaving it in debug mode permanently is that it can probably degrade performance, it will do extra things, debug logging and perhaps other debug-related things that can make things slow and/or consume more battery power than normal. (Not sure if it matters in practice though, could be negligible compared to other things.)

2 Likes

Something is buggy with the modem/kernel and can not be fixed by resetting the provider or even flip the HKS for the modem. I have the same issue starting from a cold boot. Often when you do this, (and not rare) you can not make a phonecall or receive one. The only remedy is a reboot and test again. It has happened to me that a second reboot was needed to wakeup the modem but this is more rare. Sometimes I have to poweroff and start from cold again.

Once the modem is up and can make calls it will keep working until a shutdown is performed. Then starting from cold it may not work again. So if you never shutdown (say you dock it at night to charge) you will not notice the problem.

Personally I power off L5 every night. In the morning, I would say, 1 every three times it will not work and I have to reboot. So recently I got the habit of making a call in the morning to my home number to check if it works. If not, reboot.

As said, flipping the HKS does not help.

1 Like

Is there any information on a screen or at the terminal that correlates with this? That is, is there any way to detect this without making a call?

I power off every night too. For a while there (when the MMS DoS problem was happening) I was sending myself a text message first thing every day. Maybe I should resume doing that.