Librem 5 PureOS Store Uninstall app

Once installed cannot uninstall PureOS app from the store. I assume these are flatpacks but flatpack commands in the terminal do not work.

Ideas how to get rid of apps installed manually?

e.g. uninstall Evolution

If you installed at the shell with

apt install package

then uninstall at the shell with

apt remove package

(remove software but keep any related system configuration or settings)


apt purge package

(remove software and related system configuration or settings)

1 Like

actually installed on poureos store thats what is confusing. the pureos store says no packages to remove even though it shows as installed eg “Evolution”

If you have Librem 5 Goodies installed (do you?) then (on my phone) that depends on parts of Evolution.

Probably best to leave it.

i have goodies installed, for some reason though nothing uninstalls, that was just an example, “Password Safe” also doesnt uninstall.

I guess: Find out the exact package name and use one of the above apt commands. At least you might get a clearer idea of why it doesn’t want to uninstall, if it still refuses to.

That worked for me, it would be nice if the PureOS store made it easier to see which apps can be uninstalled from within the pureos store and which require apt terminal function.

  1. suggestion to have an “i” icon for each installed up that shows things like package name, installed location, installed manually through PureOS store, installed manually through terminal, installed as part of PureOS package install.

I haven’t looked under the covers but I would guess that

  • it can’t tell whether a package was installed via the GUI or installed via the terminal
  • it can tell whether the package was installed manually (explicitly) or installed to satisfy dependencies for something else

We also have to allow the possibility that what you are experiencing is just a bug.

1 Like

The PureOS Store is not very good, needs work. Thoughts so far, of the current version…

  • if updates need to be “dist-upgrade” it doesn’t seem to be able to update
  • it’s not able to remove software
  • if there are dependency issues, it gives no solution or info
  • categories are slow to load or don’t load at all (no apps appear after waiting), and the categories themselves are not intuitive (more would be better - there already are some “Other Categories”, which are empty)
  • can’t see what updates have been applied, when and what changed (only available when updating)
  • activating (warning) and managing flatpaks, snaps or other PPAs should be baked in to one - this is not it (would be nice to be able to set boundaries to apps when or even before installing them)… and on that note, I think there should be some kind of guide and link to managing webapps too (“one stop shop” of everything app related)
  • and as was already mentioned, there seems be no settings, such as if and when to check and possibly download an possibly install various updates
  • no indication if new apps are available or if new adaptive apps are available
1 Like

I want to add some further issues:

  • Going in PureOSStore --> Software Repositories under Packges I can see Byzantinum + sceurity + updates. In the subtitle it is written: 0 applications installed (which is not the case -.-)
  • I added Flathub so the repo is also mentioned in PureOSStore --> Software Repositories, but the slider button is inactive
  • Going in GNOME Settings --> Applications no applications are listed

Another question:
Is it possible to purge PureOS Store without crashing the system because of its dependencies? I tried apt remove instead apt purge and also saw a lot of necessary apps which will be removed too. So, finally I decided not to delete it.

Hey there,
I could resolve the last point of my old post. You can find the problem here: GNOME Control Center - No Applications

The solution is to install malcontent: sudo apt update && sudo apt install malcontent

My system at the moment of the problem: PureOS Byzantinum + Kernel 6.1 + gnome-control-center 38.4-1pureos7

Sadly I have not found any solution for the other two points I marked in my old post. See what the future brings…Maybe some app upgrades in PureOS itself XD

How do I uninstall cameracalib.desktop? What is the package name? Using apt list camera or apt search cameracalib did not work.

This app also installed a lot of additional apps: 2D SLAM dem, kinect-stereo-,Navigation loc, Rawlog Viewer, Reactive Navi, etc

What is odd is that typing camera-calib in terminal opens the program but typing sudo apt remove camera-calib says
** E: Unable to locate package camera-calib**

1 Like

I guess you need to look for a package name containing something like ‘mrpt-apps’ or ‘libmrpt-dev’


dpkg -S /path-to/the-specific.desktop

The directory is usually /usr/share/applications


Yeah, I can’t find it in there. What is the name of the PureOS Store? I am thinking to launch the store with sudo from the terminal and then maybe I can uninstall it.
I’ve noticed that usually apps that require sudo are the ones that can’t be uninstalled from the store.

1 Like

The things is, I want to uninstall all the apps with a single command. I don’t want to manually uninstall every app that was installed with this package, the risk of removing something that is essential to the phone is too big.

1 Like

What does that mean? The command that I outlined gives no output? an error? What was the command that you typed? What was the error message?

Note that that command doesn’t change anything on your system. It just answers the question “What is the package name?”

Once you have uninstalled the actual package, you can use sudo apt autoremove to see what can consequently be removed. However if you are nervous about that, you might want to do the “autoremove” twice i.e. once to get a list of packages to post here (and hence not confirmed) and then the second time in order to go ahead, if the list of packages seems appropriate.

1 Like

Thank you for your reply sir irvinewade.
It outputs:

thunderbird, mrpt-apps, librem5-goodies, yad, firefox-esr, keepassxc, gnome-weather, 
gnome-user-share, gnome-usage, gnome-terminal, nautilus, gnome-session-common, 
gnome-maps, gnome-initial-setup, yelp, gnome-disk-utility, gnome-control-center, 
gnome-contacts, gnome-clocks, gnome-chess, gnome-calls, gnome-calculator, 
gnome-bluetooth, gnome-calendar, gnome-2048, gkbd-capplet, geoclue-2.0, gedit, 
geary, evolution-data-server, gcr, evince, epiphany-browser, eog, desktop-file-utils, 
deja-dup, chatty, phoc, python3.9, rygel, librem5-base-defaults, notification-daemon, 
millipixels, xdg-desktop-portal-gtk, pureos-store, network-manager-gnome, vim-common, 
phosh, phosh-mobile-settings, squeekboard, kgx: /usr/share/applications

EDIT: Formatting
EDIT2: It might be (and probably is) that the app in not from the “official” PureOS repository. Earlier I run the command flatpak remote-add --if-not-exists flathub to get access to more apps.

1 Like

Try uninstalling this.


Unfortunately the wrong command.

You specify the actual .desktop file that you are trying to uninstall.

So probably: dpkg -S /usr/share/applications/cameracalib.desktop

In response to: