Librem 5 Pureos Store Upgrade Seems Broken

Using the Pureos Store graphical app:

“Loading Updates… this could take a while”

Two hours later: “Loading Updates… this could take a while”

Three hours later: “Loading Updates… this could take a while”.

How do I get updates to work again?

Also, how do I repair the Pureos Store? All app categories are only empty boxes with three dots in each box. No apps are listed anywhere there now. I might have broken it when installing the whether app. The app froze up. The app wouldn’t close (kept bouncing back when swiping all the way up). So I rebooted the phone to force the app to close. Now the store is broken.

Neither sudo apt update nor sudo apt upgrade help.

At one point something I did (can’t remember what) showed locked files, with a warning that forcing them to unlock might damage the operating system. So I just closed the terminal window.


I’ve experienced this for so long I’ve come to think of it as default behavior for the “store”. It’s just horrible in design, name and function.


That is true. But this seems to be the case for almost all stores on linux distros I have installed (on computers). I don’t know what it is, but they almost all suck. PureOS is no exception. Terrible.

Works way better than it used to. If it fails to start or spins an endless donut, I kill “Software Installs” from Usage. But then I only use it for discovery and rarely to uninstall something – I always update from the terminal.

Still, I have to wonder why it works so well on Armbian, Mint and Ubuntu, but not on the L5. :man_shrugging:

Does it work right on the L14?

It’s because it is just GNOME software with few modifications. It is relatively old in Byzantium and should be much better with the next PureOS release crimson.


Yes. I use GNOME Software on my Fedora desktops, and it is way faster and more reliable than the rather old PureOS Store fork of it. I have the feeling that especially having flatpaks installed makes the application less reliable.

This issue is in my bookmarks to provide quickly the link here in the forum :slight_smile:

1 Like

re: Your link to “This issue”. Here are the steps that got me past this issue:

Click “Usage” icon on Librem5 desktop. Scroll down to find: “PureOS Store” and touch it. Touch “Force Quit”. Then wait.

Now re-open pureOS Store (by touching Libre5 desktop icon). Says something like: (loading …)

Wait some more.

Now touching “Create” makes screen changes to “Create” with subheading “Other Software” with 4 blank boxes with “” in each, etc.

Then wait some more and finally it displays a list of software.

Also touching back arrow, then touching “Work”, then waiting some more, … and then screen changes to “Work” with subheading “Other Software”, then waiting some more, it finally displays a list of software.

I now seem to recall that I’ve done this all before. (I don’t really use this phone right now. Waiting for it to get better, so all I really do is updates.)

Overall the whole experience is tedious.

Also now it says Software Updates available, so these must have been blocked or dammed up, so am working on that now.

After reboot now it says, “Low Disk Space on “boot””. $ sudo apt autoremove # fixed that.

Yes, and for me, confusing. Due to the “tedious” process, I think deleting/uninstalling the link to Store is faster.

I click Store and I’ve waited 20 minutes and nothing loads up. I assume there are no more programs available. Tried each category and same result - empty after 20 minutes allotted.

I also have the useless error note:

Will "$ sudo apt autoremove #" remove it, and repair whatever prompts to error? I’m not sure what is being removed, the error notice, or the issue causing it.

(Correcting myself…) If you run sudo apt autoremove and it finds some unused Linux kernels, then removing those should free up space.

It is not a useless error message. It is alerting you to a potentially serious problem, a problem that will be much easier to solve before it becomes a serious problem.

Diagnose with the command: df /boot

and look at the Use% value.

This worked for me, …for now.

It does not remove all old kernels, but it is easy and harmless. Use $ df before and afterwards to see if you have lowered your /boot partition usage. If not, you might need other steps removing old kernel packages.

Before using the autoremove:
using df /boot:
Filesystem 1-K-blocks Used Available Use% Mounter on /dev/mmcblk0p1 461052 0% 100% /boot

With autoremove commands:

Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
The following packages will be REMOVED:
linux-image-6.2.0-1-librem5 linux-image-6.3.0-1-librem5
0 upgraded, 0 newly installed, 2 to remove and 1 not upgraded.
After this operation, 180 MB disk space will be freed.
Do you want to continue? [Y/n] y
(Reading database … 109211 files and directories currently installed.)
Removing linux-image-6.2.0-1-librem5 (6.2.13pureos3) …
update-initramfs: Deleting /boot/initrd.img-6.2.0-1-librem5
Using DTB: freescale/imx8mq-librem5-r4.dtb
flash-kernel: Kernel 6.2.0-1-librem5 has been removed.
flash-kernel: A higher version (6.5.0-1-librem5) is still installed, no reflashing required.
Removing linux-image-6.3.0-1-librem5 (6.3.13pureos1~byz1) …
update-initramfs: Deleting /boot/initrd.img-6.3.0-1-librem5
Using DTB: freescale/imx8mq-librem5-r4.dtb
flash-kernel: Kernel 6.3.0-1-librem5 has been removed.
flash-kernel: A higher version (6.5.0-1-librem5) is still installed, no reflashing required.

After: df /boot

Filesystem 1K-blocks Used Available Use% Mounted on
/dev/mmcblk0p1 461087 192143 245136 44% /boot

After cold reboot and using df /boot again.

Filesystem 1K-blocks Used Available Use% Mounted on
/dev/mmcblk0p1 461087 192143 245136 44% /boot

Since I will be reflashing, even though the autoremove said “no reflashing needed” I am not worried about space for now.
It freed up space.

My search, so far, hasn’t found a command to check for updates, the L5 being on still, hasn’t notified me of updates.

Since I will be reflashing, I am still trying to where the find where ‘Chat’ stores the attachments. I even tried that narrow minded Google too. To many other like it use the word/s chat.

Posted using L5 :relieved:


It’s sudo apt update. It then looks for them, and if it finds any, the command to install them is sudo apt upgrade. That upgrades the installed packages that pertain to the found updates.


The chats are stored here:

To open the .db file and read it, you need a database-reader app, and they’re kind of complex to use for browsing what’s there, in my opinion.

But if you’re only interested in saving your chats to the card for importing them back in after you reflash, then you don’t need to read it, I guess.

I don’t know if chat attachments are stored there as well.


:100: You da man!

Thanks Amarok
That is the solution.


There will be the same issue with Contacts, location as given here: Tips & Tricks · Wiki · Librem5 / Librem 5 Community Wiki · GitLab

Again, for save and restore around a reflash, just knowing the file path should be enough - and that did work for me.

Before replacing (or saving) a .db file, I recommend ensuring that no process is accessing it.


I can’t find the images so am going to save each on, one at a time, using Save To USB stick. Tedious, but faster I think than spending hours again reading. YES, things need to be read, but no time for novels in another language - techineze). And yes, I’ve dozens of tab open tabs, deciphering, cross referencing etcetera.

I didn’t buy it for hobby time. I ended up with it to help save time!

I was chastised by local health care giants for not having a cell. Until it works smoothly, I don’t fess up to having one.

A trick I learned is to leave the back off. Too man times it locks up with screen of icons. Too, just touching the USB C female causes the device to freak out and give a blank screen, Services locks up w/ opening Advanced Network.

1 Like

Hopefully, reflashing will correct some of that. :crossed_fingers:

1 Like

Yes and there are many other crazy things going on. “Restart” hangs. I’m confident that reflash, if I manage it right, will correct many issues.


I suppose it might also be worth it to copy any Geary profile/config for restoration after the reflash…? It would save having to set up email again.

(I don’t currently have any email accounts loaded in Geary, so I can’t tell what files might normally be present inside /home/purism/.config/geary.)

Other things that might be worth backing up:

certain contents of /home/purism/.mozilla (if you’ve done any personalization, e.g. bookmarks, extensions, chrome/css, etc.)

certain contents of /home/purism/.config/epiphany (ditto)