Librem 5 various observations

Some of these I’ve aired before, others not. Most, I think, can be fixed in software.

  • Should really tell you what the battery charge percentage is on the lock screen. It’s annoying to have to unlock the phone just to see the charge percentage.
  • The privacy settings for lockscreen don’t seem to work (or I flatly don’t understand them). I want the screen to power off quickly (to save battery juice), but not LOCK for several minutes; that way I can set the phone down, do something else for three minutes, and not have to unlock it. As it is, if the screen goes off the phone locks, despite settings that supposedly will let you set a delay.
  • Sometimes when I am midway through typing in the PIN to unlock the phone, it simply goes black again, and I have to do it again. (this item and the one above make me wonder if there are TWO instances of the lock screen software running, somehow, with perhaps only one of them paying attention to the settings panel.)
  • Why does the phone power on when I put the battery in? Shouldn’t it stay off until explicitly powered on?
  • The calculator app keeps popping the virtual keyboard up, even though it has a built-in number pad. If I change views or do anything, up pops the keyboard, and I have to shove it back out of the way.
  • (This one is hard to reproduce, but I think the following will suffice). If I put all of the kill switches “down” (ie. OFF/Killed) and start the phone, as expected the screen rotation portrait/landscape must be done manually. Turning them ON after powering up doesn’t seem to re-enable the automatic rotation, and you can’t get to it through the swipe-down settings panel; all it will let you do is manually set the orientation. (I tried a long press; it doesn’t work). Going into settings->display reveals a screen orientation option, but it’s mislabeled; it says you are in landscape in vertical mode, and portrait in horizontal mode. A restart is necessary to restore the automatic rotation as an option. The sub menu in settings does NOT show up if you turn off all the kill switches AFTER the phone has been started. In other words the screen rotation software doesn’t seem to properly respond to the sensor being killed/unkilled with the kill switches while the phone is running, AND that one settings panel has portrait and landscape confused.

Most critical for me, though, is a hardware issue and support is now being non-responsive. I can’t get the modem to work. I’m on T-mobile (USA), and Support sent me a second modem with what was supposed to be a different firmware version that would work. However, it doesn’t, and they’ve not responded to two emails now where I told them it doesn’t work. So my phone is not a phone.

EDIT: Support did get back to me. They responded instantly the first time, which spoiled me, and it took a few days this time. (We’re now going through a third iteration, since they asked for a log file; I now know not to be concerned unless it takes over a week to get back to me.)

10 Likes

Hey @SteveC i can confirm all the same observations that you have from the user perspective at least all these little issues add up a little frustration sometimes. Hopefully none of them are difficult to eventually run down in software and optimize.

Sorry to hear about the modem if it doesnt power up i would contact support. If it doesnt connect make sure APN settings are correct. Switch SIM cards and test with different provider.

I’m totally unable to detect the Tmobile network. I can see the AT&T network on it, at least from work I can.

It powers up; I can get its firmware version number.

I HAVE been in touch with support, but they stopped responding when the second modem didn’t work. EDIT: they DID respond, it just took a couple of days longer the second time. The fast response the first time spoiled me, I guess

1 Like

Sorry, this has been half-done for ages. https://gitlab.gnome.org/World/Phosh/squeekboard/-/merge_requests/291

3 Likes

Those are the same observations I have made so far, but did not report back to Pursim (yet).

This is good news and bad news. If we both came up with the same list then that’s a good sign that that will be most of the prominent issues. (Of course, there is always one more bug, but hopefully there aren’t TOO many more.) The bad news is that they are known issues already, but haven’t been fixed (and I’m not being cynical in saying so; there are plenty of benign reasons for that to be so, if indeed it is so).

Thanks!! (You’ve been most patient with my gripes!)

another observation i have which is a little odd one.

  • when the battery drops below 10% it seems to get hotter than when the phone battery is 100%, its completely subjective but the phone power draw seems to increase the lower the battery which is a little odd

anybody can corraborate?

You mean when not charging? i.e. operating strictly off battery.

Configuration: on battery not charging, 4G Mobile Roaming Enabled with VPN, with or without using the phone, screen locked or unlocked, typical running applications: chatty, geary, firefox ESR, Files, Contacts, Tootl.

It makes some sense, actually.
When the battery is full, the voltage is around 4.2V.
As the battery drains, the voltage gradually drops, probably close to 3.6V.
As Ohm’s law says: Power (W) = Current (A) x Voltage (V) , so for the same “requested” power from the battery, let’s say 10W, at 100% (4.2V) the current will be 10/4.2 = 2.38A, while at 3.26% (close to 0%), the current will be higher: 10/3.26 = 3.06A; that’s ~0.7A more - pretty noticeable difference.

More current (Amps) from the battery will generate more heat. So for the same power draw, at lower charge levels, the phone will get hotter.

You can run the Power Statistics app, select Laptop battery, History, select Rate and keep it open from 100% to 10% and compare the power draw in W (Rate) to the Charge level graph.
For battery temperature, you can use upower -d or sensors from package “lm-sensors” in Terminal. sensors will show you the current (mA/Amps) draw to (+) or from (-) the battery (only the negative values have the “-” sign prefixed), and the voltage levels.
Or just cat the files in /sys/class/power_supply/max170xx_battery/.

The better example is the other way around: when charging the battery. But keep in mind that the charge controller will push more power (and current) to the battery when it’s at lower charge levels (up to 1.7 - 1.9A from what I’ve seen) and gradually reduce the amperage as it fills up. At (close) to full, the input current to the battery is around 0.02A (trickle charging) and it should get to 0.

But the bottom line is that at low charge levels, the battery will be the hottest, due to high current (A): it gets up to 46 C on a 25C ambient temperature, that is without any significant usage load (no apps, 4G on w data off, WiFI off).
It will become a problem to charge the battery in hot environments or when you also need to use the phone heavily, i.e. the charging will temporarily stop, the red led will blink, etc.
And the fact that the Redpine WiFI module is probably the hottest component (even ~idle), doesn’t help either. I might try testing the Atheros WiFi module from the L14, for my own curiosity.

Edit: corrected minimum voltage around 0%

5 Likes

Yes that makes sense using the history rate now, within the statistics app it does not show the current profile though so you are saying you have to manually collect and plot the current data and over time 100%-5% over multiple discharge cycles plot and overlay current cycle data to see if trends exist or something like that?

I distinctly remember the iphone at times exhibiting similar behaviour, but that was fixed over time via software.

Not really - because it has already been done. But, yes, if it interests you then a cron job grabbing data from /sys/... and adding to a .CSV file, coupled with LibreOffice, should be able to produce some nice graphs of current v. battery charge percentage.

2 Likes

This seems to be a problem with the modules/drivers for LSM9DS1. If you are in your error state that you cannot re-enable the automatic orientation try the following:

  • run monitor-sensor in one terminal. You should get a line No accelerometer. The command will continuously show you the state of the sensors of the phone.
  • in another terminal run the command sudo rmmod st_lsm6dsx_i2c st_lsm6dsx_spi st_lsm6dsx; lsmod | grep lsm to remove the drivers for LSM9DS1 and check whether the modules disappeared. If you still get an output showing lines including st_lsm6dsx you’ll need to try again and maybe debug why the modules didn’t unload.
  • after you successfully removed the three modules make sure at least one kill switch is in the position for “on” - e.g. enable mobile modem.
  • (re-)load the modules for LSM9DS1: sudo modprobe st_lsm6dsx_spi; sudo modprobe st_lsm6dsx_i2c; lsmod | grep lsm
  • in your terminal running monitor-sensor you should get a line containing +++ Accelerometer appeared and the symbol in phosh for screen rotation should switch to automatic again
1 Like

Started configuring a work-around for the issue and a similar one concerning the proximity sensor. You can follow progress here.

Update:

Done, the configuration works on my Librem5 running PureOS Byzantium.

@SteveC could you test the solution and provide feedback?

Another update:

I already installed the package from the pipeline in my repository and it seems to work. Be aware if you want to test it that it also contains some more changes made by @dos and @evangelos.tzaras .

Installing the so far unreviewed package might brake your installation. If you’re not able to fix that by yourself - please wait until the changes made it to the official repository and you’ll get them offered as a regular update.

3 Likes

very cool, won’t test it but thanks for the work, i have had issues with the proximity sensor sometimes running when it shouldn’t probably draining battery. it would blank the display when i put my finger on it even though i didn’t make a call.

It’s merged now and will hopefully end up in the next release :slight_smile: :partying_face:

A couple other observations:

  1. setting scaling below 200% appears to break the settings menue, can’t use it after rotating screen portrait, landscape, other apps works.
  2. the auto high contrast mode is great, but appears to activate differently for the keyboard, the apps, the browser, and the shell (after restart it works better).
  3. there is too much lag in opening the gnome settings panel.
  4. in app text selections in general doesn’t work well and text selection in the Geary email app does not work unless you select reply and text is editable, text selection through touch input is jerky and tends to select paragraphs instead of just text lines or words (same in the notepad app).
  5. touch input scroll is jerky as well and swipe or scroll doesn’t appear sensitive enough and is cancelled, or when executed scrolls too fast, this also happens in Firefox.
  6. while on the desktop all these actions seem to work fine using a mouse or touchpad.