Librem 5 won't boot

When I attempt to turn on my Librem 5 I get a green indicator light, but the phone doesn’t actually boot, i.e., nothing shows up on the screen.

For a little background, yesterday I made a call on the L5 and while on the call, the phone just shut down on me. I had been using it less than an hour, but I thought it might have been a batter issue, so I ran the recharging procedure (Evergreen)… multiple times… after the 3rd or 4th time the phone actually booted up. I started using it again to set up some apps and after about an hour it died again. I know it had a little more than 50% battery because I saw the battery indicator just a few minutes before it died. I ran the recharging procedure again today and all I’m getting is the green light.

Does anyone have any thoughts about what I might do to get it working?


1 Like

Is the light constant or blinking?
No possibility of a heat issue?

I don’t suppose you got a spare battery - it would be easy then to see if it could be a faulty battery? I’d contact support. (If it would happen to be faulty, take precautions it going catastrophic as battery fires are nasty and faulty ones are more likely to fail)

If you do get it to boot, you might want to take a look at the battery charging graphs.

1 Like

It should be a broke kernel or bug.
The only you can try it is unplug the L5 then force to turn OFF the phone like long pressing the power button for 20 sec, after turn ON the L5 by pressing the power button for long press 20 sec. If not booting with this maybe a kernel issue or dep then you need reburn pureos in ur L5.

The phone is room temperature, so I don’ tthink it’s a heat issue. No, I don’ thave a spare battery.

1 Like

I’ve tried the long-press method both to turn off and turn on the phone. How would I reburn pureos without the phone booting?

The only way that the L5 will suddenly shutdown it is if the L5 get really hot, or break a critical dependencies, there is a troubles when the machine suddenly shutdown, something will never boot because a broke filesystem, this behavior has happened to me on gnu+linux OSes.
There is a tools called Jumpdrive to recovery the L5 sadly I don’t know how it works but there are other people here more expert than me about Jumpdrive like @Quarnero
To Reburn PureOS you can follow the instructions: this post it out to date, so replace that step for: and last step librem5-flash-image --dist byzantium --variant luks exemps: New Post: Reflashing the Librem 5
Please before Reburn PureOS take the time to learn good all the documentation for reburning… if it is the first time doing this do not be hurry and wait to learn good all the documentation, Librem 5 it is NOT a conventional phone like others, it very very import to learn all the documentation only doing this will safe prevent that you broke your L5 again.
After Reburning PureOS make sure that all Firmware and Driver it up to date specially the bootloader das-uboot.

Additionally you can try Rescue before Reburn like remove the battery and let get the L5 get cooler later put the L5 on Lockdown mode(ALL HKS OFF) insert the battery turn ON by pressing the power button 5 sec, if not boot with 5 sec pressing, try with 20 sec power button long pressing.

1 Like

This method should help there in order to change something and hopefully properly re-calibrate your currently used battery:

By taking out Librem 5 battery and after some seconds putting it back into its slot you might expect that noted battery percentage changed to some other value, but this is not important for you (but for the used battery of course, I guess). What is important that you do (watch/wait for around four hours) is to keep your Librem 5 charging until the red LED light turn off (100%). Please note that your Librem 5 battery by doing so cannot overcharge (I’m quite sure), so do not worry much about when to disconnect USB-PD cable from Librem 5. If you need your Mobile connection you can leave this Librem 5 on (recommended without WiFi on, not to add some slightly higher heat), but if late evening you can turn it off as well (without disconnecting charging cable before red LED off).

Once red LED light off you need to disconnect USB-PD charging cable and have three options to power on your Librem 5 again:
−− short holding of power-on button (up to 4 seconds),
−− taking out of Librem 5 battery and putting it back again.
−− Third option should not be used when battery having full capacity.

Please use provided (original) power supply (high amperage one). Hope this helps as it is more about how you behave toward your Li-ion battery and not the other way around. Please power off when battery percentage under 30%, especially 20%, and not about to be used (just do something if not about to recharge Librem 5 battery soon again). Just avoid getting into same described scenario (as I see it) again.

I appreciate the thought you put into this response, but everything you suggested requires that the phone boots up (turns on), which is precisely what my phone isn’t doing.

How is this different from the recharging procedure that I linked in my original question, please? I’ve done the process a few times, each time waiting for the red light to go off. The last 2 times I noticed that the red light when off in under 10 minutes (I guess because I had already charged it fully). In each case I held the button down for a few seconds like the procedure indicates, but it still won’t boot.

1 Like

If you remove the battery and plug it in, will it then boot (ensuring your power supply can handle powering the phone first)?

1 Like

Are you Reburned Pure Operating System into L5? and still not power ON?

I’ve tried this a few times and, no, it won’t boot even after removing and replacing the battery.

I’m not sure what you mean by “Reburned”, but, no, it doesn’t power on.

Reinstall Pure OS.

I’m not sure how to reinstall Pure OS if the phone doesn’t boot up. Is there a way to do that?

To reinstall PureOS not need boot the phone just putting the L5 on serial mode.
Additionally there is a device that could easy to tell you why is not booting, this device is not released yet but for futures uses: Librem 14 compat USB-Cereal

I followed the steps to reflash (, but the sudo ./scripts/librem5-flash-image line returned a “command not found” error, which I expect is because the “librem5-flash-image” file doesn’t exist in the directory. There’s a file called “flash-image” which didn’t work either.

I meant leaving the battery out.

Yup… I tried this, too. But it appears that the cable and adapter that came with the phone don’t supply enough power for the phone to boot even with all of the kill switches turned to the down position (all transmitters off). When I try to turn the phone on with just power from the USB-PD and no battery I see the notification light as yellow or yellow flashing with red. Based on the LED Indicator Colors documentation this means that there’s insufficient power.

1 Like

Make sure that USB-PD cable is disconnected from this Librem 5 (and HKS sliders enabled, providing no power to the built-in cards).

If your Librem 5 is not powering on with what mentioned earlier, after battery fully charged:

I hope that holding power-on button for 20 seconds helps there, as at least this should help if this BPP-L503 battery still healthy and useful there:

Please do not lose your health if you cannot rely on this battery. This is the most important thought here, toward you from my side.