Librem Tunnel problem


#1

I have recently gone from wicd to network manager on my Debian Buster machine,
Xfce setup, and have a hard time getting the Librem Tunnel to work.
(I went to Network Manager, since VPN seemed much easier to setup using this).

Running

./local/bin/liberty tunnel-setup

works fine, and entering my username gusnan and password I get

“Librem One Tunnel successfully added to Network Manager”.

But then when I edit my Network Connection (which works fine without VPN),
and check the box for “Connect automatically to VPN” - “gusnan@librem.one US1”

I cannot connect to my connection, I get the animation when trying to connect,
and then it stops.

My syslog gives me this:

Jun 22 01:04:45 gusnan-thinkpad-x220i NetworkManager[598]: <info>  [1561158285.7397] vpn-connection[0x564f7e00c760,d3ac23cd-e487-41a7-b1d9-e96f9d4ead94,"gusnan@librem.one US1",0]: Started the VPN service, PID 13468
Jun 22 01:04:45 gusnan-thinkpad-x220i NetworkManager[598]: <info>  [1561158285.7517] vpn-connection[0x564f7e00c760,d3ac23cd-e487-41a7-b1d9-e96f9d4ead94,"gusnan@librem.one US1",0]: Saw the service appear; activating connection
Jun 22 01:04:45 gusnan-thinkpad-x220i NetworkManager[598]: <error> [1561158285.7821] vpn-connection[0x564f7e00c760,d3ac23cd-e487-41a7-b1d9-e96f9d4ead94,"gusnan@librem.one US1",0]: Failed to request VPN secrets #3: No agents were available for this request.

I am located in Europe (Sweden), if that makes any difference.

What is wrong? Am I missing installing some package?

(Complete Librem One bundle).


#2

I saw a question like this in Librem Chat (Support Room I think). If I remember right, when setting up the config, I think the person was told to use their username, not username@librem.one. I’m just using Tunnel on my iPhone, so no first hand knowledge configuring a computer to use it.

Hopefully one of the support team sees your question :slightly_smiling_face:. Or you could ask in the Matrix channel.

Good luck!


#3

Does the VPN connection appear int the VPN section of the GUI drop down? I have had issues with the auto-connect with wifi.


#4

It does - Together with a empty checkbox in the menu. (I don’t know what that is supposed to mean). It is also listed in the “Networks connections” window correctly under VPN, but to me it seems there’s a really small amount of settings. Even the “Export” button is shaded out and non-clickable.

Thanks for the tips regarding WiFi - I’ll will try using the VPN with a cabled connection, and report back.

[edit]Just tried with cabled connection, with the same result as with wireless[/edit]


#5

I am not running Debian but we worked through some issues here. There might be something that helps you there. I hope this helps.


#6

Just tried the VPN in a PureOS virtual machine, and it worked just fine. (But I would like to get it working on the above described type of system too).


#7

I am not sure what you mean " Together with a empty checkbox in the menu."
Is the “menu” the drop down from the top toolbar?
Is it an on/off toggle?
journalctl may help.
Do you have an .opvn file?
There are a few links that may help on the issue I linked. One of them is here where you can try to create a .opvn config file

Perhaps if you go the CLI route and try to create an .opvn config then you can get errors and go from there.
You may want to try the chat room for more support.


#8

Thanks - I have found that I didn’t have the network-manager-openvpn-gnome installed, and after installing this, I have quite a few more settings to play around with.

Now I might have more of a chance to make it work. Thanks for all your help.


#9

Still not getting anywhere - I get as far as I get a password dialog, but when entering my password I get the same dialog again, and again, and again…

As said, this is on Debian Buster using Xfce, and obviously Network manager - All this works just fine on a PureOS in Virtualbox, but on my Debian machine I have no luck.


#10

Sorry to hear you are still having issues. To be honest I am not sure where you are having the issues. “Password dialog”? Where? After doing what? If you give some more details or the steps you are taking, it may point to something.


#11

I have done the instructions on https://docs.puri.sm/Librem_One/PureOS/VPN_Tunnel.html - so the tunnel is added in my Network Manager, so I change the settings on my wireless connection, and select “Automatically connect to VPN” and select my added VPN (gusnan@librem.one US1) there.

After this, when connecting to this connection, I get the spinning icon for a while, and after this I get a dialog “Authenticate VPN”, “A password is required”.

Filling in my librem one password here, the dialog repeats again, and again, but I don’t get connected.


#12

I have not been able to get the checkbox to work. not sure why. If the VPN connects when you simply hit the slider on the drop down then things are working. I have seen some scripts where you set up a service to keep the vpn connected. Sorry don’t have an answer for you.


#13

It seems like the username and password is generated by the tunnel-setup script based on the username and password for Librem one I enter in the script - I tried again running it, now using the git version from source.puri.sm - Didn’t help. It doesn’t fill in the generated password, but does it correctly with the user name.

I believe in theory if I could get the password from my PureOS setup to my Buster laptop somehow, I would be good to go.


#14

DId you see this post above? Have you tried it?


#15

I have been using only username all the time, not username@librem.one.


#16

Hmm, do you also have nm-applet installed? Based on this link, it seems like that could help alleviate the problem of not using GNOME.

https://bugzilla.redhat.com/show_bug.cgi?id=1394977


#17

I cannot find nm-applet when trying to install it - What it is called in Debian? - But I don’t believe there’s a problem with Network Manager or related programs. To me it looks like the tunnel-setup command doesn’t work completely on my Debian machine -

On PureOS it works fine, asks for Librem One username and (long) password, and then processes this, and enters another username and password in the Network manager VPN settings (I can see that the entered username is a long hexadecimal number, while my librem one username simply is gusnan). I cannot view the password (Which I understand). On my Debian machine, when doing the same and run the script, it fills the same username as on PureOS, but doesn’t fill any password at all.


#18

Hmm, dang, it seems nm-applet is provided by network-manager-gnome. I guess you could try installing that and see what happens.


#19

I already have that installed.


#20

I’ve got it working! The tunnel-setup script that is used in the scripts didn’t fill out the VPN password correctly in Network Manager. There is one username and password for librem one (in my case my username is gusnan), and the tunnel-setup script asks for this, and generates another username and password for usage by the VPN in Network Manager. On PureOS both these generated username and password is entered in Network Manager correctly automatically by the script, but on my Debian Buster, when running the script, only the username got into NM’s VPN settings correctly (the password was entered empty, and I have tried filling this with my librem one password, which of course is not the one requested).

The script of course knows the password, so I simply modified it to also simply print the password to terminal, and entered it by hand in Network Managers VPN settings.

And this worked! :grinning:

Anyway, thanks to all of you who have tried to help.