Logging issue - how to enable USB debugging with Librem Mini v2

@jonathon.hall I am having a long running issue with my qubes install, it encounters a ‘boot freeze’ when two monitors are connected.

I first posted about it in the forums here

I have a github issue about it here

I am now trying to produce logs of this bug, but have been unable to do so as logs of my ‘bad boots’ are conveniently missing, here is my thread about this in the qubes forum

I’d like to try USB debugging to capture the issue as outlined here

However its my understanding that the Librem Mini v2 doesn’t support xHCI Debug Capability, is this true? If not could someone please let me know how I could go about getting USB debugging working ?

1 Like

@sienks Re: the root issue relating to boot freezes, have you tried updating PureBoot? In PureBoot 28, I fixed a graphics initialization issue with high-resolution displays that manifested similarly (PureBoot 28 - Upstreaming and Upscaling – Purism)

I’m not sure if your configuration will trigger this problem or not, but it’s worth trying before going further down the troubleshooting rabbit hole.

(And I did steer you toward Qubes in the first place, which was wrong if it is indeed this issue, sorry about that.)

No I think it should support this - although I’ve never tried it. In my sys-usb qube I see /sys/devices/pci0000:00/0000:00:06.0/dbc and it says disabled, so Linux seems to think it’s there. The SoC supports it, and FWIW I don’t see any other boards in coreboot doing anything in particular to enable it.

This seems pretty useful to get to the console without having to solder on a UART though, if it’s still not solved in the latest PureBoot we can work through this to see what’s going on. Adding kernel command line parameters is possible from the PureBoot recovery shell. (There’s no UI unfortunately, basically edit /tmp/config and add to CONFIG_BOOT_KERNEL_ADD, then use basic-autoboot.sh to boot the first boot option.)

1 Like

Thanks for your reply.

Updating Pureboot was one of the first things I did originally and the issue persisted.

I checked and found I was running Pureboot 27.1

I just updated to version 29 and the issue seems to have disappeared, in saying that I defiantly need more time and more boots to confirm the issue is truly gone as there have been times when the issue was intermittent.

Out of curiosity if I were to install Coreboot would this issue occur or was it specific to Pureboot?


Thanks for following up, I’m glad it seems to have been fixed. Please follow up again if the issue does come back.

The issue was specific to PureBoot. At that time, different graphics initialization was used in coreboot/SeaBIOS compared to PureBoot. (coreboot/SeaBIOS used the Intel video BIOS on Mini, PureBoot used Linux i915.)

Now though, they’ve both converged on the same graphics initialization - they both use coreboot libgfxinit on Mini and all of our laptops. So any future problems relating to graphics are probably not specific to PureBoot.

1 Like