Pureboot problem - Librem Mini v2

Hi,

I am currently running Qubes OS on a Librem Mini v2, it uses Pureboot.

Since purchase, when I boot the computer with two monitors connected the following will occur approx 90% of the time:

Once the following appears it just sits there stuck.

This will occur when using the Librem Key or booting without the Librem Key.

If I unplug one monitor and pass the initial boot screen (pictured) then plug the screen back in everything then functions normally.

I recently updated to the latest pureboot release: pureboot-librem_mini_v2-Release-27.1 and the issue still persists.

Is anyone else experiencing this issue ?

Thanks

@sienks Video is controlled by Qubes at this point, I’d suggest taking this to the Qubes forum. You might be able to type the disk unlock password “blind” and continue boot.

Qubes has the i915 driver in its initrd, so it initializes Intel graphics before the LUKS prompt is shown. The corruption you see happens as it is initializing i915. I see that too, but in my case the LUKS prompt always appears on one display (the others continue to show junk until the graphical environment is up).

I ran several tests on Mini v2 and L14 with multiple displays and could not find a situation where it failed to show the LUKS prompt. I did find some similar reports for Qubes, but nothing that I think directly applies to your situation:

Switching HDMI/DP cables will not help on Mini v2 because the HDMI port is internally provided by a Display Port-HDMI converter, the GPU always sees two DisplayPort connections.

1 Like

Sorry for the late reply.

Thankyou for taking the time to test & write such a detailed response I would have been clueless without this. As suggested Ill take this over to the Qubes forum.

Jonathon you mentioned you saw the ‘corruption’ but the LUK’s prompt always appears on one display.

I didn’t mention this because I didn’t think it made a difference but could a hardware KVM switch have any impact?
I use the following:

Link: 4 Port Dual Monitor KVM Switch Kit HDMI 4K60Hz with EDID HKS0802A1U – TESmart
Model: HKS0802A1U

I haven’t tested without the KVM switch yet.

Also, I also encountered this issue using a single screen, albeit only once.

Yes it’s possible the KVM switch could be related - just guessing, could relate to nuances of modeswitching or the switch’s EDID emulation. It’d be a good idea to try without the switch once.

1 Like

Hi Jonathan, you mentioned ‘I ran several tests on Mini v2 and L14’.

Did you run these tests with Qubes OS?

If so, were running the same hardware, the same software the only difference being our screens, mouse & keyboard. The difference being you didnt encounter this issue.

Yes, that was with Qubes on both devices.

1 Like