LUKS password prompt not appearing - Dual boot

I have recently installed Parabola on my second hard drive. I have managed to get everything set up and running well except one problem. After selecting Parabola in the Pureboot menu, it proceeds to start the kernel, but doesn’t display a prompt for the LUKS password. The last thing I see is []kexec_core: Starting new kernel.

I can still enter my LUKS password, and it will boot as normal to the desktop environment, but I cannot see the prompt.

If Parabola has any trouble booting, for example a systemd service that failed, Then it displays the previously completed password prompt, and the error message for the systemd service.

I am not sure if this is a Pureboot, or a Parabola problem…

Is there anyway to see this prompt originally without having to install something from the AUR such as Plymouth? I don’t want a fancy bootloader, just a text prompt would be fine.

I have tried playing around with mkinitcpio hooks and kernel parameter, both don’t seem to fix the problem.

A little information about how my system is set up:

Pureboot with HEADS to boot
Shared unencrypted /boot partition using grub on the main drive.
LUKS encrypted partition on main drive for PureOS.
LUKS encrypted partition on secondary drive for Parabola

hi, would you mind filling an issue here: https://source.puri.sm/pureos/packages/smartcard-key-luks/-/issues ?

1 Like

Thanks for your response. I have signed up for an account in order to file the issue, and am awaiting confirmation from the Gitlab administrator.

1 Like