MAC address changes each boot in PureOS?

I use MAC filtering on my home wifi router. At work I have to register with a specific MAC address to gain access to the WiFi network. I notice that the MAC address changes on my new Librem 15 on each reboot. Is this a feature that I can turn off?

This could be a hardware issue (or firmware, but I doubt you’d be the only one suffering from it).

Try the following workaround, assuming your network interface is eth0 and you use DHCP:

  • Open the file /etc/network/interfaces

  • Add the following content

    iface eth0 inet dhcp
    hwaddress ether 00:a0:c6:e3:b2:17
    auto eth0

Basically this changes the mac address of your network card, at a software level (here we are setting always the same address).

Thank you for taking the time to reply. I did find out how to fix it. Apparently it’s a default feature of NetworkManager which can be turned off:

The file is: /etc/NetworkManager/NetworkManager.conf

The entry to add is:


Thanks for the feedback about your solution :slight_smile: