Make bootable unit with dd?

Is there a reason I can’t make the boot usb stick with normal dd? I tried, but it didn’t boot. Seems strange to have to use some glitzy tool just to write a booter.

dd is byte-copy utility. If the image is bootable on the given media - dd can be used to transfer the image to the media (with caveat for cdr)

If the image is bootable on the given media

does this mean that the pureos install image may not be bootable on a usb stick?

Did you write the image to the main device like /dev/sdb or to a partition like /dev/sdb1 ?

In general USB bootable images have to be build in a specific way. I don’t remember how exactly how.

You have to use /dev/sdx and not /dev/sdx1

See this tutorial:

I have done it this way many times and it has always worked for me.

Those are peculiar instructions. If you mkfs then dd I presume dd will just overwrite the fs that was just installed.

Anyway I tried writing to three different devices with or without that “trick” mentioned in the article and the pureos usb still doesn’t boot.

In general USB bootable images have to be build in a specific way. I don’t remember how exactly how.

@prolog never had to do anything special to write a bootable image myself.

It isn’t a trick, disk image needs to be dd’d to disk, partition image to partition.
USB may have cd emulation boot mode (so it can boot from iso image) or normal UMS boot mode (so you need proper MBR/UEFI image). If you cannot boot live cd then either your bios does not support usb-cd-emulation or it’s not enabled there. If you cannot boot mbr image you uefi might have legacy boot mode disabled.

1 Like

You can also do it using the cp command, as described here:

cp debian.iso /dev/sdX

hello and welcome !

have you tried it like this and it hasn’t worked for you ?

sudo dd bs=4M if=/path/to/bootable-os.iso of=/dev/sd(insert-drive-letter-here) status=progress oflag=sync

i suppose the CLI has it’s appeal but from the GNOME environment you can use ‘Disks’ to make bootable usb devices with ‘restore-image’ from the menu on the top-right side of the GUI window. this method also works for making external usb connected SATA based SSDs bootable. i have not had issues with it so far.

@lash could it be that you are tying to install pure OS on a non Librem machine, and the actual problem is the UEFI mode of that machine?

the Librem-Mini machine comes with SeaBIOS + CoreBOOT (or PureBOOT/HEADS) not EfiBIOS that most proprietary motherboards from AMI do.

you can make a new GPT partition table under an unformated 512 MiB ‘bios-grub’ labeled partition and a second 512 MiB fat32 /bios partition on the Librem-Mini and it will install PureOS just fine.

this sounds like a good clue. Thanks, I will try this.

If not, is there an emulation option with the correct setup that I can use to have a look around? Like qemu for example?

what do you hope QEMU will accomplish for you ?

Ah yes <-

@reC just wanna have a look at the OS is all :slight_smile:

So my guess was correct that you were trying to boot pure OS on a non librem hardware, and that didn’t work but other linux OS which contain an EFI boot shim were working?


dunno yet

At least know more about what the problem is now. Thanks, guys.

By the way I tried that flash app image tool and it failed. Cant remember if it was segfault or missing so.

The dd comand by @reC

works with images just tried it with a raspberry pi image since i needed a new installation after ruining the old one.
so it should also work with pure os on an USB stick.
just to make sure you don’t have faulty image did you check the checksum against the one provided by purism. I’ve always had good results with etcher no mater which base os