Mic Picks Up Only Static?

I never had reason to use the Mic on this computer until recently. I just tested it on several pieces of software. it only picks up static.

The sound settings show the software that is recording audio. The hardware switch is set to on. Yet it only picks up static?

Please advise.

1 Like

i’ve been struggling with this a bit also. I haven’t necessarily solved it but here are a few things I’ve tried:

  • I’m assuming you are running PureOS. If so, make sure you have the latest update. The recent update that updated the kernel to 4.19.0 (or something) made a big difference in my display. It might help with other hardware.

  • Then check your Sound settings on the gnome settings. I noticed the default setting was a low mic volume (under Input). When I increased the volume, so people could hear me on a video call, is when I noticed the static kick in. I realized I would have to find a happy balance between static and people being able to hear me.

  • I noticed the mic was worse with skype than with MS Teams. So, some apps may have better noise canceling also.

  • I mention noise canceling because I do wonder if the noise you are hearing is static or the mic is actually picking up background noise from the fan for instance. So, you might try doing some tests where the machine is in a cooler setting so the fan doesn’t kick in and see if that helps.

Basically, the mic does seem to be a problem on my 15v4 running pureOS. So, it might be the drivers with pureOS, etc.

I haven’t found a true solution yet.

1 Like

My computer (Librem13v2) does the same (only static from the microphone).
I’ve contacted customer support on this.
On my computer, the camera works, but the microphone does not.
There has been a previous thread on a similar-sounding failure:

In that person’s case, it may have been a loose or broken wire. The microphone is behind a tiny pinhole to the left of the camera, so the microphone wires have to go through the laptop’s hinge.

1 Like

Things I’ve tried:

  • Updating the OS.

  • Adjusting the mic sound settings (all ranges).

  • Plugging in a headphones/mic, testing the mic piped through the headphone jack.

  • Repeating with another mic.

  • Repeating all tests with the mic hardware switch on and off.

  • Repeating the tests in another OS inside a Boxes VM.

I’ve tested in several programs that record audio.

Nothing changes. Nothing. Just static on all tests.

I need to be able to make VOIP calls. This is a pretty big deal breaker.

1 Like

the Librem Laptops only have a headphone jack there is no microphone routed thru that 3.5mm jack mybe the advice from this topic might help you out.

1 Like

When you toggle the hardware kill switch for microphone/camera, is camera going on and off without issues?

The camera works without issues. The hardware switch seems to be working.

UPDATE: A USB mic works. The internal mic, still just static.

Thanks for all of your testing and feedback @Emily! This is really helpful. I haven’t thought of trying an external mic / webcam. I’ll give that a try.

Hi @Emily, thanks for sharing your experience. I face the same issue with my Librem 15v3 and I am considering buying an external mic. May I ask which one did you go for? Is it working fine with your Librem, which version do you have? Are you using PureOS? Was the setup easy? Is it good for speech and not picking the sound from the speakers, i.e. is it a directional microphone?

On my Librem13v2, I’ve used the cheapest available analog-to-digital converter (“Plugable USB Audio Adapter”, $24), which I had lying around at home for years, the Røde Videomicro microphone ($80, from the camera shop a couple of blocks from my house), and a nineteensixties or seventies-era Soviet mount, which I also had lying around at home for years. Basically, I scrounged together whatever happened to be available locally under quarantine conditions.
The microphone was plug-and-play in PureOS. The only user intervention required was to go to Settings (accessed by the hidden menu under the triangle at the top right corner of the screen, look for the crossed wrench and screwdriver), then navigate to:
Sound –> Input –> Choose Device
and click on the option for an external USB device, and adjust the volume accordingly.
Sound quality is better than what you get from a laptop internal microphone, but not ideal. For good sound quality you’re looking at several hundred dollars to a few thousand dollars, or finding second-hand equipment.
The Røde is more than good enough for videoconferencing.
It’s a directional microphone (caridoid pattern), but as far as I know, the main way sound from the speakers is excluded is through software. Of course, if you’re the only person at your computer, a better solution is to use headphones instead of speakers.
There’s another recent thread on this topic, here.

1 Like

I simply tested with a USB mic. I think any mic using the USB port would likely work.

i’m till hopeful there is a fix for the internal mic, as hauling another peripheral around will be a pain.

1 Like

I’m overseas. There’s no way I’ll be able to get this serviced anytime soon.

I really need to get this mic working.

Any others had this problem? And did you find a solution?

Just to be clear here. You have contacted support with no solution to this most basic of functions?

Same problem here. After endlessly futzing with it, I gave up and ordered a headset and a USB to TRRS adapter / sound card.

The strange thing is that the system sound settings or pavucontrol (Pulse Audio Control Center) show microphone activity correctly in the little red indicator bar. However the microphone only records static.

The strange thing is that the system sound settings or pavucontrol (Pulse Audio Control Center) show microphone activity correctly in the little red indicator bar. However the microphone only records static.

Not so strange at all. I think the problem is usually either a miswired mic (see the other thread on this topic) or a disconnected or broken wire. None of these things would be automatically detected by software.

@Brad: My Librem was out of warranty, and the impression I got from support is that it’s complicated enough to diagnose and repair that they didn’t want to guide a customer through a home repair. I decided I could live with a nonfunctional internal mic.

They offered a viable solution. Backlogs on supply chains are the current constraint to getting it implemented.