Millipixels doesn't see camera

I recently updated my librem 5 to run kernel 5.15.9pureos1, and other packages (install millipixels, and remove megapixels for example). However, after the reboot, millipixels doesn’t seem to see the camera, giving “Selected camera is not available. Is it turned on?”

Digging more I found that uname lists 5.13. Now I understand that doesn’t show the current kernel version on a librem 5. However, based on prior kernels it seemed the that uname kept the first two numbers but not the last. So could it still be trying to boot the old kernel?

I do see linux-image-5.15.0-1-librem5 at 5.15.9pureos1 and is installed.

Yes, the camera switch is in the on position and the gui shows that they it is not disabled.


Camera(milli*) still not work reliable on 5.15.9 so you need to wait till Linux 5.16 or 5.15.12 for camera.


I think that’s the thing. You could check if you have all the files in /boot. There should be a couple old backup kernels present.

uname never lied to me, so I recommend trusting it regarding the currently booted kernel.

1 Like

Same problem here. Apparently the system is up to date but:
uname -a: Linux pureos 5.13.0-1-librem5
apt list linux-image-librem5: byzantium 5.15.9pureos1 arm64
and the /boot folder contains:


launching an apt full-upgrade has no effect

1 Like

Please try following before executing apt full-upgrade:
sudo apt update
sudo apt list linux-image-librem5 -a
sudo apt install linux-image-librem5 or sudo apt upgrade linux-image-librem5 even sudo apt reinstall linux-image-librem5
sudo apt full-upgrade
sudo apt autoremove
sudo reboot as mandatory, as already mentioned elsewhere.

If necessary (I doubt, not sure): sudo apt install millipixels.

Edit: just by doing/repeating:
sudo apt update
sudo apt upgrade
sudo reboot
you’ll reach current/desired finish line/state as well, I hope.


read this topic for the solution:

Presumably intended to be sudo reboot
(in two places).

1 Like

Of course. Just edited my post. Thanks a lot! Sorry, just way to many copy/paste from my side, corrected now thanks to you.

1 Like

Thank you. New kernel is running now. Something must have gone wrong during my previous update process … is, for some reason, sudo reboot different from a simple restart from GUI?

1 Like

I’m accustomed to sudo reboot therefore cannot compare, but something else like to share (find out) here: when you’d like to turn off your Librem 5 for some longer time (even overnight) please execute: sudo shutdown -hF now, as this command might make difference in preserving BPP-L503, Evergreen one, battery life significantly (hopefully). Would like to hear about your finding (if you have time for this, here related shutdown, test/testing proposal), please.

Sure, I’ll make some test, but honestly my battery doesn’t discharge much overnight, if that’s what you mean, 1-2% I guess. I need to pay more attention to this. I’ll let you know.

1 Like

That fixed it thanks,
I’m seeing issues with charging now for some reason. I’ll create a new post when I’ve characterized it better.

1 Like

@steve and @fiacco, yesterday I was doing some cleaning (making some more space) on my laptop and in parallel came up with this one (please take a look if old Linux Kernel still there):
sudo dpkg --list | grep linux-image
sudo apt-get --purge remove linux-image-5.13.0-1-librem5
uname -mrso

Currently it does not save photos for me. Do people have the same issue?

Is there anything in the logs?

After switching to selfie and back to the main camera it works. Did not thought to check the selfie. Once I checked the selfie worked and back to the main it works. Maybe something was set wrong from the previous megapixels and needed the toggle.

I did many tests. I didn’t notice any differences on battery life, both sudo shutdown and Power Off (GUI) lead to a loss of charge around 1% in 9 hours. They are the same.

1 Like

Many thanks! 1% … is indeed not much … Meaning, even to boot up a Linux system again Librem 5 battery needs to release some of its well stored “juice”.