Missing MMS Settings?

I just got Chatty 0.60 on my Pinephone Mobian Phosh – it has MMS. I have Mint Mobile (USA MVNO). I put in the published settings… well, the ones that were available on the Chatty settings form. There was no place to add MNC, MCC or MMS Port.

Has anyone gotten MMS to work on Mint Mobile?


OK… How about this? Since Chatty doesn’t allow the user to see or modify these values, does anyone know how to change them manually? MMCLI didn’t offer any obvious answers.

The MMS settings are in this file: ~/.mms/modemmanager/mms

Open it and look what you have there now, I think it is probably some default values. The ones you need to set are the following three (here are my settings that work for me, probably you will need different values):


The third one there, CarrierMMSProxy, may or may not be needed, I think some providers do not use any proxy, but it is needed in my case. The first two I think are always needed. There are also some other settings in that file, I think it’s fine to leave the rest at the default values.

Strictly speaking I think these are not chatty settings but mmsd settings, it is mmsd that uses that file. MMS is handled through a collaboration of three parts: ModemManager, Chatty and mmsd.

Regarding the possibility of configuring things via GUI, as far as I know that part is not working yet. When people (myself included) say that “MMS works now” what is meant is that it works after entering settings manually.

Here is an open issue about these things:

1 Like

Fascinating. The GUI does work, at least on Mobian, because the values I set in the GUI are in the mms file. Unfortunately, MNC, MCC and MMS Port – required by Mint Mobile – are not.

It’s late. I’ll follow your link and and try to add those variables tomorrow. :sleeping:

1 Like

I am actually using a prepaid mint sim card to play around and tinker with with my Librem 5, I also could not get MMS working, so if you find a solution I am interested. Eventually I hope to make my LIbrem 5 my daily driver which will likely run on a T-Mobile sim card. MMS is a big sticking point for me, Librem 5 has other things that could use improvement, but having no MMS for now makes it a non-starter as a daily driver for me personally.

1 Like

I added your info to the wiki: https://source.puri.sm/Librem5/community-wiki/-/wikis/Cellular-Providers

I am not using Mint Mobile, nor have I managed to get MMS working. However, I noticed that, if I say I have an iPhone when I am asking for MMS settings, my MVNO gives me the port number as part of the proxy address, whereas it gives the same port as the separate ‘MMS port’ field if I ask for settings for an Android phone. So, I figured Chatty probably wanted the proxy in the iPhone format with the MMS port number appended, such as: mms.example.com:1234.

I don’t know if this format is a valid configuration for mmsd, but it was accepted by the GUI and ended up in the configuration file. Idly I wonder: does anyone know where the configuration file format is documented? The mmsdtng man page is not much help.

The source code?

As another data point I’m not able to get MMS to work on a prepaid T-Mobile SIM, so it may not be related to the settings available in Chatty. According to T-Mobile’s BYOD APN configuration page the settings should be as follows:

APN: epc.tmobile.com
MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc

Since the other URLs on that page use t-mobile.com (with a hyphen) instead of tmobile.com I’ve tried adding the hyphen too, but that didn’t help. I’ve also tried clearing out ~/.mms without any luck either.

Perhaps this is elementary, but did you subsequently reestablish a cell connection? On my calyx phone I had to reboot to get MMS working after adjusting those settings (Mint mobile, a T-Mobile MVNO).

1 Like

I think so, I was able to make calls and send SMS messages. I may experiment with rebooting too.

For me, the following format is working, I have this line in my ~/.mms/modemmanager/mms file:


Might be worth trying to write the IP address instead of mms.example.com.

Note also that for MMS to work you need to have a mobile data connection working, so check that separately first. And I think the MMS_APN needs to be the same as the APN used for the mobile data connection.

In my case, the MMS_APN in the ~/.mms/modemmanager/mms file is as follows:


and the apn line in the file for my mobile connection (in the /etc/NetworkManager/system-connections/ directory) looks as follows:


So both of them are set to “internet.tele2.se” and I think mmsd is explicitly checking that they are identical. If your provider requires a different APN for MMS compared to the APN for mobile Internet connection, then I think it will not work. Something more needs implementing in ModemManager and/ormmsd to make things work with multiple APNs.

Here is an issue about the case when the APNs are different:

To summarize:

  • Try ip-address:port-number format for CarrierMMSProxy
  • Check that mobile data connection is working first, because mmsd needs it
  • Check that your MMS_APN is the same as the APN used for your mobile data connection
1 Like

Same here. Hopefully it’ll be the easy fix.

Got it working. Steps:

  • Create a new APN in Settings > Mobile Network with the following configuration:
    • Name: T-Mobile
      APN: fast.t-mobile.com
    • Note: epc.t-mobile.com also works for the APN
  • Ensure “Mobile Data” is toggled ON and confirm that you have a data connection (e.g. by turning off wifi and loading a new web page)
  • Go to Chatty > Preferences > SMS and MMS Settings and enter the following config:
    • MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc
      APN: fast.t-mobile.com
    • Note: this must be the same APN as you’re using in Settings
  • Apply

With this I’m able to send and receive MMS messages.


:boom: :man_dancing: You ROCK! That worked great on PP Mobian/Phosh on Mint Mobile (a T-Mobile MVNO) using Mint settings. I can barely wait for my L5!


I am using Mint Mobile with my Librem5 and was able to get MMS (picture messages and group messages) to work by doing this:

In Chatty, go to Preferences - SMS and MMS settings:

MMSC: http://wholesale.mmsmvno.com/mms/wapenc
APN: Wholesale

I don’t know if it is necessary but I have also added an Access Point Name in my phone Settings - Mobile - Access Point Names. Name=Mint and APN=Wholesale

It took me a while to get this to work and in the end I think what was needed after applying these settings was rebooting the phone.

1 Like

I have switched SIMs from AWESIM to another provider (so i can make international calls), and updated correct settings directly in: ~/.mms/modemmanager/mms, however when opening chatty the SMS and MMS Setting are greyed out and show as invalid:

MMS Carrier Settings:

Cannot be edited.
Are not showing the correct values identified in mms settings file. Is there another Chatty configuration file so you can force these to be adopted?

It appears to erroneously lookp up MMS settings based on APN in my case “RESELLER” in the USA (based on AT&T backbone), and if it does not get a match shows MMS settings as not valid and doesn’t even allow editing in Chatty settings, this seems like a BUG. Those APN MMS settings are basically the same as AT&T.

FYI: mobile data works fine, text SMS can be sent and received, just not MMS due to invalid settings.

You could try simply removing the ~/.mms/modemmanager/mms file (or move it somewhere so you have a backup of it), then reboot, then chatty should create a new file from scratch. I think chatty will then try to pick initial settings from the mobile-broadband-provider-info package, see https://gitlab.gnome.org/GNOME/mobile-broadband-provider-info (if you feel inspired you can contribute a patch to that package to help making settings correct for your carrier, then users will not have to edit settings manually).

After the ~/.mms/modemmanager/mms file has been recreated it should hopefully have the format that chatty expects, because then chatty itself has created the file. Then after that you could add your desired settings again either within chatty or by editing the new file.

Thanks, actually that folder and mms doesn’t exist anymore (when i did trouble shooting i probably nuked it trying what you said, but maybe getting rid of too much), happen to know where I can find a baseline template? It doesn’t seem to re-create the folder automatically on chatty re-install.

Hm, it does recreate it for me. I tested this half an hour ago, before my previous reply here, then I removed the ~/.mms directory and rebooted, and after reboot the directory had been recreated.

I don’t know exactly what triggers it to recreate it, but maybe reinstall is not enough, you need a reboot?