MMS support Telia Sweden?

I am trying to get MMS to work in Chatty with Telia/Sweden, but with no luck. I have entered the below settings in Chatty, but it still doesn’t work.

Anything else I could try?

These are the suggested settings on Telia’s homepage:
For Android:

Name: Telia MMS
User name: mms
Password: telia
MMSC: http://mmss/
MMS-port: 8080 (Will also work with Port:80)
MCC: 240
MNC: 01
Verification/Authentication type: PAP
APN type: mms

For iPhone:

User name: Leave empty
Password: Leave empty
MMSC: http://mmss/
MMS-max size: 307200
MMS UA Prof URL: Leave empty

If you go to your modem settings what does the apn show? (gnome settings->modem->Access Point Names).

If the APN differs from what’s in chatty try the current APN that’s in your modem settings.

If that doesn’t work can you post the output of journalctl -f | grep mmsd-tng while trying to send an mms message(try a picture or some file).

If you mean gnome-settings->mobile->Access Point Names, it looks like the following.

and inside “Telia 3G” (Don’t ask me why it is called 3G, but that has been the default before I started to add and try new ones)

Problem is that all MMS settings are not available in Chatty nor gnome-settings. Also, the problem sending and MMS for me is that there is no paper clip beside the text input field, so I can’t chose any picture or file.

Yes that’s wher I ment,
Try setting the APN in chatty’s mms settings to “Telia 3G”. It may you will need to wait for multiple APN support before it works as well.

Oh, I see. Will try that out.

dec 14 12:42:35 pureos mmsdtng[1351]: mmsd-tng[1351]: Could not find settings: Operator ID '24001' not found in service provider database
dec 14 12:42:35 pureos mmsdtng[1351]: mmsd-tng[1351]: Your MMS settings are not in the database! Please file a merge request at so they can be added
dec 14 12:42:35 pureos mmsd-tng[1351]: Could not find settings: Operator ID '24001' not found in service provider database
dec 14 12:42:35 pureos mmsd-tng[1351]: Your MMS settings are not in the database! Please file a merge request at so they can be added

This is what I found on Telia Sweden in


		<!-- -->
		<apn value="">
			<plan type="postpaid"/>
			<usage type="internet"/>
			<name>Telia 3G</name>

It seems like indeed information like

	<apn value="">
			<usage type="mms"/>

is missing for Telia.

Interesting, ok.
You could try filing a bug report at the mentioned url asking for telia to be added.

Not sure what else you can do.

After the latest update to chatty, it seems I can put whatever I want in the Chatty MMS settings and still get the paper clip to attach an image. I have been trying different gnome-settings modem APNs, but only get the following errors in journalctl:

dec 14 14:25:08 pureos mmsdtng[1351]: mmsd-tng[1351]: ../plugins/modemmanager.c:set_context() Current Context APN:, mmsd-tng settings MMS APN:
dec 14 14:25:08 pureos mmsdtng[1351]: mmsd-tng[1351]: ../plugins/modemmanager.c:set_context() The modem is not connected to the correct APN!
dec 14 14:25:08 pureos mmsdtng[1351]: mmsd-tng[1351]: ../plugins/modemmanager.c:bearer_handler() Set MMSC: http://mmss/, Set Proxy:, Set MMS APN:

Ok, this is really weird!
Here are my settings, that finally made it work:

chatty settings

However, chatty settings seem to clear the proxy setting every time the modem is restarted (which I do by toggling the kill switch). The proxy setting should be

1 Like

Also, the mms received ended up in a group conversation with me, my phone number and the other person :smiley: not in our regular chat.

Maybe this issue:

Yes, looks like the same issue.

I also got MMS to work with a Telia SIM card now, but as you showed above that seems to require setting the APN to “” for both MMS and for the regular mobile data connection. Then MMS works, but for me mobile data does not work anymore then. I mean, it works in the way that MMS messages are clearly fetched using that connection, but it no longer works for general Internet access.

Perhaps Telia only allow MMS-related network traffic using the “” APN. If that’s the case, then we need to make things work with two different APNs, “” for mobile data and at the same time “” for MMS.

So we need things to work with multiple APNs,ere is an issue about that:

I have tried a “Comviq kontant” SIM card also, and in that case things work better because in that case the MMS APN is the same as the regular mobile data connection APN, both are “”. So in that case MMS can work together with the mobile data connection.

Not completely sure here, but I think I have both mobile data and mms working simultaneously with the settings above. The chatty proxy setting gets cleared upon a modem restart though, and I think I had to toggle mobile data off/on to get it to work with the APN. However, that is not much different from with the other APN selected. Oftentimes, after leaving a wifi network, the phone pretends to be connected but won’t fetch any e-mails etc. until after a mobile data toggle. Librem5’s internet connection is not reliable for me, even when it says it is connected…

What about if you turn off WiFi using the kill switch, then try to use the web browser – does that work when you are using the “” APN?
I think it will not work.
If that does work for you, I have to try again and see what went wrong for me.

Atm no, but I am pretty sure it worked at one point. Anyhow, the indicator reports mobile 4G connectivity either way, which is wrong if mobile data is not working.

Hack it into the file yourself?

Per giving the directory, and the file to be edited is seemingly serviceproviders.xml - until a fix comes through from upstream?

1 Like

It turns out this info is in fact in /usr/share/mobile-broadband-provider-info/apns-conf.xml

<apn carrier="Telia MMS" mcc="240" mnc="01" apn="" mmsc="http://mmss/" mmsproxy="" mmsport="80">
<apn carrier="Telia 3G" mcc="240" mnc="01" apn="" type="default,supl"/>

So, question is, why isn’t Telia MMS settings used by Chatty automatically?

… and why is the info potentially in both files?